]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
- up to 2.0.0
[packages/doomsday.git] / doomsday.spec
1 Summary:        jDoom, jHeretic and jHexen for Linux
2 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
3 Name:           doomsday
4 Version:        2.0.0
5 Release:        1
6 License:        GPL v2 / CC 3.0 (icons)
7 Group:          Applications/Games
8 Source0:        http://downloads.sourceforge.net/deng/%{name}-%{version}.tar.gz
9 # Source0-md5:  add8b4b70878aa9d98b8bb9a6502882b
10 Source1:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
11 # Source1-md5:  b7b7a9389eba56679e5db65d95c06803
12 Source2:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
13 # Source2-md5:  573845e6e747f68617ac67f3a87dc78e
14 Source3:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
15 # Source3-md5:  c89e36c49eabe2846137f313a5250308
16 Source4:        %{name}-doom.desktop
17 Source5:        %{name}-heretic.desktop
18 Source6:        %{name}-hexen.desktop
19 URL:            http://www.dengine.net/
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  Qt5Core-devel
22 BuildRequires:  Qt5Network-devel
23 BuildRequires:  Qt5OpenGL-devel
24 BuildRequires:  Qt5OpenGLExtensions-devel
25 BuildRequires:  Qt5X11Extras-devel
26 BuildRequires:  SDL2-devel
27 BuildRequires:  SDL2_mixer-devel
28 BuildRequires:  assimp-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  ncurses-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  python
34 BuildRequires:  python-modules
35 BuildRequires:  qt5-build
36 BuildRequires:  qt5-qmake
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.595
39 BuildRequires:  xorg-lib-libXrandr-devel
40 Requires(post): /sbin/ldconfig
41 Requires:       TiMidity++
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The Doomsday Engine allows you to play the classic first-person
46 shooters DOOM, Heretic, and Hexen using modern technology, with
47 hardware accelerated 3D graphics, surround sound and much more.
48
49 %description -l pl.UTF-8
50 jDoom, jHeretic i jHexen dla Linuksa.
51
52 %prep
53 %setup -q
54
55 %build
56 install -d doomsday/_build
57 cd doomsday/_build
58 %{cmake} ..
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man6}
64
65 %{__make} -C doomsday/_build install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 # no -devel package. cleanup
69 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so
70 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}
71 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/cmake
72
73 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
74 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
75 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
76 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
77
78 cp -p %{_sourcedir}/%{name}-doom.desktop $RPM_BUILD_ROOT%{_desktopdir}
79 cp -p %{_sourcedir}/%{name}-hexen.desktop $RPM_BUILD_ROOT%{_desktopdir}
80 cp -p %{_sourcedir}/%{name}-heretic.desktop $RPM_BUILD_ROOT%{_desktopdir}
81
82 cp -p doomsday/doc/output/*.6 $RPM_BUILD_ROOT%{_mandir}/man6
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post
88 /sbin/ldconfig
89 %banner -o -e %{name} <<-EOF
90 To run doomsday you need some WAD file: either freedoom package
91 or some shareware or commercial WAD from Doom or Heretic:
92 Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
93 Heretic.wad or Heretic1.wad.
94 When you have them, run doomsday with:
95 doomsday -game [ jdoom | jheretic | jhexen ]
96 EOF
97
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 #%doc doomsday/build/README
103 %attr(755,root,root) %{_bindir}/doomsday
104 %attr(755,root,root) %{_bindir}/doomsday-2.0.0
105 %attr(755,root,root) %{_bindir}/doomsdayscript
106 %attr(755,root,root) %{_bindir}/doomsdayscript-2.0.0
107 %attr(755,root,root) %{_bindir}/doomsday-server
108 %attr(755,root,root) %{_bindir}/doomsday-server-2.0.0
109 %attr(755,root,root) %{_bindir}/doomsday-shell
110 %attr(755,root,root) %{_bindir}/doomsday-shell-2.0.0
111 %attr(755,root,root) %{_bindir}/doomsday-shell-text
112 %attr(755,root,root) %{_bindir}/doomsday-shell-text-2.0.0
113 %attr(755,root,root) %{_bindir}/md2tool
114 %attr(755,root,root) %{_bindir}/savegametool
115 %attr(755,root,root) %{_bindir}/savegametool-2.0.0
116 %attr(755,root,root) %{_bindir}/texc
117 %attr(755,root,root) %{_bindir}/wadtool
118
119 %attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2.0
121 %attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.2.0
123 %attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.2.0
125 %attr(755,root,root) %{_libdir}/libdeng_gamefw.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libdeng_gamefw.so.2.0
127 %attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.2.0
129 %attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.2.0
131 %attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.2.0
133
134 %{_libdir}/doomsday
135 %{_datadir}/doomsday
136 %{_desktopdir}/*.desktop
137 %{_pixmapsdir}/*.png
138 %{_mandir}/man6/*
This page took 0.063559 seconds and 3 git commands to generate.