]> git.pld-linux.org Git - packages/dokuwiki-plugin-data.git/blob - dokuwiki-plugin-data.spec
- add <span class="sep"> to table lists as well
[packages/dokuwiki-plugin-data.git] / dokuwiki-plugin-data.spec
1 %define         plugin          data
2 Summary:        DokuWiki Structured Data Plugin
3 Name:           dokuwiki-plugin-%{plugin}
4 Version:        20100125
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://download.github.com/splitbrain-dokuwiki-plugin-data-1e1e56a.zip
9 # Source0-md5:  2f1fbc2c8c88e846d5fd52c8500c0294
10 URL:            http://wiki.splitbrain.org/plugin:data
11 Patch0:         interwiki.patch
12 Patch1:         helper-map.patch
13 Patch2:         separator-style.patch
14 BuildRequires:  rpmbuild(macros) >= 1.520
15 Requires:       dokuwiki >= 20090214b-5
16 Requires:       php(sqlite)
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         dokuconf        /etc/webapps/dokuwiki
21 %define         dokudir         /usr/share/dokuwiki
22 %define         cachedir        /var/lib/dokuwiki/cache
23 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
24 %define         find_lang       %{_usrlibrpm}/dokuwiki-find-lang.sh %{buildroot}
25
26 %description
27 This plugin allows you to add structured data to any DokuWiki page.
28 Think about this data as additional named attributes. Those attributes
29 can then be queried and aggregated. The plugin is similar to what was
30 done here for the repository plugin but its internals are very
31 different to the repository plugin.
32
33 %prep
34 %setup -qc -n %{plugin}
35 mv splitbrain-dokuwiki-plugin-data-*/* .
36 %patch0 -p1
37 %patch1 -p1
38 %patch2 -p1
39
40 version=$(awk '/date/{print $2}' plugin.info.txt)
41 if [ $(echo "$version" | tr -d -) != %{version} ]; then
42         : %%{version} mismatch
43         exit 1
44 fi
45
46 # cleanup backups after patching
47 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{plugindir},%{cachedir}}
52 cp -a . $RPM_BUILD_ROOT%{plugindir}
53
54 touch $RPM_BUILD_ROOT%{cachedir}/dataplugin.sqlite
55
56 # find locales
57 %find_lang %{name}.lang
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 # force css cache refresh
64 if [ -f %{dokuconf}/local.php ]; then
65         touch %{dokuconf}/local.php
66 fi
67
68 %files -f %{name}.lang
69 %defattr(644,root,root,755)
70 %dir %{plugindir}
71 %{plugindir}/syntax
72 %{plugindir}/*.php
73 %{plugindir}/*.txt
74 %{plugindir}/*.css
75 %{plugindir}/*.sql
76 %attr(660,http,http) %ghost %{cachedir}/dataplugin.sqlite
This page took 0.05958 seconds and 4 git commands to generate.