]> git.pld-linux.org Git - packages/dhcpcd.git/blob - dhcpcd.spec
- fixed invalid /etc/dhcpcd path
[packages/dhcpcd.git] / dhcpcd.spec
1 %define ver     1.3.22-pl1
2 Summary:        DHCP Client Daemon
3 Summary(de):    DHCPC-Dämon
4 Summary(es):    Servidor DHCPC
5 Summary(fr):    Démon DHCPC
6 Summary(pl):    Klient (daemon) DHCP
7 Summary(pt_BR): Servidor DHCPC
8 Summary(tr):    DHCPC sunucu süreçi (daemon)
9 Name:           dhcpcd
10 Version:        %(echo %{ver} | sed -e "s#-##")
11 Release:        13
12 License:        GPL v2
13 Vendor:         Sergei Viznyuk <sv@phystech.com>
14 Group:          Networking/Daemons
15 Source0:        http://www.phystech.com/ftp/%{name}-%{ver}.tar.gz
16 Patch0:         %{name}-configure.patch
17 Patch1:         %{name}-ntpdrift-66136.patch
18 Patch2:         %{name}-noMoFakery.patch
19 Patch3:         %{name}-noNISfakery.patch
20 Patch4:         %{name}-pid_path_fix.patch
21 Patch5:         %{name}-other_path_fix.patch
22 BuildRequires:  automake
23 BuildRequires:  autoconf
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define _sbindir        /sbin
27
28 %description
29 dhcpcd is an implementation of the DHCP client specified in
30 draft-ietf-dhc-dhcp-09 (when -r option is not specified) and RFC1541
31 (when -r option is specified).
32
33 It gets the host information (IP address, netmask, broadcast address,
34 etc.) from a DHCP server and configures the network interface of the
35 machine on which it is running. It also tries to renew the lease time
36 according to RFC1541 or draft-ietf-dhc-dhcp-09.
37
38 %description -l de
39 dhcpcd ist eine Implementierung des DHCP-Client, spezifiziert in
40 draft-ietf-dhc-dhcp-09 (wenn -r option nicht angegeben) und RFC1541
41 (wenn -r option angegeben).
42
43 Es bezieht die Host-Infos (IP-Adresse, Netmask, Broadcast-Adresse,
44 usw.) von einem DHCP-Server und konfiguriert die Netzschnittstelle des
45 Computers, auf dem es läuft Es versucht, die Verleihzeit gemäß RFC1541
46 bzw. draft-ietf-dhc-dhcp-09 zu verlängern.
47
48 %description -l es
49 dhcpcd es una implementación del cliente DHCP especificado en
50 draft-ietf-dhc-dhcp-09 (cuando la opción -r no está especificada) y
51 RFC1541 (cuando la opción -r está especificada). Captura la
52 información del host (dirección IP, máscara de red, dirección de
53 broadcast, etc.) de un servidor DHCP y configura la interface de red
54 de la máquina donde esté ejecutando. También intenta renovar el tiempo
55 de alquiler de los direcciones de acuerdo con RFC1541 o
56 draft-ietf-dhc-dhcp-09.
57
58 %description -l fr
59 dhcpcd est une implantation du client DHCP spécifié dans les
60 draft-ietf-dhc-dhcp-09 (sans l'option -r) et RFC1541 (avec l'option -r).
61
62 Il obtient l'information sur l'hôte (adresse IP, masque réseau,
63 adresse de diffusion, etc.) à partir d'un serveur DHCP et configure
64 l'interface réseau de la machine sur laquelle il tourne. Il essaie
65 aussi de renouveler le « lease time » selon les RFC1541 ou
66 draft-ietf-dhc-dhcp-09.
67
68 %description -l pl
69 dhcpd jest implementacja klienta DHCP, opisan± w
70 draft-ietf-dhc-dhcp-09 (kiedy nie podaje siê opcji -r) oraz RFC1544
71 (kiedy podaje siê opcjê -r).
72
73 Pobiera on informacjê o komputerze (adres IP, maska sieci, adres
74 rozg³oszeniowy itd.) i konfiguruje interfejs sieciowy maszyny, na
75 której jest uruchomiony. Próbuje równie¿ od¶wiezyæ czas przestoju
76 zgodnie z RFC1541 oraz draft-ietf-dhc-dhcp-09.
77
78 %description -l pt_BR
79 dhcpcd é uma implementação do cliente DHCP especificado em
80 draft-ietf-dhc-dhcp-09 (quando a opção -r não é especificada) e
81 RFC1541 (quando a opção -r é especificada). Ele captura a informação
82 do host (endereço IP, máscara de rede, endereço de broadcast, etc.) de
83 um servidor DHCP e configura a interface de rede da máquina em que
84 está rodando. Ele também tenta renovar o tempo de aluguel dos
85 endereços de acordo com RFC1541 ou draft-ietf-dhc-dhcp-09.
86
87 %description -l tr
88 Makina bilgilerini (IP adresi, að maskesi, yayýn adresi, vb.) bir DHCP
89 sunucusundan alýr ve üzerinde çalýþtýðý makinanýn að arayüzünü
90 ayarlar. Ayrýca RFC1541 veya draft-ietf-dhc-dhcp-09'a uygun olarak,
91 kira zamanýný (lease time) yenilemeye çalýþýr.
92
93 %prep
94 %setup -q -n %{name}-%{ver}
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98 %patch3 -p1
99 %patch4 -p0
100 %patch5 -p0
101
102 %build
103 rm -f missing
104 aclocal
105 %{__autoconf}
106 %{__automake}
107 %configure
108 %{__make} all mandir=%{_mandir} sbindir=%{_sbindir}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_sysconfdir}/dhcpc
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         mandir=%{_mandir} \
117         sbindir=%{_sbindir}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README AUTHORS ChangeLog NEWS
125 %dir %{_sysconfdir}/dhcpc
126 %attr(755,root,root) %{_sbindir}/dhcpcd
127 %{_mandir}/man8/dhcpcd.8*
This page took 0.080251 seconds and 4 git commands to generate.