]> git.pld-linux.org Git - packages/dhcpcd.git/blob - dhcpcd.spec
- added BOOT package
[packages/dhcpcd.git] / dhcpcd.spec
1 %define ver     1.3.20-pl0
2 Summary:        DHCP Client Daemon
3 Summary(de):    DHCPC-Dämon
4 Summary(fr):    Démon DHCPC
5 Summary(pl):    Klient (daemon) DHCP
6 Summary(tr):    DHCPC sunucu süreçi (daemon)
7 Name:           dhcpcd
8 Version:        %(echo %{ver} | sed -e "s#-##")
9 Release:        1
10 License:        GPL
11 Vendor:         Sergei Viznyuk <sv@phystech.com>
12 Group:          Networking/Daemons
13 Group(pl):      Sieciowe/Serwery
14 Source0:        http://www.phystech.com/ftp/%{name}-%{ver}.tar.gz
15 Patch0:         dhcpcd-configure.patch
16 BuildRequires:  automake
17 BuildRequires:  autoconf
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 %if %{?BOOT:1}%{!?BOOT:0}
20 #BuildRequires: glibc-static
21 %endif
22
23 %define         _sbindir        /sbin
24
25 %description
26 dhcpcd is an implementation of the DHCP client specified in
27 draft-ietf-dhc-dhcp-09 (when -r option is not speci- fied) and RFC1541
28 (when -r option is specified).
29
30 It gets the host information (IP address, netmask, broad- cast
31 address, etc.) from a DHCP server and configures the network interface
32 of the machine on which it is running. It also tries to renew the
33 lease time according to RFC1541 or draft-ietf-dhc-dhcp-09.
34
35 %description -l de
36 dhcpcd ist eine Implementierung des DHCP-Client, spezifiziert in
37 draft-ietf-dhc-dhcp-09 (wenn -r option nicht angegeben) und RFC1541
38 (wenn -r option angegeben).
39
40 Es bezieht die Host-Infos (IP-Adresse, Netmask, Broadcast-Adresse,
41 usw.) von einem DHCP-Server und konfiguriert die Netzschnittstelle des
42 Computers, auf dem es läuft Es versucht, die Verleihzeit gemäß RFC1541
43 bzw. draft-ietf-dhc-dhcp-09 zu verlängern.
44
45 %description -l fr
46 dhcpcd est une implantation du client DHCP spécifié dans les
47 draft-ietf-dhc-dhcp-09 (sans l'option -r) et RFC1541 (avec l'option
48 -r).
49
50 Il obtient l'information sur l'hôte (adresse IP, masque réseau,
51 adresse de diffusion, etc.) à partir d'un serveur DHCP et configure
52 l'interface réseau de la machine sur laquelle il tourne. Il essaie
53 aussi de renouveler le « lease time » selon les RFC1541 ou
54 draft-ietf-dhc-dhcp-09.
55
56 %description -l pl
57 dhcpd jest implementacja klienta DHCP, opisan± w
58 draft-ietf-dhc-dhcp-09 (kiedy nie podaje siê opcji -r) oraz RFC1544
59 (kiedy podaje siê opcjê -r).
60
61 Pobiera on informacjê o komputerze (adres IP, maska sieci, adres
62 rozg³oszeniowy itd.) i konfiguruje interfejs sieciowy maszyny, na
63 której jest uruchomiony. Próbuje równie¿ od¶wiezyæ czas przestoju
64 zgodnie z RFC1541 oraz draft-ietf-dhc-dhcp-09.
65
66 %description -l tr
67 Makina bilgilerini (IP adresi, að maskesi, yayýn adresi, vb.) bir DHCP
68 sunucusundan alýr ve üzerinde çalýþtýðý makinanýn að arayüzünü
69 ayarlar. Ayrýca RFC1541 veya draft-ietf-dhc-dhcp-09'a uygun olarak,
70 kira zamanýný (lease time) yenilemeye çalýþýr.
71
72 %if %{?BOOT:1}%{!?BOOT:0}
73 %package BOOT
74 Summary:        dhcpcd for bootdisk
75 Group:          Networking/Daemons
76 Group(pl):      Sieciowe/Serwery
77 %description BOOT
78 %endif
79
80
81 %prep
82 %setup -q -n %{name}-%{ver}
83 %patch -p1
84
85 %build
86 %if %{?BOOT:1}%{!?BOOT:0}
87 aclocal
88 autoconf
89 automake -a -c
90 %configure
91 %{__make} \
92         CFLAGS="-m386 -I/usr/lib/bootdisk%{_includedir} -Os" \
93         LDFLAGS="-nostdlib -s" \
94         LIBS="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
95 mv -f %{name} %{name}-BOOT
96 %{__make} distclean
97 %endif
98
99 rm -f config.cache
100 aclocal
101 autoconf
102 automake -a -c
103 %configure
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_sysconfdir}/dhcpc
109
110 %if %{?BOOT:1}%{!?BOOT:0}
111 install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin
112 install -s %{name}-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin/%{name}
113 %endif
114
115 %{__make} install DESTDIR=$RPM_BUILD_ROOT
116
117 gzip -9nf README AUTHORS ChangeLog NEWS
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc *.gz
125 %dir %{_sysconfdir}/dhcpc
126 %attr(755,root,root) %{_sbindir}/dhcpcd
127 %{_mandir}/man8/dhcpcd.8*
128
129 %if %{?BOOT:1}%{!?BOOT:0}
130 %files BOOT
131 %attr(755,root,root) %{_libdir}/bootdisk/sbin/*
132 %endif
This page took 0.061796 seconds and 4 git commands to generate.