]> git.pld-linux.org Git - packages/dhcpcd.git/blob - dhcpcd.spec
- security note
[packages/dhcpcd.git] / dhcpcd.spec
1 # TODO
2 # - security http://security.gentoo.org/glsa/glsa-200507-16.xml
3 Summary:        DHCP Client Daemon
4 Summary(de):    DHCPC-Dämon
5 Summary(es):    Cliente (daemon) DHCP
6 Summary(fr):    Démon DHCPC
7 Summary(pl):    Klient (daemon) DHCP
8 Summary(pt_BR): Servidor DHCPC
9 Summary(tr):    DHCPC sunucu süreçi (daemon)
10 Name:           dhcpcd
11 %define ver     1.3.22-pl4
12 Version:        %(echo %{ver} | tr -d - )
13 Release:        4
14 License:        GPL v2
15 Group:          Networking/Daemons
16 Source0:        http://www.phystech.com/ftp/%{name}-%{ver}.tar.gz
17 # Source0-md5:  dd627a121e43835bead3ffef5b1a72fd
18 Patch0:         %{name}-configure.patch
19 Patch1:         %{name}-ntpdrift-66136.patch
20 Patch2:         %{name}-noMoFakery.patch
21 Patch3:         %{name}-noNISfakery.patch
22 Patch4:         %{name}-paths_fixes.patch
23 BuildRequires:  automake
24 BuildRequires:  autoconf
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sbindir        /sbin
28
29 %description
30 dhcpcd is an implementation of the DHCP client specified in
31 draft-ietf-dhc-dhcp-09 (when -r option is not specified) and RFC1541
32 (when -r option is specified).
33
34 It gets the host information (IP address, netmask, broadcast address,
35 etc.) from a DHCP server and configures the network interface of the
36 machine on which it is running. It also tries to renew the lease time
37 according to RFC1541 or draft-ietf-dhc-dhcp-09.
38
39 %description -l de
40 dhcpcd ist eine Implementierung des DHCP-Client, spezifiziert in
41 draft-ietf-dhc-dhcp-09 (wenn -r option nicht angegeben) und RFC1541
42 (wenn -r option angegeben).
43
44 Es bezieht die Host-Infos (IP-Adresse, Netmask, Broadcast-Adresse,
45 usw.) von einem DHCP-Server und konfiguriert die Netzschnittstelle des
46 Computers, auf dem es läuft Es versucht, die Verleihzeit gemäß RFC1541
47 bzw. draft-ietf-dhc-dhcp-09 zu verlängern.
48
49 %description -l es
50 dhcpcd es una implementación del cliente DHCP especificado en
51 draft-ietf-dhc-dhcp-09 (cuando la opción -r no está especificada) y
52 RFC1541 (cuando la opción -r está especificada). Captura la
53 información del host (dirección IP, máscara de red, dirección de
54 broadcast, etc.) de un servidor DHCP y configura la interface de red
55 de la máquina donde esté ejecutando. También intenta renovar el tiempo
56 de alquiler de los direcciones de acuerdo con RFC1541 o
57 draft-ietf-dhc-dhcp-09.
58
59 %description -l fr
60 dhcpcd est une implantation du client DHCP spécifié dans les
61 draft-ietf-dhc-dhcp-09 (sans l'option -r) et RFC1541 (avec l'option -r).
62
63 Il obtient l'information sur l'hôte (adresse IP, masque réseau,
64 adresse de diffusion, etc.) à partir d'un serveur DHCP et configure
65 l'interface réseau de la machine sur laquelle il tourne. Il essaie
66 aussi de renouveler le « lease time » selon les RFC1541 ou
67 draft-ietf-dhc-dhcp-09.
68
69 %description -l pl
70 dhcpd jest implementacja klienta DHCP, opisan± w
71 draft-ietf-dhc-dhcp-09 (kiedy nie podaje siê opcji -r) oraz RFC1544
72 (kiedy podaje siê opcjê -r).
73
74 Pobiera on informacjê o komputerze (adres IP, maska sieci, adres
75 rozg³oszeniowy itd.) i konfiguruje interfejs sieciowy maszyny, na
76 której jest uruchomiony. Próbuje równie¿ od¶wie¿yæ czas przestoju
77 zgodnie z RFC1541 oraz draft-ietf-dhc-dhcp-09.
78
79 %description -l pt_BR
80 dhcpcd é uma implementação do cliente DHCP especificado em
81 draft-ietf-dhc-dhcp-09 (quando a opção -r não é especificada) e
82 RFC1541 (quando a opção -r é especificada). Ele captura a informação
83 do host (endereço IP, máscara de rede, endereço de broadcast, etc.) de
84 um servidor DHCP e configura a interface de rede da máquina em que
85 está rodando. Ele também tenta renovar o tempo de aluguel dos
86 endereços de acordo com RFC1541 ou draft-ietf-dhc-dhcp-09.
87
88 %description -l tr
89 Makina bilgilerini (IP adresi, að maskesi, yayýn adresi, vb.) bir DHCP
90 sunucusundan alýr ve üzerinde çalýþtýðý makinanýn að arayüzünü
91 ayarlar. Ayrýca RFC1541 veya draft-ietf-dhc-dhcp-09'a uygun olarak,
92 kira zamanýný (lease time) yenilemeye çalýþýr.
93
94 %prep
95 %setup -q -n %{name}-%{ver}
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99 %patch3 -p1
100 %patch4 -p1
101
102 %build
103 rm -f missing
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 %configure
108 %{__make} all \
109         mandir=%{_mandir} \
110         sbindir=%{_sbindir}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_var}/lib/dhcpc
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         mandir=%{_mandir} \
119         sbindir=%{_sbindir}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc README AUTHORS ChangeLog NEWS
127 %attr(755,root,root) %{_sbindir}/dhcpcd
128 %dir %{_var}/lib/dhcpc
129 %{_mandir}/man8/dhcpcd.8*
This page took 0.078334 seconds and 3 git commands to generate.