]> git.pld-linux.org Git - packages/devhelp.git/blob - devhelp.spec
- up to 0.12 (back to url on gnome.org)
[packages/devhelp.git] / devhelp.spec
1 #
2 # Conditional build:
3 %bcond_without  mozilla_firefox # build with mozilla-firefox-devel
4 #
5 %define         minmozver       5:1.7
6 Summary:        DevHelp is a developer's help program for GNOME
7 Summary(pl):    Program pomocy dla programistów GNOME
8 Name:           devhelp
9 Version:        0.12
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/devhelp/0.12/%{name}-%{version}.tar.gz
14 # Source0-md5:  e211ec1a75dba00d8e71a66e2ab2aec3
15 Patch0:         %{name}-bookdir.patch
16 Patch1:         %{name}-mozilla_includes.patch
17 Patch2:         %{name}-desktop.patch
18 URL:            http://www.imendio.com/projects/devhelp/
19 BuildRequires:  GConf2-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gnome-common >= 2.8.0
23 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
24 BuildRequires:  gtk+2-devel >= 2:2.6.4
25 BuildRequires:  libglade2-devel >= 1:2.5.1
26 BuildRequires:  libtool
27 %if %{with mozilla_firefox}
28 BuildRequires:  mozilla-firefox-devel
29 %else
30 BuildRequires:  mozilla-devel >= %{minmozver}
31 %endif
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpmbuild(macros) >= 1.197
34 BuildRequires:  zlib-devel
35 Requires(post,preun):   GConf2
36 Requires:       %{name}-libs = %{version}-%{release}
37 %if %{with mozilla_firefox}
38 %requires_eq    mozilla-firefox
39 %else
40 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
41 %endif
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # can be provided by mozilla or mozilla-embedded
45 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
46
47 %description
48 DevHelp is a developer's help program for GNOME.
49
50 %description -l pl
51 Program pomocy dla programistów GNOME.
52
53 %package libs
54 Summary:        Library to embed Devhelp in other applications
55 Summary(pl):    Biblioteka do osadzania Devhelp w innych aplikacjach
56 Group:          Libraries
57
58 %description libs
59 Library of Devhelp for embedding into other applications..
60
61 %description libs -l pl
62 Biblioteka Devhelp do osadzania w innych aplikacjach..
63
64 %package devel
65 Summary:        Headers for Devhelp library
66 Summary(pl):    Pliki nag³ówkowe biblioteki Devhelp
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69
70 %description devel
71 Headers for Devhelp library.
72
73 %description devel -l pl
74 Pliki nag³ówkowe biblioteki Devhelp.
75
76 %package static
77 Summary:        Static Devhelp library
78 Summary(pl):    Statyczna biblioteka Devhelp
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static version of Devhelp library.
84
85 %description static -l pl
86 Statyczna biblioteka Devhelp.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --disable-install-schemas
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_sysconfdir}/gconf \
107         $RPM_BUILD_ROOT%{_datadir}/%{name}/{books,specs}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 rm -rf $RPM_BUILD_ROOT%{_datadir}/mime-info
113
114 %find_lang %{name}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 %gconf_schema_install devhelp.schemas
121
122 %preun
123 %gconf_schema_uninstall devhelp.schemas
124
125 %post   libs -p /sbin/ldconfig
126 %postun libs -p /sbin/ldconfig
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README TODO
131 %attr(755,root,root) %{_bindir}/devhelp*
132 %{_datadir}/%{name}
133 %{_desktopdir}/*.desktop
134 %{_iconsdir}/*
135 %{_sysconfdir}/gconf/schemas/*
136
137 %files libs
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %{_libdir}/lib*.la
145 %{_pkgconfigdir}/*.pc
146 %{_includedir}/*
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/lib*.a
This page took 0.446092 seconds and 4 git commands to generate.