]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- updates for latest libpq++
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools Server
2 Summary(pl):    Serwer dynamicznego DNSu
3 Name:           ddt
4 Version:        0.5.9
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://download.sourceforge.net/ddt/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-am_ac.patch
10 Patch1:         %{name}-cgi-to-cgic.patch
11 Patch2:         %{name}-bind-includes-hack.patch
12 Patch3:         %{name}-nobody.patch
13 Patch4:         %{name}-postgresql.patch
14 URL:            http://www.ddts.org/
15 Source1:        %{name}-client.init
16 Source2:        %{name}-server.init
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bind-devel >= 9.2.1-10
20 BuildRequires:  cgilibc-devel
21 BuildRequires:  openssl-devel >= 0.9.7
22 BuildRequires:  postgresql-c++-devel
23 BuildRequires:  libgcrypt-devel
24 BuildRequires:  regexx-devel
25 BuildRequires:  macrosystem-devel
26 BuildRequires:  opt
27 BuildRequires:  sgml-tools
28 Prereq:         chkconfig
29 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 DDT stands for Dynamic Dns Tools. The goal of the project is to
33 provide an open and free (in the GPL-sense) set of tools that will
34 permit the deployment of secure and reliable dynamic DNS services.
35
36 %description -l pl
37 DDT oznacza Dynamiczne Narzêdzia DNS. Celem projektu jest dostarczenie
38 otwartego i wolnego (w sensie GPL) zestawu narzêdzi pozwalaj±cych na
39 stworzenie bezpiecznego i niezawodnego systemu dynamicznego DNS.
40
41 %package clients
42 Summary:        Dynamic DNS Tools Client
43 Summary(pl):    Klient Dynamicznego DNSu
44 Group:          Applications/Networking
45
46 %description clients
47 Dynamic DNS Tools Client.
48
49 %description clients -l pl
50 Klient Dynamicznego DNSu.
51
52 %package cgi
53 Summary:        CGI scripts for Dynamic DNS Tools Server
54 Summary(pl):    Skrypty CGI do Serwera Dynamicznego DNSu
55 Group:          Applications/Networking
56 Requires:       webserver
57
58 %description cgi
59 CGI scripts for Dynamic DNS Tools Server.
60
61 %description cgi -l pl
62 Skrypty CGI do Serwera Dynamicznego DNSu.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70 %patch4 -p1
71
72 %build
73 rm -f missing
74 %{__aclocal}
75 %{__autoconf}
76 %{__automake}
77 CPPFLAGS="-I%{_includedir}/cgilibc -I%{_includedir}/postgresql/server"; export CPPFLAGS
78 %configure \
79         --enable-docs \
80         --enable-server \
81         --enable-admin \
82         --with-pgsql-incdir=%{_includedir} \
83         --with-pgsql-libdir=%{_libdir}
84 # fixme
85 echo "all install:" > docs/Makefile
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
92 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
93 install -d $RPM_BUILD_ROOT/etc/logrotate.d
94 install -d $RPM_BUILD_ROOT/var/{lib/ddt-client,run/ddt}
95 install -d $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html/%{name}}
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99         
100 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
101 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
102 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
103 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
104
105 install admin/templates/* $RPM_BUILD_ROOT/home/services/httpd/html/%{name}
106 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /sbin/chkconfig --add %{name}-server
113 if [ -f /var/lock/subsys/%{name}-server ]; then
114         /etc/rc.d/init.d/%{name}-server restart >&2
115 else
116         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
117 fi
118
119 %preun
120 if [ "$1" = "0" ]; then
121         if [ -f /var/lock/subsys/%{name}-server ]; then
122                 /etc/rc.d/init.d/%{name}-server stop >&2
123         fi
124         /sbin/chkconfig --del %{name}-server
125 fi
126
127 %post clients
128 /sbin/chkconfig --add %{name}-client
129 if [ -f /var/lock/subsys/%{name}-client ]; then
130         /etc/rc.d/init.d/%{name}-client restart >&2
131 else
132         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
133 fi
134
135 %preun clients
136 if [ "$1" = "0" ]; then
137         if [ -f /var/lock/subsys/%{name}-client ]; then
138                 /etc/rc.d/init.d/%{name}-client stop >&2
139         fi
140         /sbin/chkconfig --del %{name}-client
141 fi
142
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS BUGS NEWS README THANKS TODO
146 %doc docs/*.sgml docs/include/{named.conf,zonedb}
147 %doc server/*.sql
148 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
149 %attr(755,root,root) %{_sbindir}/ddtd
150 %{_mandir}/man8/ddtd.8*
151 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
152 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
153 %attr(644,root,root) %dir /var/lib/ddt-client
154 %attr(644,root,root) %dir /var/run/ddt
155
156 %files clients
157 %defattr(644,root,root,755)
158 %doc docs/DDT*.sgml
159 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
160 %attr(755,root,root) %{_sbindir}/ddtc
161 %attr(755,root,root) %{_sbindir}/ddtcd
162 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
163 %{_mandir}/man8/ddtc.8*
164 %{_mandir}/man8/ddtcd.8*
165 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
166
167 %files cgi
168 %defattr(644,root,root,755)
169 %attr(755,root,root) /home/services/httpd/cgi-bin/*.cgi
170 %attr(644,root,root) /home/services/httpd/cgi-bin/*.conf
171 %attr(755,root,root) /home/services/httpd/html/%{name}
This page took 0.104397 seconds and 4 git commands to generate.