]> git.pld-linux.org Git - packages/dbus.git/blob - dbus.spec
- updated to 0.20, new-style bconds, separated -gtk
[packages/dbus.git] / dbus.spec
1 #
2 # TODO: gcj, mono, python
3 #
4 # Conditional build:
5 %bcond_without  glib    # without glib support
6 %bcond_without  gtk     # without GTK+ programs
7 %bcond_without  qt      # without qt support
8 #
9 %if %{without glib}
10 %undefine       with_gtk
11 %endif
12 %define gettext_package dbus
13 %define expat_version           1.95.5
14 %define glib2_version           2.2.0
15 %define qt_version              3.1.0
16 Summary:        D-BUS message bus
17 Summary(pl):    Magistrala przesy³ania komunikatów D-BUS
18 Name:           dbus
19 Version:        0.20
20 Release:        1
21 License:        AFL v2.0 or GPL v2
22 Group:          Libraries
23 Source0:        http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
24 # Source0-md5:  8ebff3cb4beec993e9160ff844e0411c
25 Patch0:         %{name}-ac.patch
26 Patch1:         %{name}-nolibs.patch
27 # NOTE: it's not directory, don't add /
28 URL:            http://www.freedesktop.org/software/dbus
29 BuildRequires:  XFree86-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  expat-devel >= %{expat_version}
33 %{?with_glib:BuildRequires:     glib2-devel >= %{glib2_version}}
34 %{?with_gtk:BuildRequires:      gtk+2-devel >= %{glib2_version}}
35 %{?with_qt:BuildRequires:       kdelibs-devel}
36 BuildRequires:  libtool
37 BuildRequires:  pkgconfig
38 %{?with_qt:BuildRequires:       qt-devel    >= %{qt_version}}
39 #PreReq:        rc-scripts
40 #Requires(post,preun):  /sbin/chkconfig
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 D-BUS is a system for sending messages between applications. It is
45 used both for the systemwide message bus service, and as a
46 per-user-login-session messaging facility.
47
48 %description -l pl
49 D-BUS to system przesy³ania komunikatów pomiêdzy aplikacjami. Jest
50 u¿ywany zarówno jako ogólnosystemowa us³uga magistrali komunikatów jak
51 i mo¿liwo¶æ przesy³ania komunikatów w ramach jednej sesji u¿ytkownika.
52
53 %package devel
54 Summary:        Header files for D-BUS
55 Summary(pl):    Pliki nag³ówkowe D-BUS
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}
58
59 %description devel
60 Header files for D-BUS.
61
62 %description devel -l pl
63 Pliki nag³ówkowe D-BUS.
64
65 %package static
66 Summary:        Static D-BUS libraries
67 Summary(pl):    Statyczne biblioteki D-BUS
68 Group:          Development/Libraries
69
70 %description static
71 Static D-BUS libraries.
72
73 %description static -l pl
74 Statyczne biblioteki D-BUS.
75
76 %package glib
77 Summary:        GLib-based library for using D-BUS
78 Summary(pl):    Biblioteka do u¿ywania D-BUS oparta o GLib
79 Group:          Libraries
80 Requires:       %{name} = %{version}
81
82 %description glib
83 D-BUS add-on library to integrate the standard D-BUS library with the
84 GLib thread abstraction and main loop.
85
86 %description glib -l pl
87 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
88 z abstrakcj± w±tków i g³ówn± pêtl± GLib.
89
90 %package glib-devel
91 Summary:        Header files for GLib-based library for using D-BUS
92 Summary(pl):    Pliki nag³ówkowe biblioteki do u¿ywania D-BUS opartej o GLib
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}
95 Requires:       %{name}-glib = %{version}
96 Requires:       glib2-devel >= %{glib_version}
97
98 %description glib-devel
99 Header files for GLib-based library for using D-BUS.
100
101 %description glib-devel -l pl
102 Pliki nag³ówkowe biblioteki do u¿ywania D-BUS opartej o GLib.
103
104 %package glib-static
105 Summary:        Static GLib-based library for using D-BUS
106 Summary(pl):    Statyczna biblioteka do u¿ywania D-BUS oparta o GLib
107 Group:          Development/Libraries
108 Requires:       %{name}-glib-devel = %{version}
109
110 %description glib-static
111 Static GLib-based library for using D-BUS.
112
113 %description glib-static -l pl
114 Statyczna biblioteka do u¿ywania D-BUS oparta o GLib.
115
116 %package gtk
117 Summary:        GTK+-based graphical D-BUS frontend utility
118 Summary(pl):    Oparte na GTK+ graficzne narzêdzie do D-BUS
119 Group:          X11/Applications
120 Requires:       %{name} = %{version}
121
122 %description gtk
123 GTK+-based graphical D-BUS frontend utility.
124
125 %description gtk -l pl
126 Oparte na GTK+ graficzne narzêdzie do D-BUS.
127
128 %package qt
129 Summary:        Qt-based library for using D-BUS
130 Summary(pl):    Biblioteka do u¿ywania D-BUS oparta o Qt
131 Group:          Libraries
132 Requires:       %{name} = %{version}
133
134 %description qt
135 D-BUS add-on library to integrate the standard D-BUS library with the
136 Qt thread abstraction and main loop.
137
138 %description qt -l pl
139 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
140 z abstrakcj± w±tków i g³ówn± pêtl± Qt.
141
142 %package qt-devel
143 Summary:        Header files for Qt-based library for using D-BUS
144 Summary(pl):    Pliki nag³ówkowe biblioteki do u¿ywania D-BUS opartej o Qt
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}
147 Requires:       %{name}-qt = %{version}
148 Requires:       kdelibs-devel
149
150 %description qt-devel
151 Header files for Qt-based library for using D-BUS.
152
153 %description qt-devel -l pl
154 Pliki nag³ówkowe biblioteki do u¿ywania D-BUS opartej o Qt.
155
156 %package qt-static
157 Summary:        Static Qt-based library for using D-BUS
158 Summary(pl):    Statyczna biblioteka do u¿ywania D-BUS oparta o Qt
159 Group:          Development/Libraries
160 Requires:       %{name}-qt-devel = %{version}
161
162 %description qt-static
163 Static Qt-based library for using D-BUS.
164
165 %description qt-static -l pl
166 Statyczna biblioteka do u¿ywania D-BUS oparta o Qt.
167
168 %prep
169 %setup -q
170 %patch0 -p1
171 %patch1 -p1
172
173 %build
174 %{__libtoolize}
175 %{__aclocal}
176 %{__autoconf}
177 %{__autoheader}
178 %{__automake}
179 %configure \
180         QTDIR=/usr \
181         %{!?with_glib:--disable-glib} \
182         %{!?with_gtk:--disable-gtk} \
183         %{!?with_qt:--disable-qt} \
184         --disable-tests \
185         --disable-verbose-mode \
186         --disable-asserts
187
188 %{__make}
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT
195
196 ## %find_lang %{gettext_package}
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 #%pre
202 # Add the "messagebus" user
203 #/usr/sbin/useradd -c 'System message bus' -u 81 \
204 #       -s /sbin/nologin -r -d '/' messagebus 2> /dev/null || :
205
206 %post   -p /sbin/ldconfig
207 #/sbin/chkconfig --add messagebus
208
209 #%preun
210 #if [ $1 = 0 ]; then
211 #    service messagebus stop > /dev/null 2>&1
212 #    /sbin/chkconfig --del messagebus
213 #fi
214
215 %postun -p /sbin/ldconfig
216
217 %post   glib -p /sbin/ldconfig
218 %postun glib -p /sbin/ldconfig
219
220 %post   qt -p /sbin/ldconfig
221 %postun qt -p /sbin/ldconfig
222
223 ##  -f %{gettext_package}.lang
224 %files
225 %defattr(644,root,root,755)
226 %doc AUTHORS COPYING ChangeLog NEWS README doc/TODO
227 %attr(755,root,root) %{_bindir}/dbus-cleanup-sockets
228 %attr(755,root,root) %{_bindir}/dbus-daemon-1
229 # dbus-launch R: XFree86-libs
230 %attr(755,root,root) %{_bindir}/dbus-launch
231 %attr(755,root,root) %{_bindir}/dbus-send
232 %attr(755,root,root) %{_libdir}/libdbus-1.so.*.*.*
233 %dir %{_libdir}/dbus-*
234 %dir %{_sysconfdir}/dbus-1
235 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/dbus-1/*.conf
236 #/etc/rc.d/init.d/*
237 %dir %{_sysconfdir}/dbus-1/system.d
238 %dir %{_localstatedir}/run/dbus
239 %{_mandir}/man1/dbus-cleanup-sockets.1*
240 %{_mandir}/man1/dbus-daemon-1.1*
241 %{_mandir}/man1/dbus-launch.1*
242 %{_mandir}/man1/dbus-send.1*
243 #%{_libdir}/dbus-1.0/services
244
245 %files devel
246 %defattr(644,root,root,755)
247 %doc doc/*.{html,txt}
248 %attr(755,root,root) %{_libdir}/libdbus-1.so
249 %{_libdir}/libdbus-1.la
250 %{_libdir}/dbus-*/include
251 %{_pkgconfigdir}/dbus-1.pc
252 %{_includedir}/dbus*
253 %{!?_without_glib:%exclude %{_includedir}/dbus*/dbus/dbus-glib.h}
254 %{!?_without_qt:%exclude %{_includedir}/dbus*/dbus/dbus-qt.h}
255
256 %files static
257 %defattr(644,root,root,755)
258 %{_libdir}/libdbus-1.a
259
260 %if %{with glib}
261 %files glib
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_bindir}/dbus-glib-tool
264 %attr(755,root,root) %{_bindir}/dbus-monitor
265 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
266 %{_pkgconfigdir}/dbus-glib-1.pc
267 %{_mandir}/man1/dbus-monitor.1*
268
269 %files glib-devel
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
272 %{_libdir}/libdbus-glib-1.la
273 %{_includedir}/dbus*/dbus/dbus-glib.h
274
275 %files glib-static
276 %defattr(644,root,root,755)
277 %{_libdir}/libdbus-glib-1.a
278 %endif
279
280 %if %{with gtk}
281 %files gtk
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_bindir}/dbus-viewer
284 %endif
285
286 %if %{with qt}
287 %files qt
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_libdir}/libdbus-qt-1.so.*.*.*
290
291 %files qt-devel
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_libdir}/libdbus-qt-1.so
294 %{_libdir}/libdbus-qt-1.la
295 %{_includedir}/dbus*/dbus/dbus-qt.h
296
297 %files qt-static
298 %defattr(644,root,root,755)
299 %{_libdir}/libdbus-qt-1.a
300 %endif
This page took 0.079031 seconds and 3 git commands to generate.