]> git.pld-linux.org Git - packages/dahdi-linux.git/blob - dahdi-linux.spec
- added fixes from upstream, now it builds with 2.6.31
[packages/dahdi-linux.git] / dahdi-linux.spec
1 #
2 # TODO:
3 # - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
4 #
5 # Conditional build:
6 %bcond_without  dist_kernel     # without distribution kernel
7 %bcond_with     oslec           # with Open Source Line Echo Canceller
8 %bcond_without  xpp             # without Astribank
9 %bcond_with     verbose
10
11 %ifarch sparc
12 %undefine       with_smp
13 %endif
14 %ifarch alpha
15 %undefine       with_xpp
16 %endif
17
18 %define         rel     1
19 %define         pname   dahdi-linux
20 %define         FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
21 Summary:        DAHDI telephony device support
22 Summary(pl.UTF-8):      Obsługa urządzeń telefonicznych DAHDI
23 Name:           %{pname}%{_alt_kernel}
24 Version:        2.2.0.2
25 Release:        %{rel}
26 License:        GPL
27 Group:          Base/Kernel
28 Source0:        http://downloads.digium.com/pub/telephony/dahdi-linux/dahdi-linux-%{version}.tar.gz
29 # Source0-md5:  1f932729ad28f2f028afcf2cc5ccf7ba
30 Source3:        %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
31 # Source3-md5:  88db9b7a07d8392736171b1b3e6bcc66
32 Source4:        %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
33 # Source4-md5:  c1f1a18d3e20d283f42c71e580a64b5a
34 Source5:        %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
35 # Source5-md5:  e1c7231d6225ac999cb18f4e858f66b6
36 Source6:        %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
37 # Source6-md5:  2ea860bb8a9d8ede2858b9557b74ee3c
38 Patch0:         %{pname}-svn-fixes.patch
39 URL:            http://www.asterisk.org/
40 %if %{with kernel} && %{with dist_kernel}
41 BuildRequires:  kernel%{_alt_kernel}-module-build
42 BuildRequires:  module-init-tools
43 %endif
44 BuildRequires:  newt-devel
45 BuildRequires:  perl-base
46 BuildRequires:  perl-tools-pod
47 BuildRequires:  rpmbuild(macros) >= 1.379
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # Rules:
51 # - modules_X: single modules, just name module with no suffix
52 # - modules_X: subdir modules are just directory name with slash like dirname/
53 # - keep X and X_in in sync
54 # - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
55
56 %define modules_1       dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_loc.o dahdi_dummy.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o 
57 %define modules_1_in    dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_loc,dahdi_dummy,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
58 %define modules_2       voicebuss wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
59 %define modules_2_in    voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
60 %ifnarch alpha
61 %define modules_nalpha  wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
62 %define modules_nalpha_in       wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
63
64 %endif
65 %define modules         %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
66 %define modules_in      %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
67
68 %description
69 DAHDI telephony device driver.
70
71 %description -l pl.UTF-8
72 Sterownik do urządzeń telefonicznych DAHDI.
73
74 %package devel
75 Summary:        Header files for dahdi interface
76 Group:          Development/Libraries
77 # if base package contains shared library for which these headers are
78 #Requires:      %{name} = %{version}-%{release}
79 # if -libs package contains shared library for which these headers are
80 #Requires:      %{name}-libs = %{version}-%{release}
81
82 %description devel
83 Header files for dahdi interface.
84
85 %package -n kernel%{_alt_kernel}-%{pname}
86 Summary:        DAHDI Linux kernel driver
87 Summary(pl.UTF-8):      Sterownik DAHDI dla jądra Linuksa
88 Release:        %{rel}@%{_kernel_ver_str}
89 Group:          Base/Kernel
90 Requires(post,postun):  /sbin/depmod
91 %if %{with dist_kernel}
92 %requires_releq_kernel
93 Requires(postun):       %releq_kernel
94 %{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
95 %endif
96
97 %description -n kernel%{_alt_kernel}-%{pname}
98 DAHDI telephony Linux kernel driver.
99
100 %description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
101 Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
102
103 %prep
104 %setup -q -n %{pname}-%{version}
105 %patch0 -p1
106
107 for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}; do
108         ln -s $a drivers/dahdi/firmware
109         tar -C drivers/dahdi/firmware -xzf $a
110 done
111
112 cat > download-logger <<'EOF'
113 #!/bin/sh
114 # keep log of files make wanted to download in firmware/ dir
115 echo "$@" >> download.log
116 EOF
117 chmod a+rx download-logger
118
119 %build
120 %{__make} include/dahdi/version.h
121
122 %build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include 
123
124 check_modules() {
125         err=0
126         for a in drivers/dahdi/{*/,}*.ko; do
127                 [[ $a = *-dist.ko ]] && continue
128                 [[ $a = *-up.ko ]] && continue
129                 [[ $a = *-smp.ko ]] && continue
130                 echo >&2 "unpackaged module: ${a%.ko}"
131                 err=1
132         done
133
134         [ $err = 0 ] || exit 1
135 }
136 check_modules
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
141 cd drivers/dahdi
142 %install_kernel_modules -m %{modules_in} -d misc
143 cd ../..
144
145 install include/dahdi/*.h $RPM_BUILD_ROOT%{_includedir}/dahdi/
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post -n kernel%{_alt_kernel}-%{pname}
151 %depmod %{_kernel_ver}
152
153 %postun -n kernel%{_alt_kernel}-%{pname}
154 %depmod %{_kernel_ver}
155
156 %files devel
157 %defattr(644,root,root,755)
158 %{_includedir}/dahdi
159
160 %files -n kernel%{_alt_kernel}-%{pname}
161 %defattr(644,root,root,755)
162 /lib/modules/%{_kernel_ver}/misc/*.ko*
This page took 0.428216 seconds and 4 git commands to generate.