]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- gss-devel for -devel if heimdal was enabled (fixes libcurl.la having libgss.la...
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssl     # without SSL support
4 %bcond_without  heimdal # without HEIMDAL support
5 #
6 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
7 Summary(es):    Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
8 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
9 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
10 Summary(ru):    õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
11 Summary(uk):    õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
12 Name:           curl
13 Version:        7.15.0
14 Release:        2
15 License:        MIT-like
16 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
17 Group:          Applications/Networking
18 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
19 # Source0-md5:  e3b130320d3704af375c097606f49c01
20 Patch0:         %{name}-no_strip.patch
21 Patch1:         %{name}-ac.patch
22 Patch2:         %{name}-heimdal.patch
23 URL:            http://curl.haxx.se/
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake
26 BuildRequires:  libidn-devel >= 0.4.1
27 %{?with_heimdal:BuildRequires:  heimdal-devel >= 0.7}
28 BuildRequires:  libtool
29 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
30 Requires:       openssl-tools >= 0.9.7d
31 Requires:       libidn >= 0.4.1
32 Obsoletes:      libcurl2
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 cURL is a tool for getting files with URL syntax, supporting FTP,
37 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
38 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
39 cookies, user+password authentication and a busload of other useful
40 tricks. The main use for curl is when you want to get or send files
41 automatically to or from a site using one of the supported protocols.
42
43 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
44 Dict servers, using any of the supported protocols. cURL is designed
45 to work without user interaction or any kind of interactivity. cURL
46 offers many useful capabilities, like proxy support, user
47 authentication, FTP upload, HTTP post, and file transfer resume.
48
49 %description -l pl
50 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
51 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
52 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
53 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
54 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
55 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
56 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
57 %{?with_ssl:Ten pakiet obs³uguje tak¿e SSL.}
58
59 %description -l pt_BR
60 Curl é um cliente para baixar/enviar arquivos de/para servidores
61 usando um dos protocolos suportados. É projetado para funcionar sem a
62 interação do usuário.
63
64 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
65 continuar transferências interrompidas, e mais...
66
67 %description -l ru
68 curl - ÜÔÏ ËÌÉÅÎÔ Ó ÍÎÏÖÅÓÔ×ÏÍ ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ÐÒÏÔÏËÏÌÏ× ÄÌÑ ÐÏÌÕÞÅÎÉÑ
69 ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ×, ÓÐÒÏÅËÔÉÒÏ×ÁÎÎÙÊ ÄÌÑ ÒÁÂÏÔÙ ËÁË × ÎÅÉÎÔÅÒÁËÔÉ×ÎÏÍ
70 ÒÅÖÉÍÅ, ÔÁË É Ó ×ÏÚÍÏÖÎÏÓÔØÀ ÄÉÁÌÏÇÁ Ó ÐÏÌØÚÏ×ÁÔÅÌÅÍ.
71
72 curl ÐÏÄÄÅÒÖÉ×ÁÅÔ ÍÎÏÇÏ ÐÏÌÅÚÎÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ, ÓÒÅÄÉ ËÏÔÏÒÙÈ ÐÏÄÄÅÒÖËÁ
73 ÐÒÏËÓÉ, Á×ÔÏÒÉÚÁÃÉÑ ÐÏÌØÚÏ×ÁÔÅÌÑ, ÚÁËÁÞÉ×ÁÎÉÅ ÐÏ FTP, ÐÏÄÄÅÒÖËÁ HTTP
74 POST, ×ÏÓÓÔÁÎÏ×ÌÅÎÉÅ ÐÒÅÒ×ÁÎÎÏÊ ÐÅÒÅÓÙÌËÉ É ÍÎÏÇÏÅ ÄÒÕÇÏÅ.
75
76 curl - ÃÅ Ë̦¤ÎÔ Ú ÂÁÇÁÔØÍÁ Ð¦ÄÔÒÉÍÕ×ÁÎÉÍÉ ÐÒÏÔÏËÏÌÁÍÉ ÄÌÑ ÏÔÒÉÍÁÎÎÑ
77 ÆÁÊ̦נڠÓÅÒ×ÅÒ¦×, ÓÐÒÏÅËÔÏ×ÁÎÉÊ ÄÌÑ ÒÏÂÏÔÉ ÑË × ÎŦÎÔÅÒÁËÔÉ×ÎÏÍÕ
78 ÒÅÖÉͦ, ÔÁË ¦ Ú ÍÏÖÌÉצÓÔÀ Ä¦ÁÌÏÇÕ Ú ËÏÒÉÓÔÕ×ÁÞÅÍ.
79
80 curl Ð¦ÄÔÒÉÍÕ¤ ÂÁÇÁÔÏ ËÏÒÉÓÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ, ÓÅÒÅÄ ÑËÉȠЦÄÔÒÉÍËÁ
81 ÐÒÏËÓ¦, Á×ÔÏÒÉÚÁæѠËÏÒÉÓÔÕ×ÁÞÁ, ×¦Ä×ÁÎÔÁÖÅÎÎÑ ÐÏ FTP, HTTP POST,
82 צÄÎÏ×ÌÅÎÎÑ ÐÅÒÅÒ×ÁÎϧ ÐÅÒÅÓÉÌËÉ ÔÁ ÂÁÇÁÔÏ ¦ÎÛÏÇÏ.
83
84 %package devel
85 Summary:        Header files and development documentation for curl library
86 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
87 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
88 Summary(ru):    æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
89 Summary(uk):    æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       libidn-devel >= 0.4.1
93 %{?with_heimdal:Requires:       heimdal-devel}
94 %{?with_heimdal:Requires:       gss-devel}
95 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
96 Obsoletes:      libcurl2-devel
97
98 %description devel
99 Header files and development documentation for curl library.
100
101 %description devel -l pl
102 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
103
104 %description devel -l pt_BR
105 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
106
107 %description devel -l ru
108 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
109 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
110
111 %description devel -l uk
112 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
113 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
114
115 %package static
116 Summary:        Static version of curl library
117 Summary(pl):    Statyczna wersja biblioteki curl
118 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
119 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
120 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 Static version of curl library.
126
127 %description static -l pl
128 Statyczna wersja biblioteki curl.
129
130 %description static -l pt_BR
131 Bibliotecas estáticas para desenvolvimento com o curl.
132
133 %description static -l ru
134 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÕÀ ÂÉÂÌÉÏÔÅËÕ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
135 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
136
137 %description static -l uk
138 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞÎՠ¦Â̦ÏÔÅËÕ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
139 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144 %patch1 -p1
145 %{?with_heimdal:%patch2 -p0}
146
147 %build
148 %{__libtoolize}
149 %{__aclocal}
150 %{__autoconf}
151 %{__autoheader}
152 %{__automake}
153 %configure \
154         %{?with_ssl:--with-ssl=%{_prefix}} \
155         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
156         %{?with_heimdal:--with-gssapi-includes=%{_includedir}} \
157         --with-ipv6
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
176 %attr(755,root,root) %{_bindir}/curl
177 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
178 %{_mandir}/man1/curl.1*
179
180 %files devel
181 %defattr(644,root,root,755)
182 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
183 %attr(755,root,root) %{_bindir}/curl-config
184 %attr(755,root,root) %{_libdir}/libcurl.so
185 %{_libdir}/libcurl.la
186 %{_includedir}/curl
187 %{_mandir}/man1/curl-config.1*
188 %{_mandir}/man3/*curl*.3*
189
190 %files static
191 %defattr(644,root,root,755)
192 %{_libdir}/libcurl.a
This page took 0.161611 seconds and 4 git commands to generate.