]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- added using %%{__make} macro.
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Name:           curl
3 Version:        6.5.2
4 Release:        1
5 License:        MPL
6 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
7 Group:          Applications/Networking
8 Group(pl):      Aplikacje/Sieciowe
9 Source0:        http://curl.haxx.nu/stuff/%{name}-%{version}.tar.gz
10 URL:            http://curl.haxx.nu/
11 BuildRequires:  openssl-devel
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 cURL is a tool for getting files with URL syntax, supporting FTP,
16 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
17 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
18 cookies, user+password authentication and a busload of other useful
19 tricks. The main use for curl is when you want to get or send files
20 automatically to or from a site using one of the supported protocols.
21
22 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
23 Dict servers, using any of the supported protocols. cURL is designed
24 to work without user interaction or any kind of interactivity. cURL
25 offers many useful capabilities, like proxy support, user
26 authentication, FTP upload, HTTP post, and file transfer resume. Note
27 that while cURL also supports the SSL protocol, this version is
28 compiled without SSL (https:) support.
29
30 %description -l pl
31 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
32 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
33 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
34 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
35 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
36 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
37 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów. Chocia¿
38 cURL obs³uguje równie¿ protokó³ SSL, wersja ta jest skompilowana bez
39 obs³ugi SSL (https:).
40
41 %prep
42 %setup -q 
43
44 %build
45 LDFLAGS="-s"; export LDFLAGS
46 %configure \
47         --with-ssl=/usr
48 %{__make} 
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} DESTDIR=$RPM_BUILD_ROOT install
53
54 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
55         README* CHANGES CONTRIBUTE FAQ LEGAL MPL-1.0.txt RESOURCES TODO
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc *.gz
62 %attr(755,root,root) %{_bindir}/curl
63 %{_mandir}/man1/*
This page took 0.032485 seconds and 4 git commands to generate.