]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.15.5
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares    # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssl     # without SSL support
5 %bcond_without  heimdal # without HEIMDAL support
6 #
7 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
8 Summary(es):    Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
9 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
10 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
11 Summary(ru):    õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
12 Summary(uk):    õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
13 Name:           curl
14 Version:        7.15.5
15 Release:        1
16 License:        MIT-like
17 Group:          Applications/Networking
18 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
19 # Source0-md5:  594142c7d53bbdd988e8cef6354eeeff
20 Patch0:         %{name}-no_strip.patch
21 Patch1:         %{name}-ac.patch
22 Patch2:         %{name}-heimdal.patch
23 URL:            http://curl.haxx.se/
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake
26 %{?with_ares:BuildRequires:     c-ares-devel}
27 %{?with_heimdal:BuildRequires:  heimdal-devel >= 0.7}
28 BuildRequires:  libidn-devel >= 0.4.1
29 BuildRequires:  libtool
30 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
31 Requires:       %{name}-libs = %{version}-%{release}
32 Requires:       libidn >= 0.4.1
33 Requires:       openssl-tools >= 0.9.7d
34 Obsoletes:      libcurl2
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 cURL is a tool for getting files with URL syntax, supporting FTP,
39 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
40 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
41 cookies, user+password authentication and a busload of other useful
42 tricks. The main use for curl is when you want to get or send files
43 automatically to or from a site using one of the supported protocols.
44
45 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
46 Dict servers, using any of the supported protocols. cURL is designed
47 to work without user interaction or any kind of interactivity. cURL
48 offers many useful capabilities, like proxy support, user
49 authentication, FTP upload, HTTP post, and file transfer resume.
50
51 %description -l pl
52 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
53 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
54 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
55 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
56 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
57 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
58 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
59 %{?with_ssl:Ten pakiet obs³uguje tak¿e SSL.}
60
61 %description -l pt_BR
62 Curl é um cliente para baixar/enviar arquivos de/para servidores
63 usando um dos protocolos suportados. É projetado para funcionar sem a
64 interação do usuário.
65
66 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
67 continuar transferências interrompidas, e mais...
68
69 %description -l ru
70 curl - ÜÔÏ ËÌÉÅÎÔ Ó ÍÎÏÖÅÓÔ×ÏÍ ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ÐÒÏÔÏËÏÌÏ× ÄÌÑ ÐÏÌÕÞÅÎÉÑ
71 ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ×, ÓÐÒÏÅËÔÉÒÏ×ÁÎÎÙÊ ÄÌÑ ÒÁÂÏÔÙ ËÁË × ÎÅÉÎÔÅÒÁËÔÉ×ÎÏÍ
72 ÒÅÖÉÍÅ, ÔÁË É Ó ×ÏÚÍÏÖÎÏÓÔØÀ ÄÉÁÌÏÇÁ Ó ÐÏÌØÚÏ×ÁÔÅÌÅÍ.
73
74 curl ÐÏÄÄÅÒÖÉ×ÁÅÔ ÍÎÏÇÏ ÐÏÌÅÚÎÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ, ÓÒÅÄÉ ËÏÔÏÒÙÈ ÐÏÄÄÅÒÖËÁ
75 ÐÒÏËÓÉ, Á×ÔÏÒÉÚÁÃÉÑ ÐÏÌØÚÏ×ÁÔÅÌÑ, ÚÁËÁÞÉ×ÁÎÉÅ ÐÏ FTP, ÐÏÄÄÅÒÖËÁ HTTP
76 POST, ×ÏÓÓÔÁÎÏ×ÌÅÎÉÅ ÐÒÅÒ×ÁÎÎÏÊ ÐÅÒÅÓÙÌËÉ É ÍÎÏÇÏÅ ÄÒÕÇÏÅ.
77
78 curl - ÃÅ Ë̦¤ÎÔ Ú ÂÁÇÁÔØÍÁ Ð¦ÄÔÒÉÍÕ×ÁÎÉÍÉ ÐÒÏÔÏËÏÌÁÍÉ ÄÌÑ ÏÔÒÉÍÁÎÎÑ
79 ÆÁÊ̦נڠÓÅÒ×ÅÒ¦×, ÓÐÒÏÅËÔÏ×ÁÎÉÊ ÄÌÑ ÒÏÂÏÔÉ ÑË × ÎŦÎÔÅÒÁËÔÉ×ÎÏÍÕ
80 ÒÅÖÉͦ, ÔÁË ¦ Ú ÍÏÖÌÉצÓÔÀ Ä¦ÁÌÏÇÕ Ú ËÏÒÉÓÔÕ×ÁÞÅÍ.
81
82 curl Ð¦ÄÔÒÉÍÕ¤ ÂÁÇÁÔÏ ËÏÒÉÓÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ, ÓÅÒÅÄ ÑËÉȠЦÄÔÒÉÍËÁ
83 ÐÒÏËÓ¦, Á×ÔÏÒÉÚÁæѠËÏÒÉÓÔÕ×ÁÞÁ, ×¦Ä×ÁÎÔÁÖÅÎÎÑ ÐÏ FTP, HTTP POST,
84 צÄÎÏ×ÌÅÎÎÑ ÐÅÒÅÒ×ÁÎϧ ÐÅÒÅÓÉÌËÉ ÔÁ ÂÁÇÁÔÏ ¦ÎÛÏÇÏ.
85
86 %package libs
87 Summary:        curl library
88 Summary(pl):    Biblioteka curl
89 Group:          Libraries
90
91 %description libs
92 curl library.
93
94 %description libs -l pl
95 Biblioteka curl.
96
97 %package devel
98 Summary:        Header files and development documentation for curl library
99 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
100 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
101 Summary(ru):    æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
102 Summary(uk):    æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
103 Group:          Development/Libraries
104 Requires:       %{name}-libs = %{version}-%{release}
105 %{?with_heimdal:Requires:       heimdal-devel}
106 Requires:       libidn-devel >= 0.4.1
107 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
108 Obsoletes:      libcurl2-devel
109
110 %description devel
111 Header files and development documentation for curl library.
112
113 %description devel -l pl
114 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
115
116 %description devel -l pt_BR
117 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
118
119 %description devel -l ru
120 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
121 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
122
123 %description devel -l uk
124 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
125 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
126
127 %package static
128 Summary:        Static version of curl library
129 Summary(pl):    Statyczna wersja biblioteki curl
130 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
131 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
132 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}-%{release}
135
136 %description static
137 Static version of curl library.
138
139 %description static -l pl
140 Statyczna wersja biblioteki curl.
141
142 %description static -l pt_BR
143 Bibliotecas estáticas para desenvolvimento com o curl.
144
145 %description static -l ru
146 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÕÀ ÂÉÂÌÉÏÔÅËÕ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
147 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
148
149 %description static -l uk
150 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞÎՠ¦Â̦ÏÔÅËÕ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
151 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
152
153 %prep
154 %setup -q
155 %patch0 -p1
156 %patch1 -p1
157 %{?with_heimdal:%patch2 -p0}
158
159 %build
160 %{__libtoolize}
161 %{__aclocal}
162 %{__autoconf}
163 %{__autoheader}
164 %{__automake}
165 %configure \
166         %{?with_ssl:--with-ssl=%{_prefix}} \
167         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
168         %{?with_heimdal:--with-gssapi=%{_prefix}} \
169         %{?with_ares:--enable-ares=%{_prefix}} \
170         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
171
172 %{__make}
173
174 %install
175 rm -rf $RPM_BUILD_ROOT
176
177 %{__make} install \
178         DESTDIR=$RPM_BUILD_ROOT
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   libs -p /sbin/ldconfig
184 %postun libs -p /sbin/ldconfig
185
186 %files
187 %defattr(644,root,root,755)
188 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
189 %attr(755,root,root) %{_bindir}/curl
190 %{_mandir}/man1/curl.1*
191
192 %files libs
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
199 %attr(755,root,root) %{_bindir}/curl-config
200 %attr(755,root,root) %{_libdir}/libcurl.so
201 %{_libdir}/libcurl.la
202 %{_includedir}/curl
203 %{_pkgconfigdir}/libcurl.pc
204 %{_mandir}/man1/curl-config.1*
205 %{_mandir}/man3/*curl*.3*
206
207 %files static
208 %defattr(644,root,root,755)
209 %{_libdir}/libcurl.a
This page took 0.050128 seconds and 4 git commands to generate.