]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- BR: tar >= 1.22 (required for .tar.lzma sources)
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
8 #
9 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
10 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
11 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
12 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
13 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
14 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
15 Name:           curl
16 Version:        7.19.6
17 Release:        1
18 License:        MIT-like
19 Group:          Applications/Networking
20 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
21 # Source0-md5:  9351ad8ee0bea75015dfa9ec6248e055
22 Patch0:         %{name}-no_strip.patch
23 Patch1:         %{name}-ac.patch
24 Patch2:         %{name}-pc.patch
25 Patch3:         %{name}-krb5flags.patch
26 URL:            http://curl.haxx.se/
27 BuildRequires:  autoconf >= 2.57
28 BuildRequires:  automake
29 %{?with_ares:BuildRequires:     c-ares-devel}
30 %{?with_kerberos5:BuildRequires:        heimdal-devel}
31 BuildRequires:  libidn-devel >= 0.4.1
32 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
33 BuildRequires:  libtool
34 BuildRequires:  openldap-devel
35 %if %{with ssl}
36 %if %{with gnutls}
37 BuildRequires:  gnutls-devel
38 %else
39 BuildRequires:  openssl-devel >= 0.9.7d
40 %endif
41 %endif
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  zlib-devel
44 Requires:       %{name}-libs = %{version}-%{release}
45 Requires:       libidn >= 0.4.1
46 %{?with_ssh:Requires:   libssh2 >= 0.16}
47 Requires:       openssl-tools >= 0.9.7d
48 Obsoletes:      libcurl2
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 cURL is a tool for getting files with URL syntax, supporting FTP,
53 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
54 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
55 cookies, user+password authentication and a busload of other useful
56 tricks. The main use for curl is when you want to get or send files
57 automatically to or from a site using one of the supported protocols.
58
59 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
60 Dict servers, using any of the supported protocols. cURL is designed
61 to work without user interaction or any kind of interactivity. cURL
62 offers many useful capabilities, like proxy support, user
63 authentication, FTP upload, HTTP post, and file transfer resume.
64
65 %description -l pl.UTF-8
66 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
67 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
68 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
69 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
70 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
71 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
72 pliki z/na serwer używając jednego z dostępnych protokołów.
73 %{?with_ssl:Ten pakiet obsługuje także SSL.}
74
75 %description -l pt_BR.UTF-8
76 Curl é um cliente para baixar/enviar arquivos de/para servidores
77 usando um dos protocolos suportados. É projetado para funcionar sem a
78 interação do usuário.
79
80 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
81 continuar transferências interrompidas, e mais...
82
83 %description -l ru.UTF-8
84 curl - это клиент с множеством поддерживаемых протоколов для получения
85 файлов с серверов, спроектированный для работы как в неинтерактивном
86 режиме, так и с возможностью диалога с пользователем.
87
88 curl поддерживает много полезных возможностей, среди которых поддержка
89 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
90 POST, восстановление прерванной пересылки и многое другое.
91
92 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
93 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
94 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
95
96 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
97 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
98 в╕дновлення перервано╖ пересилки та багато ╕ншого.
99
100 %package libs
101 Summary:        curl library
102 Summary(pl.UTF-8):      Biblioteka curl
103 Group:          Libraries
104 Suggests:       ca-certificates
105 Conflicts:      ca-certificates < 20080809-4
106
107 %description libs
108 curl library.
109
110 %description libs -l pl.UTF-8
111 Biblioteka curl.
112
113 %package devel
114 Summary:        Header files and development documentation for curl library
115 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
116 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
117 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
118 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
119 Group:          Development/Libraries
120 Requires:       %{name}-libs = %{version}-%{release}
121 %{?with_ares:Requires:  c-ares-devel}
122 %{?with_kerberos5:Requires:     heimdal-devel}
123 Requires:       libidn-devel >= 0.4.1
124 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
125 %if %{with ssl}
126 %if %{with gnutls}
127 Requires:       gnutls-devel
128 %else
129 Requires:       openssl-devel >= 0.9.7c
130 %endif
131 %endif
132 Requires:       zlib-devel
133 Obsoletes:      libcurl2-devel
134
135 %description devel
136 Header files and development documentation for curl library.
137
138 %description devel -l pl.UTF-8
139 Pliki nagłówkowe i dokumentacja do biblioteki curl.
140
141 %description devel -l pt_BR.UTF-8
142 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
143
144 %description devel -l ru.UTF-8
145 Этот пакет содержит файлы, необходимые для разработки программ с
146 использованием библиотеки curl.
147
148 %description devel -l uk.UTF-8
149 Цей пакет містить файли, необхідні для розробки програм з
150 використанням бібліотеки curl.
151
152 %package static
153 Summary:        Static version of curl library
154 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
155 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
156 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
157 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
158 Group:          Development/Libraries
159 Requires:       %{name}-devel = %{version}-%{release}
160
161 %description static
162 Static version of curl library.
163
164 %description static -l pl.UTF-8
165 Statyczna wersja biblioteki curl.
166
167 %description static -l pt_BR.UTF-8
168 Bibliotecas estáticas para desenvolvimento com o curl.
169
170 %description static -l ru.UTF-8
171 Этот пакет содержит статическую библиотеку для разработки программ с
172 использованием библиотеки curl.
173
174 %description static -l uk.UTF-8
175 Цей пакет містить статичну бібліотеку для розробки програм з
176 використанням бібліотеки curl.
177
178 %prep
179 %setup -q
180 %patch0 -p1
181 %patch1 -p1
182 %patch2 -p1
183 %patch3 -p1
184
185 %build
186 %{__libtoolize}
187 %{__aclocal} -I m4
188 %{__autoconf}
189 %{__autoheader}
190 %{__automake}
191 %configure \
192         ac_cv_header_gss_h=no \
193 %if %{with ssl}
194         --with-ca-bundle=/etc/certs/ca-certificates.crt \
195 %if %{with gnutls}
196         --with-gnutls=%{_prefix} --without-ssl \
197 %else
198         --with-ssl=%{_prefix} \
199 %endif
200 %endif
201         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
202         %{?with_ares:--enable-ares=%{_prefix}} \
203         --enable-ldaps \
204         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
205
206 %{__make}
207
208 %install
209 rm -rf $RPM_BUILD_ROOT
210
211 %{__make} install \
212         DESTDIR=$RPM_BUILD_ROOT
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post   libs -p /sbin/ldconfig
218 %postun libs -p /sbin/ldconfig
219
220 %files
221 %defattr(644,root,root,755)
222 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
223 %attr(755,root,root) %{_bindir}/curl
224 %{_mandir}/man1/curl.1*
225
226 %files libs
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
230
231 %files devel
232 %defattr(644,root,root,755)
233 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
234 %attr(755,root,root) %{_bindir}/curl-config
235 %attr(755,root,root) %{_libdir}/libcurl.so
236 %{_libdir}/libcurl.la
237 %{_includedir}/curl
238 %{_pkgconfigdir}/libcurl.pc
239 %{_mandir}/man1/curl-config.1*
240 %{_mandir}/man3/curl_*.3*
241 %{_mandir}/man3/libcurl*.3*
242
243 %files static
244 %defattr(644,root,root,755)
245 %{_libdir}/libcurl.a
This page took 0.052035 seconds and 4 git commands to generate.