]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- release2: libcurl2{,-devel} added to Obsletes for allow upgrade from MDK.
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(es):    Busca URL (soporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP y HTTPS)
3 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
4 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
5 Name:           curl
6 Version:        7.9.2
7 Release:        2
8 License:        MPL
9 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
10 Group:          Applications/Networking
11 Group(de):      Applikationen/Netzwerkwesen
12 Group(pl):      Aplikacje/Sieciowe
13 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
14 Patch0:         %{name}-no_strip.patch
15 Patch1:         %{name}-readtimeout-fix.patch
16 URL:            http://curl.haxx.se/
17 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      libcurl2
20
21 %description
22 cURL is a tool for getting files with URL syntax, supporting FTP,
23 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
24 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
25 cookies, user+password authentication and a busload of other useful
26 tricks. The main use for curl is when you want to get or send files
27 automatically to or from a site using one of the supported protocols.
28
29 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
30 Dict servers, using any of the supported protocols. cURL is designed
31 to work without user interaction or any kind of interactivity. cURL
32 offers many useful capabilities, like proxy support, user
33 authentication, FTP upload, HTTP post, and file transfer resume.
34
35 %description -l es
36 Curl es un cliente para bajar documentos/archivos de servidores usando
37 uno de los protocolos soportados. Está proyectado para funcionar sin
38 interacción del usuario.
39
40 Curl trabaja con proxy, autenticación, ftp put, HTTP post, y puede
41 continuar transferencias interrumpidas, y además...
42
43 %description -l pl
44 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
45 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
46 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
47 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
48 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
49 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
50 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
51
52 Uwaga: ten pakiet wspiera takze SSL.
53
54 %description -l pt_BR
55 Curl é um cliente para baixar/enviar arquivos de/para servidores
56 usando um dos protocolos suportados. É projetado para funcionar sem a
57 interação do usuário.
58
59 Curl trabalha com proxy, autenticação, ftp put, HTTP post, e pode
60 continuar transferências interrompidas, e mais...
61
62 %package devel
63 Summary:        Header files and development documentation for curl library
64 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
65 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
66 Group:          Development/Libraries
67 Group(de):      Entwicklung/Libraries
68 Group(es):      Desarrollo/Bibliotecas
69 Group(fr):      Development/Librairies
70 Group(pl):      Programowanie/Biblioteki
71 Group(pt_BR):   Desenvolvimento/Bibliotecas
72 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
73 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
74 Requires:       %{name} = %{version}
75 Obsoletes:      libcurl2-devel
76
77 %description devel
78 Header files and development documentation for curl library.
79
80 %description -l pl devel
81 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
82
83 %description -l pt_BR devel
84 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
85
86 %package static
87 Summary:        Static version of curl library
88 Summary(pl):    Statyczna wersja biblioteki curl
89 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
90 Group:          Development/Libraries
91 Group(de):      Entwicklung/Libraries
92 Group(es):      Desarrollo/Bibliotecas
93 Group(fr):      Development/Librairies
94 Group(pl):      Programowanie/Biblioteki
95 Group(pt_BR):   Desenvolvimento/Bibliotecas
96 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
97 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
98 Requires:       %{name}-devel = %{version}
99
100 %description static
101 Static version of curl library.
102
103 %description -l pl static
104 Statyczna wersja biblioteki curl.
105
106 %description -l pt_BR static
107 Bibliotecas estáticas para desenvolvimento com o curl.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113
114 %build
115 %configure \
116         %{!?_without_ssl:--with-ssl=%{_prefix}} \
117         --with-ipv6
118
119 %{__make} 
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install DESTDIR=$RPM_BUILD_ROOT
125
126 gzip -9nf CHANGES LEGAL README docs/TheArtOfHttpScripting \
127         docs/{BUGS,CONTRIBUTE,FAQ,FEATURES,INTERNALS,MANUAL,README*,RESOURCES,THANKS,TODO}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc *.gz docs/*.gz
138 %attr(755,root,root) %{_bindir}/%{name}
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140 %{_mandir}/man1/*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/%{name}-config
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %attr(755,root,root) %{_libdir}/lib*.la
147 %{_includedir}/*
148 %{_mandir}/man3/*
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/lib*.a
This page took 0.091778 seconds and 4 git commands to generate.