]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- adapterized.
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(es):    Busca URL (soporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP y HTTPS)
3 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
4 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
5 Name:           curl
6 Version:        7.9.4
7 Release:        1
8 License:        MPL
9 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
10 Group:          Applications/Networking
11 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-no_strip.patch
13 URL:            http://curl.haxx.se/
14 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 Obsoletes:      libcurl2
17
18 %description
19 cURL is a tool for getting files with URL syntax, supporting FTP,
20 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
21 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
22 cookies, user+password authentication and a busload of other useful
23 tricks. The main use for curl is when you want to get or send files
24 automatically to or from a site using one of the supported protocols.
25
26 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
27 Dict servers, using any of the supported protocols. cURL is designed
28 to work without user interaction or any kind of interactivity. cURL
29 offers many useful capabilities, like proxy support, user
30 authentication, FTP upload, HTTP post, and file transfer resume.
31
32 %description -l es
33 Curl es un cliente para bajar documentos/archivos de servidores usando
34 uno de los protocolos soportados. Está proyectado para funcionar sin
35 interacción del usuario.
36
37 Curl trabaja con proxy, autenticación, ftp put, HTTP post, y puede
38 continuar transferencias interrumpidas, y además...
39
40 %description -l pl
41 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
42 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
43 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
44 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
45 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
46 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
47 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
48
49 Uwaga: ten pakiet wspiera takze SSL.
50
51 %description -l pt_BR
52 Curl é um cliente para baixar/enviar arquivos de/para servidores
53 usando um dos protocolos suportados. É projetado para funcionar sem a
54 interação do usuário.
55
56 Curl trabalha com proxy, autenticação, ftp put, HTTP post, e pode
57 continuar transferências interrompidas, e mais...
58
59 %package devel
60 Summary:        Header files and development documentation for curl library
61 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
62 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}
65 Obsoletes:      libcurl2-devel
66
67 %description devel
68 Header files and development documentation for curl library.
69
70 %description devel -l pl
71 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
72
73 %description devel -l pt_BR
74 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
75
76 %package static
77 Summary:        Static version of curl library
78 Summary(pl):    Statyczna wersja biblioteki curl
79 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}
82
83 %description static
84 Static version of curl library.
85
86 %description static -l pl
87 Statyczna wersja biblioteki curl.
88
89 %description static -l pt_BR
90 Bibliotecas estáticas para desenvolvimento com o curl.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %configure \
98         %{!?_without_ssl:--with-ssl=%{_prefix}} \
99         --with-ipv6
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install DESTDIR=$RPM_BUILD_ROOT
107
108 gzip -9nf CHANGES LEGAL README docs/TheArtOfHttpScripting \
109         docs/{BUGS,CONTRIBUTE,FAQ,FEATURES,INTERNALS,MANUAL,README*,RESOURCES,THANKS,TODO}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc *.gz docs/*.gz
120 %attr(755,root,root) %{_bindir}/%{name}
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*
122 %{_mandir}/man1/*
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/%{name}-config
127 %attr(755,root,root) %{_libdir}/lib*.so
128 %attr(755,root,root) %{_libdir}/lib*.la
129 %{_includedir}/*
130 %{_mandir}/man3/*
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/lib*.a
This page took 0.070535 seconds and 4 git commands to generate.