]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- 7.34.0
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %bcond_with     http2           # without HTTP/2.0 support (nghttp2 based)
8 %bcond_without  metalink        # without metalink support
9 %if "%{pld_release}" != "ac"
10 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
11 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
12 %bcond_without  rtmp            # without Real Time Media Protocol
13 %else
14 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
15 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
16 %bcond_with     rtmp            # without Real Time Media Protocol
17 %endif
18
19 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
20 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
24 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
25 Name:           curl
26 Version:        7.34.0
27 Release:        1
28 License:        MIT-like
29 Group:          Applications/Networking
30 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
31 # Source0-md5:  552371ae5e40bd7d9c92c62ac4b7be81
32 Patch0:         %{name}-ac.patch
33 Patch1:         %{name}-krb5flags.patch
34 # make the curl tool link SSL libraries also used by src/tool_metalink.c
35 Patch2:         metalink.patch
36 URL:            http://curl.haxx.se/
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
40 %{?with_kerberos5:BuildRequires:        heimdal-devel}
41 %{?with_http2:BuildRequires:    nghttp2-devel}
42 BuildRequires:  libidn-devel >= 0.4.1
43 %{?with_metalink:BuildRequires: libmetalink-devel}
44 %{?with_rtmp:BuildRequires:     librtmp-devel}
45 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
46 BuildRequires:  libtool
47 BuildRequires:  nettle-devel
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(macros) >= 1.453
52 %if %{with ssl}
53 %if %{with gnutls}
54 BuildRequires:  gnutls-devel
55 %else
56 BuildRequires:  openssl-devel >= 1.0.1
57 %endif
58 %endif
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       libidn >= 0.4.1
63 Obsoletes:      libcurl2
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 cURL is a tool for getting files with URL syntax, supporting FTP,
68 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
69 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
70 cookies, user+password authentication and a busload of other useful
71 tricks. The main use for curl is when you want to get or send files
72 automatically to or from a site using one of the supported protocols.
73
74 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75 Dict servers, using any of the supported protocols. cURL is designed
76 to work without user interaction or any kind of interactivity. cURL
77 offers many useful capabilities, like proxy support, user
78 authentication, FTP upload, HTTP post, and file transfer resume.
79
80 %description -l pl.UTF-8
81 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
82 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
83 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
84 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
85 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
86 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
87 pliki z/na serwer używając jednego z dostępnych protokołów.
88 %{?with_ssl:Ten pakiet obsługuje także SSL.}
89
90 %description -l pt_BR.UTF-8
91 Curl é um cliente para baixar/enviar arquivos de/para servidores
92 usando um dos protocolos suportados. É projetado para funcionar sem a
93 interação do usuário.
94
95 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
96 continuar transferências interrompidas, e mais...
97
98 %description -l ru.UTF-8
99 curl - это клиент с множеством поддерживаемых протоколов для получения
100 файлов с серверов, спроектированный для работы как в неинтерактивном
101 режиме, так и с возможностью диалога с пользователем.
102
103 curl поддерживает много полезных возможностей, среди которых поддержка
104 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
105 POST, восстановление прерванной пересылки и многое другое.
106
107 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
108 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
109 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
110
111 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
112 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
113 в╕дновлення перервано╖ пересилки та багато ╕ншого.
114
115 %package libs
116 Summary:        curl library
117 Summary(pl.UTF-8):      Biblioteka curl
118 Group:          Libraries
119 %{?with_ares:Requires:  c-ares >= 1.7.0}
120 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
121 %if %{with ssl} && %{without gnutls}
122 Requires:       openssl >= 1.0.1
123 %endif
124 Suggests:       ca-certificates
125 Conflicts:      ca-certificates < 20080809-4
126
127 %description libs
128 curl library.
129
130 %description libs -l pl.UTF-8
131 Biblioteka curl.
132
133 %package devel
134 Summary:        Header files and development documentation for curl library
135 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
136 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
137 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
138 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
139 Group:          Development/Libraries
140 Requires:       %{name}-libs = %{version}-%{release}
141 %{?with_ares:Requires:  c-ares-devel}
142 %{?with_kerberos5:Requires:     heimdal-devel}
143 Requires:       libidn-devel >= 0.4.1
144 %{?with_rtmp:Requires:  librtmp-devel}
145 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
146 %{?with_ldap:Requires:  openldap-devel}
147 %if %{with ssl}
148 %if %{with gnutls}
149 Requires:       gnutls-devel
150 %else
151 Requires:       openssl-devel >= 0.9.7c
152 %endif
153 %endif
154 Requires:       zlib-devel
155 Obsoletes:      libcurl2-devel
156
157 %description devel
158 Header files and development documentation for curl library.
159
160 %description devel -l pl.UTF-8
161 Pliki nagłówkowe i dokumentacja do biblioteki curl.
162
163 %description devel -l pt_BR.UTF-8
164 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
165
166 %description devel -l ru.UTF-8
167 Этот пакет содержит файлы, необходимые для разработки программ с
168 использованием библиотеки curl.
169
170 %description devel -l uk.UTF-8
171 Цей пакет містить файли, необхідні для розробки програм з
172 використанням бібліотеки curl.
173
174 %package static
175 Summary:        Static version of curl library
176 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
177 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
178 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
179 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182
183 %description static
184 Static version of curl library.
185
186 %description static -l pl.UTF-8
187 Statyczna wersja biblioteki curl.
188
189 %description static -l pt_BR.UTF-8
190 Bibliotecas estáticas para desenvolvimento com o curl.
191
192 %description static -l ru.UTF-8
193 Этот пакет содержит статическую библиотеку для разработки программ с
194 использованием библиотеки curl.
195
196 %description static -l uk.UTF-8
197 Цей пакет містить статичну бібліотеку для розробки програм з
198 використанням бібліотеки curl.
199
200 %prep
201 %setup -q
202 %patch0 -p1
203 %patch1 -p1
204
205 %{__rm} -v m4/lt*.m4 m4/libtool.m4
206
207 %build
208 %{__libtoolize}
209 %{__aclocal} -I m4
210 %{__autoconf}
211 %{__autoheader}
212 %{__automake}
213 %configure \
214         ac_cv_header_gss_h=no \
215 %if %{with ssl}
216         --with-ca-bundle=/etc/certs/ca-certificates.crt \
217 %if %{with gnutls}
218         --with-gnutls --without-ssl \
219 %else
220         --with-ssl=%{_prefix} \
221 %endif
222 %endif
223         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
224         %{?with_metalink:--with-libmetalink} \
225         %{?with_rtmp:--with-librtmp} \
226         %{?with_http2:--with-nghttp2} \
227         %{?with_ares:--enable-ares} \
228         --enable-ipv6 \
229         %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
230
231 %{__make}
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 # no longer in upstream but a lot of apps tries to include it so we create fake one
239 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
240 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
241
242 %clean
243 rm -rf $RPM_BUILD_ROOT
244
245 %post   libs -p /sbin/ldconfig
246 %postun libs -p /sbin/ldconfig
247
248 %files
249 %defattr(644,root,root,755)
250 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
251 %attr(755,root,root) %{_bindir}/curl
252 %{_mandir}/man1/curl.1*
253
254 %files libs
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
257 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
258
259 %files devel
260 %defattr(644,root,root,755)
261 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
262 %attr(755,root,root) %{_bindir}/curl-config
263 %attr(755,root,root) %{_libdir}/libcurl.so
264 %{_libdir}/libcurl.la
265 %{_includedir}/curl
266 %{_pkgconfigdir}/libcurl.pc
267 %{_mandir}/man1/curl-config.1*
268 %{_mandir}/man3/curl_*.3*
269 %{_mandir}/man3/libcurl*.3*
270
271 %files static
272 %defattr(644,root,root,755)
273 %{_libdir}/libcurl.a
This page took 1.021929 seconds and 4 git commands to generate.