]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.16.4
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  kerberos5       # without MIT Kerberos 5 support
7 #
8 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
9 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
10 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
11 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
12 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
13 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
14 Name:           curl
15 Version:        7.16.4
16 Release:        1
17 License:        MIT-like
18 Group:          Applications/Networking
19 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
20 # Source0-md5:  ffa6d1f4e28ca493a43f9dc17882c4d8
21 Patch0:         %{name}-no_strip.patch
22 Patch1:         %{name}-ac.patch
23 Patch2:         %{name}-pc.patch
24 URL:            http://curl.haxx.se/
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 %{?with_ares:BuildRequires:     c-ares-devel}
28 %{?with_kerberos5:BuildRequires:        krb5-devel}
29 BuildRequires:  libidn-devel >= 0.4.1
30 %{?with_ssh:BuildRequires:      libssh2-devel}
31 BuildRequires:  libtool
32 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
33 BuildRequires:  zlib-devel
34 Requires:       %{name}-libs = %{version}-%{release}
35 Requires:       libidn >= 0.4.1
36 Requires:       openssl-tools >= 0.9.7d
37 Obsoletes:      libcurl2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 cURL is a tool for getting files with URL syntax, supporting FTP,
42 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
43 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
44 cookies, user+password authentication and a busload of other useful
45 tricks. The main use for curl is when you want to get or send files
46 automatically to or from a site using one of the supported protocols.
47
48 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
49 Dict servers, using any of the supported protocols. cURL is designed
50 to work without user interaction or any kind of interactivity. cURL
51 offers many useful capabilities, like proxy support, user
52 authentication, FTP upload, HTTP post, and file transfer resume.
53
54 %description -l pl.UTF-8
55 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
56 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
57 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
58 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
59 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
60 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
61 pliki z/na serwer używając jednego z dostępnych protokołów.
62 %{?with_ssl:Ten pakiet obsługuje także SSL.}
63
64 %description -l pt_BR.UTF-8
65 Curl é um cliente para baixar/enviar arquivos de/para servidores
66 usando um dos protocolos suportados. É projetado para funcionar sem a
67 interação do usuário.
68
69 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
70 continuar transferências interrompidas, e mais...
71
72 %description -l ru.UTF-8
73 curl - это клиент с множеством поддерживаемых протоколов для получения
74 файлов с серверов, спроектированный для работы как в неинтерактивном
75 режиме, так и с возможностью диалога с пользователем.
76
77 curl поддерживает много полезных возможностей, среди которых поддержка
78 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
79 POST, восстановление прерванной пересылки и многое другое.
80
81 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
82 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
83 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
84
85 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
86 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
87 в╕дновлення перервано╖ пересилки та багато ╕ншого.
88
89 %package libs
90 Summary:        curl library
91 Summary(pl.UTF-8):      Biblioteka curl
92 Group:          Libraries
93
94 %description libs
95 curl library.
96
97 %description libs -l pl.UTF-8
98 Biblioteka curl.
99
100 %package devel
101 Summary:        Header files and development documentation for curl library
102 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
103 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
104 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
105 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
106 Group:          Development/Libraries
107 Requires:       %{name}-libs = %{version}-%{release}
108 %{?with_ares:Requires:  c-ares-devel}
109 %{?with_kerberos5:Requires:     krb5-devel}
110 Requires:       libidn-devel >= 0.4.1
111 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
112 Requires:       zlib-devel
113 Obsoletes:      libcurl2-devel
114
115 %description devel
116 Header files and development documentation for curl library.
117
118 %description devel -l pl.UTF-8
119 Pliki nagłówkowe i dokumentacja do biblioteki curl.
120
121 %description devel -l pt_BR.UTF-8
122 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
123
124 %description devel -l ru.UTF-8
125 Этот пакет содержит файлы, необходимые для разработки программ с
126 использованием библиотеки curl.
127
128 %description devel -l uk.UTF-8
129 Цей пакет містить файли, необхідні для розробки програм з
130 використанням бібліотеки curl.
131
132 %package static
133 Summary:        Static version of curl library
134 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
135 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
136 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
137 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140
141 %description static
142 Static version of curl library.
143
144 %description static -l pl.UTF-8
145 Statyczna wersja biblioteki curl.
146
147 %description static -l pt_BR.UTF-8
148 Bibliotecas estáticas para desenvolvimento com o curl.
149
150 %description static -l ru.UTF-8
151 Этот пакет содержит статическую библиотеку для разработки программ с
152 использованием библиотеки curl.
153
154 %description static -l uk.UTF-8
155 Цей пакет містить статичну бібліотеку для розробки програм з
156 використанням бібліотеки curl.
157
158 %prep
159 %setup -q
160 %patch0 -p1
161 %patch1 -p1
162 %patch2 -p1
163
164 %build
165 %{__libtoolize}
166 %{__aclocal}
167 %{__autoconf}
168 %{__autoheader}
169 %{__automake}
170 %configure \
171         ac_cv_header_gss_h=no \
172         %{?with_ssl:--with-ssl=%{_prefix}} \
173         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
174         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
175         %{?with_ares:--enable-ares=%{_prefix}} \
176         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   libs -p /sbin/ldconfig
190 %postun libs -p /sbin/ldconfig
191
192 %files
193 %defattr(644,root,root,755)
194 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
195 %attr(755,root,root) %{_bindir}/curl
196 %{_mandir}/man1/curl.1*
197
198 %files libs
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
201
202 %files devel
203 %defattr(644,root,root,755)
204 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
205 %attr(755,root,root) %{_bindir}/curl-config
206 %attr(755,root,root) %{_libdir}/libcurl.so
207 %{_libdir}/libcurl.la
208 %{_includedir}/curl
209 %{_pkgconfigdir}/libcurl.pc
210 %{_mandir}/man1/curl-config.1*
211 %{_mandir}/man3/*curl*.3*
212
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libcurl.a
This page took 0.057938 seconds and 4 git commands to generate.