]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updatedo to 7.18.1
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  kerberos5       # without MIT Kerberos 5 support
7 #
8 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
9 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
10 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
11 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
12 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
13 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
14 Name:           curl
15 Version:        7.18.1
16 Release:        2
17 License:        MIT-like
18 Group:          Applications/Networking
19 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
20 # Source0-md5:  3e50dd887d6a354be312d874e1d3426c
21 Patch0:         %{name}-no_strip.patch
22 Patch1:         %{name}-ac.patch
23 Patch2:         %{name}-pc.patch
24 URL:            http://curl.haxx.se/
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 %{?with_ares:BuildRequires:     c-ares-devel}
28 %{?with_kerberos5:BuildRequires:        krb5-devel}
29 BuildRequires:  libidn-devel >= 0.4.1
30 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
31 BuildRequires:  libtool
32 BuildRequires:  openldap-devel
33 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
34 BuildRequires:  zlib-devel
35 Requires:       %{name}-libs = %{version}-%{release}
36 Requires:       libidn >= 0.4.1
37 %{?with_ssh:Requires:   libssh2 >= 0.16}
38 Requires:       openssl-tools >= 0.9.7d
39 Obsoletes:      libcurl2
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 cURL is a tool for getting files with URL syntax, supporting FTP,
44 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
45 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
46 cookies, user+password authentication and a busload of other useful
47 tricks. The main use for curl is when you want to get or send files
48 automatically to or from a site using one of the supported protocols.
49
50 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
51 Dict servers, using any of the supported protocols. cURL is designed
52 to work without user interaction or any kind of interactivity. cURL
53 offers many useful capabilities, like proxy support, user
54 authentication, FTP upload, HTTP post, and file transfer resume.
55
56 %description -l pl.UTF-8
57 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
58 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
59 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
60 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
61 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
62 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
63 pliki z/na serwer używając jednego z dostępnych protokołów.
64 %{?with_ssl:Ten pakiet obsługuje także SSL.}
65
66 %description -l pt_BR.UTF-8
67 Curl é um cliente para baixar/enviar arquivos de/para servidores
68 usando um dos protocolos suportados. É projetado para funcionar sem a
69 interação do usuário.
70
71 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
72 continuar transferências interrompidas, e mais...
73
74 %description -l ru.UTF-8
75 curl - это клиент с множеством поддерживаемых протоколов для получения
76 файлов с серверов, спроектированный для работы как в неинтерактивном
77 режиме, так и с возможностью диалога с пользователем.
78
79 curl поддерживает много полезных возможностей, среди которых поддержка
80 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
81 POST, восстановление прерванной пересылки и многое другое.
82
83 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
84 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
85 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
86
87 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
88 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
89 в╕дновлення перервано╖ пересилки та багато ╕ншого.
90
91 %package libs
92 Summary:        curl library
93 Summary(pl.UTF-8):      Biblioteka curl
94 Group:          Libraries
95
96 %description libs
97 curl library.
98
99 %description libs -l pl.UTF-8
100 Biblioteka curl.
101
102 %package devel
103 Summary:        Header files and development documentation for curl library
104 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
105 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
106 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
107 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
108 Group:          Development/Libraries
109 Requires:       %{name}-libs = %{version}-%{release}
110 %{?with_ares:Requires:  c-ares-devel}
111 %{?with_kerberos5:Requires:     krb5-devel}
112 Requires:       libidn-devel >= 0.4.1
113 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
114 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
115 Requires:       zlib-devel
116 Obsoletes:      libcurl2-devel
117
118 %description devel
119 Header files and development documentation for curl library.
120
121 %description devel -l pl.UTF-8
122 Pliki nagłówkowe i dokumentacja do biblioteki curl.
123
124 %description devel -l pt_BR.UTF-8
125 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
126
127 %description devel -l ru.UTF-8
128 Этот пакет содержит файлы, необходимые для разработки программ с
129 использованием библиотеки curl.
130
131 %description devel -l uk.UTF-8
132 Цей пакет містить файли, необхідні для розробки програм з
133 використанням бібліотеки curl.
134
135 %package static
136 Summary:        Static version of curl library
137 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
138 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
139 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
140 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description static
145 Static version of curl library.
146
147 %description static -l pl.UTF-8
148 Statyczna wersja biblioteki curl.
149
150 %description static -l pt_BR.UTF-8
151 Bibliotecas estáticas para desenvolvimento com o curl.
152
153 %description static -l ru.UTF-8
154 Этот пакет содержит статическую библиотеку для разработки программ с
155 использованием библиотеки curl.
156
157 %description static -l uk.UTF-8
158 Цей пакет містить статичну бібліотеку для розробки програм з
159 використанням бібліотеки curl.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164 %patch1 -p1
165 %patch2 -p1
166
167 %build
168 %{__libtoolize}
169 %{__aclocal}
170 %{__autoconf}
171 %{__autoheader}
172 %{__automake}
173 %configure \
174         ac_cv_header_gss_h=no \
175         %{?with_ssl:--with-ssl=%{_prefix}} \
176         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
177         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
178         %{?with_ares:--enable-ares=%{_prefix}} \
179         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
180
181 %{__make}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post   libs -p /sbin/ldconfig
193 %postun libs -p /sbin/ldconfig
194
195 %files
196 %defattr(644,root,root,755)
197 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
198 %attr(755,root,root) %{_bindir}/curl
199 %{_mandir}/man1/curl.1*
200
201 %files libs
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
204 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
205
206 %files devel
207 %defattr(644,root,root,755)
208 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
209 %attr(755,root,root) %{_bindir}/curl-config
210 %attr(755,root,root) %{_libdir}/libcurl.so
211 %{_libdir}/libcurl.la
212 %{_includedir}/curl
213 %{_pkgconfigdir}/libcurl.pc
214 %{_mandir}/man1/curl-config.1*
215 %{_mandir}/man3/curl_*.3*
216 %{_mandir}/man3/libcurl*.3*
217
218 %files static
219 %defattr(644,root,root,755)
220 %{_libdir}/libcurl.a
This page took 0.324034 seconds and 4 git commands to generate.