]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 7.5.2.
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Name:           curl
3 Version:        7.5.2
4 Release:        1
5 License:        MPL
6 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
7 Group:          Applications/Networking
8 Group(de):      Applikationen/Netzwerkwesen
9 Group(pl):      Aplikacje/Sieciowe
10 Source0:        http://curl.haxx.se/stuff/%{name}-%{version}.tar.gz
11 URL:            http://curl.haxx.se/
12 BuildRequires:  openssl-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 cURL is a tool for getting files with URL syntax, supporting FTP,
17 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
18 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
19 cookies, user+password authentication and a busload of other useful
20 tricks. The main use for curl is when you want to get or send files
21 automatically to or from a site using one of the supported protocols.
22
23 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
24 Dict servers, using any of the supported protocols. cURL is designed
25 to work without user interaction or any kind of interactivity. cURL
26 offers many useful capabilities, like proxy support, user
27 authentication, FTP upload, HTTP post, and file transfer resume.
28
29 %description -l pl
30 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
31 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
32 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
33 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
34 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
35 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
36 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
37
38 %package devel
39 Summary:        Header files and development documentation for curl library
40 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
41 Group:          Development/Libraries
42 Group(de):      Entwicklung/Libraries
43 Group(fr):      Development/Librairies
44 Group(pl):      Programowanie/Biblioteki
45 Requires:       %{name} = %{version}
46
47 %description devel
48 Header files and development documentation for curl library.
49
50 %package static
51 Summary:        Static version of curl library
52 Summary(pl):    Statyczna wersja biblioteki curl
53 Group:          Development/Libraries
54 Group(de):      Entwicklung/Libraries
55 Group(fr):      Development/Librairies
56 Group(pl):      Programowanie/Biblioteki
57 Requires:       %{name}-devel = %{version}
58
59 %description static
60 Static version of curl library
61
62
63 %prep
64 %setup -q 
65
66 %build
67 %configure \
68         --with-ssl=/usr
69 %{__make} 
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install DESTDIR=$RPM_BUILD_ROOT
75
76 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/*.gz
87 %attr(755,root,root) %{_bindir}/%{name}
88 %attr(755,root,root) %{_libdir}/lib*.so.*
89 %{_mandir}/man1/*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_libdir}/lib*.so
94 %attr(755,root,root) %{_libdir}/lib*.la
95 %{_mandir}/man3/*
96 %{_includedir}/*
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
This page took 0.060554 seconds and 4 git commands to generate.