]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- 7.9, STBR
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(pl):    narzêdziem do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
3 Name:           curl
4 Version:        7.9
5 Release:        1
6 License:        MPL
7 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
8 Group:          Applications/Networking
9 Group(de):      Applikationen/Netzwerkwesen
10 Group(pl):      Aplikacje/Sieciowe
11 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-no_strip.patch
13 URL:            http://curl.haxx.se/
14 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 cURL is a tool for getting files with URL syntax, supporting FTP,
19 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
20 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
21 cookies, user+password authentication and a busload of other useful
22 tricks. The main use for curl is when you want to get or send files
23 automatically to or from a site using one of the supported protocols.
24
25 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
26 Dict servers, using any of the supported protocols. cURL is designed
27 to work without user interaction or any kind of interactivity. cURL
28 offers many useful capabilities, like proxy support, user
29 authentication, FTP upload, HTTP post, and file transfer resume.
30
31 %description -l pl
32 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
33 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
34 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
35 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
36 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
37 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
38 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
39
40 %package devel
41 Summary:        Header files and development documentation for curl library
42 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
43 Group:          Development/Libraries
44 Group(de):      Entwicklung/Libraries
45 Group(fr):      Development/Librairies
46 Group(pl):      Programowanie/Biblioteki
47 Requires:       %{name} = %{version}
48
49 %description devel
50 Header files and development documentation for curl library.
51
52 %description -l pl devel
53 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
54
55 %package static
56 Summary:        Static version of curl library
57 Summary(pl):    Statyczna wersja biblioteki curl
58 Group:          Development/Libraries
59 Group(de):      Entwicklung/Libraries
60 Group(fr):      Development/Librairies
61 Group(pl):      Programowanie/Biblioteki
62 Requires:       %{name}-devel = %{version}
63
64 %description static
65 Static version of curl library.
66
67 %description -l pl static
68 Statyczna wersja biblioteki curl.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 %configure \
76         %{!?_without_ssl:--with-ssl=%{_prefix}} \
77         --with-ipv6
78
79 %{__make} 
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install DESTDIR=$RPM_BUILD_ROOT
85
86 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc docs/*.gz
97 %attr(755,root,root) %{_bindir}/%{name}
98 %attr(755,root,root) %{_libdir}/lib*.so.*.*
99 %{_mandir}/man1/*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/%{name}-config
104 %attr(755,root,root) %{_libdir}/lib*.so
105 %attr(755,root,root) %{_libdir}/lib*.la
106 %{_mandir}/man3/*
107 %{_includedir}/*
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/lib*.a
This page took 0.030611 seconds and 4 git commands to generate.