]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- rel 2
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares    # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh     # without SSH support
5 %bcond_without  ssl     # without SSL support
6 %bcond_without  krb5    # without MIT Kerberos 5 support
7 #
8 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
9 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
10 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
11 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
12 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
13 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
14 Name:           curl
15 Version:        7.16.1
16 Release:        2
17 License:        MIT-like
18 Group:          Applications/Networking
19 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
20 # Source0-md5:  acdab0b0467c55e10ed02d2afed80575
21 Patch0:         %{name}-no_strip.patch
22 Patch1:         %{name}-ac.patch
23 URL:            http://curl.haxx.se/
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake
26 %{?with_ares:BuildRequires:     c-ares-devel}
27 %{?with_krb5:BuildRequires:     krb5-devel}
28 BuildRequires:  libidn-devel >= 0.4.1
29 %{?with_ssh:BuildRequires:      libssh2-devel}
30 BuildRequires:  libtool
31 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
32 BuildRequires:  zlib-devel
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       libidn >= 0.4.1
35 Requires:       openssl-tools >= 0.9.7d
36 Obsoletes:      libcurl2
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 cURL is a tool for getting files with URL syntax, supporting FTP,
41 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
42 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
43 cookies, user+password authentication and a busload of other useful
44 tricks. The main use for curl is when you want to get or send files
45 automatically to or from a site using one of the supported protocols.
46
47 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48 Dict servers, using any of the supported protocols. cURL is designed
49 to work without user interaction or any kind of interactivity. cURL
50 offers many useful capabilities, like proxy support, user
51 authentication, FTP upload, HTTP post, and file transfer resume.
52
53 %description -l pl.UTF-8
54 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
55 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
56 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
57 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
58 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
59 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
60 pliki z/na serwer używając jednego z dostępnych protokołów.
61 %{?with_ssl:Ten pakiet obsługuje także SSL.}
62
63 %description -l pt_BR.UTF-8
64 Curl é um cliente para baixar/enviar arquivos de/para servidores
65 usando um dos protocolos suportados. É projetado para funcionar sem a
66 interação do usuário.
67
68 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
69 continuar transferências interrompidas, e mais...
70
71 %description -l ru.UTF-8
72 curl - это клиент с множеством поддерживаемых протоколов для получения
73 файлов с серверов, спроектированный для работы как в неинтерактивном
74 режиме, так и с возможностью диалога с пользователем.
75
76 curl поддерживает много полезных возможностей, среди которых поддержка
77 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
78 POST, восстановление прерванной пересылки и многое другое.
79
80 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
81 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
82 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
83
84 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
85 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
86 в╕дновлення перервано╖ пересилки та багато ╕ншого.
87
88 %package libs
89 Summary:        curl library
90 Summary(pl.UTF-8):      Biblioteka curl
91 Group:          Libraries
92
93 %description libs
94 curl library.
95
96 %description libs -l pl.UTF-8
97 Biblioteka curl.
98
99 %package devel
100 Summary:        Header files and development documentation for curl library
101 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
102 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
103 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
104 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
105 Group:          Development/Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107 %{?with_ares:Requires:  c-ares-devel}
108 %{?with_krb5:Requires:  krb5-devel}
109 Requires:       libidn-devel >= 0.4.1
110 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
111 Requires:       zlib-devel
112 Obsoletes:      libcurl2-devel
113
114 %description devel
115 Header files and development documentation for curl library.
116
117 %description devel -l pl.UTF-8
118 Pliki nagłówkowe i dokumentacja do biblioteki curl.
119
120 %description devel -l pt_BR.UTF-8
121 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
122
123 %description devel -l ru.UTF-8
124 Этот пакет содержит файлы, необходимые для разработки программ с
125 использованием библиотеки curl.
126
127 %description devel -l uk.UTF-8
128 Цей пакет містить файли, необхідні для розробки програм з
129 використанням бібліотеки curl.
130
131 %package static
132 Summary:        Static version of curl library
133 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
134 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
135 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
136 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139
140 %description static
141 Static version of curl library.
142
143 %description static -l pl.UTF-8
144 Statyczna wersja biblioteki curl.
145
146 %description static -l pt_BR.UTF-8
147 Bibliotecas estáticas para desenvolvimento com o curl.
148
149 %description static -l ru.UTF-8
150 Этот пакет содержит статическую библиотеку для разработки программ с
151 использованием библиотеки curl.
152
153 %description static -l uk.UTF-8
154 Цей пакет містить статичну бібліотеку для розробки програм з
155 використанням бібліотеки curl.
156
157 %prep
158 %setup -q
159 %patch0 -p1
160 %patch1 -p1
161
162 %build
163 %{__libtoolize}
164 %{__aclocal}
165 %{__autoconf}
166 %{__autoheader}
167 %{__automake}
168 %configure \
169         %{?with_ssl:--with-ssl=%{_prefix}} \
170         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
171         %{?with_krb5:--with-gssapi=%{_prefix}} \
172         %{?with_ares:--enable-ares=%{_prefix}} \
173         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
174
175 %{__make}
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post   libs -p /sbin/ldconfig
187 %postun libs -p /sbin/ldconfig
188
189 %files
190 %defattr(644,root,root,755)
191 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
192 %attr(755,root,root) %{_bindir}/curl
193 %{_mandir}/man1/curl.1*
194
195 %files libs
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
198
199 %files devel
200 %defattr(644,root,root,755)
201 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
202 %attr(755,root,root) %{_bindir}/curl-config
203 %attr(755,root,root) %{_libdir}/libcurl.so
204 %{_libdir}/libcurl.la
205 %{_includedir}/curl
206 %{_pkgconfigdir}/libcurl.pc
207 %{_mandir}/man1/curl-config.1*
208 %{_mandir}/man3/*curl*.3*
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libcurl.a
This page took 0.040776 seconds and 4 git commands to generate.