]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 6.3.1,
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others).
2 Name:           curl
3 Version:        6.3.1
4 Release:        1
5 Copyright:      MPL
6 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
7 Group:          Applications/Networking
8 Group(pl):      Aplikacje/Sieciowe
9 Source:         http://curl.haxx.nu/stuff/%{name}-%{version}.tar.gz
10 URL:            http://curl.haxx.nu/
11 BuildRequires:  openssl-devel
12 BuildRoot:      /tmp/%{name}-%{version}-root
13
14 %description
15 cURL is a tool for getting files with URL syntax, supporting FTP, HTTP,
16 HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP POST, HTTP
17 PUT, FTP uploading, HTTP form based upload, proxies, cookies, user+password
18 authentication and a busload of other useful tricks. The main use for curl
19 is when you want to get or send files automatically to or from a site using
20 one of the supported protocols.
21
22 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and Dict
23 servers, using any of the supported protocols. cURL is designed to work
24 without user interaction or any kind of interactivity. cURL offers many
25 useful capabilities, like proxy support, user authentication, FTP upload,
26 HTTP post, and file transfer resume. Note that while cURL also supports the
27 SSL protocol, this version is compiled without SSL (https:) support.
28
29 %prep
30 %setup -q 
31
32 %build
33 LDFLAGS="-s"; export LDFLAGS
34 %configure \
35         --with-ssl=/usr
36 make 
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 make DESTDIR=$RPM_BUILD_ROOT install
41
42 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
43         README* CHANGES CONTRIBUTE FAQ LEGAL MPL-1.0.txt RESOURCES TODO
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc *.gz
50 %attr(755,root,root) %{_bindir}/curl
51 %{_mandir}/man1/*
This page took 0.092742 seconds and 4 git commands to generate.