]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- bcond desc
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without MIT Kerberos 5 support
8 #
9 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
10 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
11 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
12 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
13 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
14 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
15 Name:           curl
16 Version:        7.18.2
17 Release:        1
18 License:        MIT-like
19 Group:          Applications/Networking
20 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
21 # Source0-md5:  c389be5b0525276e58865956b7465562
22 Patch0:         %{name}-no_strip.patch
23 Patch1:         %{name}-ac.patch
24 Patch2:         %{name}-pc.patch
25 URL:            http://curl.haxx.se/
26 BuildRequires:  autoconf >= 2.57
27 BuildRequires:  automake
28 %{?with_ares:BuildRequires:     c-ares-devel}
29 %{?with_kerberos5:BuildRequires:        krb5-devel}
30 BuildRequires:  libidn-devel >= 0.4.1
31 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
32 BuildRequires:  libtool
33 BuildRequires:  openldap-devel
34 %if %{with ssl}
35 %if %{with gnutls}
36 BuildRequires:  gnutls-devel
37 %else
38 BuildRequires:  openssl-devel >= 0.9.7d
39 %endif
40 %endif
41 BuildRequires:  zlib-devel
42 Requires:       %{name}-libs = %{version}-%{release}
43 Requires:       libidn >= 0.4.1
44 %{?with_ssh:Requires:   libssh2 >= 0.16}
45 Requires:       openssl-tools >= 0.9.7d
46 Obsoletes:      libcurl2
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 cURL is a tool for getting files with URL syntax, supporting FTP,
51 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
52 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
53 cookies, user+password authentication and a busload of other useful
54 tricks. The main use for curl is when you want to get or send files
55 automatically to or from a site using one of the supported protocols.
56
57 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58 Dict servers, using any of the supported protocols. cURL is designed
59 to work without user interaction or any kind of interactivity. cURL
60 offers many useful capabilities, like proxy support, user
61 authentication, FTP upload, HTTP post, and file transfer resume.
62
63 %description -l pl.UTF-8
64 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
65 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
66 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
67 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
68 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
69 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
70 pliki z/na serwer używając jednego z dostępnych protokołów.
71 %{?with_ssl:Ten pakiet obsługuje także SSL.}
72
73 %description -l pt_BR.UTF-8
74 Curl é um cliente para baixar/enviar arquivos de/para servidores
75 usando um dos protocolos suportados. É projetado para funcionar sem a
76 interação do usuário.
77
78 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
79 continuar transferências interrompidas, e mais...
80
81 %description -l ru.UTF-8
82 curl - это клиент с множеством поддерживаемых протоколов для получения
83 файлов с серверов, спроектированный для работы как в неинтерактивном
84 режиме, так и с возможностью диалога с пользователем.
85
86 curl поддерживает много полезных возможностей, среди которых поддержка
87 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
88 POST, восстановление прерванной пересылки и многое другое.
89
90 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
91 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
92 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
93
94 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
95 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
96 в╕дновлення перервано╖ пересилки та багато ╕ншого.
97
98 %package libs
99 Summary:        curl library
100 Summary(pl.UTF-8):      Biblioteka curl
101 Group:          Libraries
102
103 %description libs
104 curl library.
105
106 %description libs -l pl.UTF-8
107 Biblioteka curl.
108
109 %package devel
110 Summary:        Header files and development documentation for curl library
111 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
112 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
113 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
114 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
115 Group:          Development/Libraries
116 Requires:       %{name}-libs = %{version}-%{release}
117 %{?with_ares:Requires:  c-ares-devel}
118 %{?with_kerberos5:Requires:     krb5-devel}
119 Requires:       libidn-devel >= 0.4.1
120 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
121 %if %{with ssl}
122 %if %{with gnutls}
123 Requires:       gnutls-devel
124 %else
125 Requires:       openssl-devel >= 0.9.7c
126 %endif
127 %endif
128 Requires:       zlib-devel
129 Obsoletes:      libcurl2-devel
130
131 %description devel
132 Header files and development documentation for curl library.
133
134 %description devel -l pl.UTF-8
135 Pliki nagłówkowe i dokumentacja do biblioteki curl.
136
137 %description devel -l pt_BR.UTF-8
138 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
139
140 %description devel -l ru.UTF-8
141 Этот пакет содержит файлы, необходимые для разработки программ с
142 использованием библиотеки curl.
143
144 %description devel -l uk.UTF-8
145 Цей пакет містить файли, необхідні для розробки програм з
146 використанням бібліотеки curl.
147
148 %package static
149 Summary:        Static version of curl library
150 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
151 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
152 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
153 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156
157 %description static
158 Static version of curl library.
159
160 %description static -l pl.UTF-8
161 Statyczna wersja biblioteki curl.
162
163 %description static -l pt_BR.UTF-8
164 Bibliotecas estáticas para desenvolvimento com o curl.
165
166 %description static -l ru.UTF-8
167 Этот пакет содержит статическую библиотеку для разработки программ с
168 использованием библиотеки curl.
169
170 %description static -l uk.UTF-8
171 Цей пакет містить статичну бібліотеку для розробки програм з
172 використанням бібліотеки curl.
173
174 %prep
175 %setup -q
176 %patch0 -p1
177 %patch1 -p1
178 %patch2 -p1
179
180 %build
181 %{__libtoolize}
182 %{__aclocal}
183 %{__autoconf}
184 %{__autoheader}
185 %{__automake}
186 %configure \
187         ac_cv_header_gss_h=no \
188 %if %{with ssl}
189         --with-ca-bundle=/usr/share/ssl/ca-bundle.crt \
190 %if %{with gnutls}
191         --with-gnutls=%{_prefix} --without-ssl \
192 %else
193         --with-ssl=%{_prefix} \
194 %endif
195 %endif
196         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
197         %{?with_ares:--enable-ares=%{_prefix}} \
198         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
199
200 %{__make}
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204
205 %{__make} install \
206         DESTDIR=$RPM_BUILD_ROOT
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %post   libs -p /sbin/ldconfig
212 %postun libs -p /sbin/ldconfig
213
214 %files
215 %defattr(644,root,root,755)
216 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
217 %attr(755,root,root) %{_bindir}/curl
218 %{_mandir}/man1/curl.1*
219
220 %files libs
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
223 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
224
225 %files devel
226 %defattr(644,root,root,755)
227 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
228 %attr(755,root,root) %{_bindir}/curl-config
229 %attr(755,root,root) %{_libdir}/libcurl.so
230 %{_libdir}/libcurl.la
231 %{_includedir}/curl
232 %{_pkgconfigdir}/libcurl.pc
233 %{_mandir}/man1/curl-config.1*
234 %{_mandir}/man3/curl_*.3*
235 %{_mandir}/man3/libcurl*.3*
236
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/libcurl.a
This page took 0.077902 seconds and 4 git commands to generate.