]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- changed all BuildRoot definitons
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Name:           curl
3 Version:        6.5.2
4 Release:        1
5 License:        MPL
6 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
7 Group:          Applications/Networking
8 Group(pl):      Aplikacje/Sieciowe
9 Source:         http://curl.haxx.nu/stuff/%{name}-%{version}.tar.gz
10 URL:            http://curl.haxx.nu/
11 BuildRequires:  openssl-devel
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 cURL is a tool for getting files with URL syntax, supporting FTP, HTTP,
16 HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP POST, HTTP
17 PUT, FTP uploading, HTTP form based upload, proxies, cookies, user+password
18 authentication and a busload of other useful tricks. The main use for curl
19 is when you want to get or send files automatically to or from a site using
20 one of the supported protocols.
21
22 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and Dict
23 servers, using any of the supported protocols. cURL is designed to work
24 without user interaction or any kind of interactivity. cURL offers many
25 useful capabilities, like proxy support, user authentication, FTP upload,
26 HTTP post, and file transfer resume. Note that while cURL also supports the
27 SSL protocol, this version is compiled without SSL (https:) support.
28
29 %description -l pl
30 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP, HTTP,
31 HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿ HTTP POST,
32 HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP oparte na 
33 formularzu, serwery proksy, ciasteczka, autoryzacja u¿ytkownik/has³o oraz 
34 wiele innych u¿ytecznych sztuczek. Curla u¿ywa siê g³ównie wtedy, kiedy chce 
35 siê automatycznie ¶ci±gn±æ lub wys³aæ pliki z/na serwer u¿ywaj±c jednego
36 z dostêpnych protoko³ów.
37 Chocia¿ cURL obs³uguje równie¿ protokó³ SSL, wersja ta jest skompilowana
38 bez obs³ugi SSL (https:).
39
40 %prep
41 %setup -q 
42
43 %build
44 LDFLAGS="-s"; export LDFLAGS
45 %configure \
46         --with-ssl=/usr
47 make 
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 make DESTDIR=$RPM_BUILD_ROOT install
52
53 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
54         README* CHANGES CONTRIBUTE FAQ LEGAL MPL-1.0.txt RESOURCES TODO
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc *.gz
61 %attr(755,root,root) %{_bindir}/curl
62 %{_mandir}/man1/*
This page took 0.030153 seconds and 4 git commands to generate.