]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.21.3
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
8 %bcond_without  rtmp            # without Real Time Media Protocol
9 #
10 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
11 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
12 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
13 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
14 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
15 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
16 Name:           curl
17 Version:        7.21.3
18 Release:        1
19 License:        MIT-like
20 Group:          Applications/Networking
21 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
22 # Source0-md5:  04f45add29bd9d314811193fc8bd8817
23 Patch0:         %{name}-no_strip.patch
24 Patch1:         %{name}-ac.patch
25 Patch2:         %{name}-pc.patch
26 Patch3:         %{name}-krb5flags.patch
27 Patch4:         libcurl.fb-changes.diff
28 URL:            http://curl.haxx.se/
29 BuildRequires:  autoconf >= 2.57
30 BuildRequires:  automake
31 %{?with_ares:BuildRequires:     c-ares-devel}
32 %{?with_kerberos5:BuildRequires:        heimdal-devel}
33 BuildRequires:  libidn-devel >= 0.4.1
34 %{?with_rtmp:BuildRequires:     librtmp-devel}
35 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
36 BuildRequires:  libtool
37 BuildRequires:  openldap-devel
38 %if %{with ssl}
39 %if %{with gnutls}
40 BuildRequires:  gnutls-devel
41 %else
42 BuildRequires:  openssl-devel >= 0.9.7d
43 %endif
44 %endif
45 BuildRequires:  tar >= 1:1.22
46 BuildRequires:  zlib-devel
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       libidn >= 0.4.1
49 %{?with_ssh:Requires:   libssh2 >= 0.16}
50 Requires:       openssl-tools >= 0.9.7d
51 Obsoletes:      libcurl2
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 cURL is a tool for getting files with URL syntax, supporting FTP,
56 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
57 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
58 cookies, user+password authentication and a busload of other useful
59 tricks. The main use for curl is when you want to get or send files
60 automatically to or from a site using one of the supported protocols.
61
62 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
63 Dict servers, using any of the supported protocols. cURL is designed
64 to work without user interaction or any kind of interactivity. cURL
65 offers many useful capabilities, like proxy support, user
66 authentication, FTP upload, HTTP post, and file transfer resume.
67
68 %description -l pl.UTF-8
69 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
70 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
71 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
72 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
73 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
74 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
75 pliki z/na serwer używając jednego z dostępnych protokołów.
76 %{?with_ssl:Ten pakiet obsługuje także SSL.}
77
78 %description -l pt_BR.UTF-8
79 Curl é um cliente para baixar/enviar arquivos de/para servidores
80 usando um dos protocolos suportados. É projetado para funcionar sem a
81 interação do usuário.
82
83 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
84 continuar transferências interrompidas, e mais...
85
86 %description -l ru.UTF-8
87 curl - это клиент с множеством поддерживаемых протоколов для получения
88 файлов с серверов, спроектированный для работы как в неинтерактивном
89 режиме, так и с возможностью диалога с пользователем.
90
91 curl поддерживает много полезных возможностей, среди которых поддержка
92 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
93 POST, восстановление прерванной пересылки и многое другое.
94
95 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
96 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
97 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
98
99 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
100 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
101 в╕дновлення перервано╖ пересилки та багато ╕ншого.
102
103 %package libs
104 Summary:        curl library
105 Summary(pl.UTF-8):      Biblioteka curl
106 Group:          Libraries
107 Suggests:       ca-certificates
108 Conflicts:      ca-certificates < 20080809-4
109
110 %description libs
111 curl library.
112
113 %description libs -l pl.UTF-8
114 Biblioteka curl.
115
116 %package devel
117 Summary:        Header files and development documentation for curl library
118 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
119 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
120 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
121 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
122 Group:          Development/Libraries
123 Requires:       %{name}-libs = %{version}-%{release}
124 %{?with_ares:Requires:  c-ares-devel}
125 %{?with_kerberos5:Requires:     heimdal-devel}
126 Requires:       libidn-devel >= 0.4.1
127 %{?with_rtmp:Requires:  librtmp-devel}
128 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
129 Requires:       openldap-devel
130 %if %{with ssl}
131 %if %{with gnutls}
132 Requires:       gnutls-devel
133 %else
134 Requires:       openssl-devel >= 0.9.7c
135 %endif
136 %endif
137 Requires:       zlib-devel
138 Obsoletes:      libcurl2-devel
139
140 %description devel
141 Header files and development documentation for curl library.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe i dokumentacja do biblioteki curl.
145
146 %description devel -l pt_BR.UTF-8
147 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
148
149 %description devel -l ru.UTF-8
150 Этот пакет содержит файлы, необходимые для разработки программ с
151 использованием библиотеки curl.
152
153 %description devel -l uk.UTF-8
154 Цей пакет містить файли, необхідні для розробки програм з
155 використанням бібліотеки curl.
156
157 %package static
158 Summary:        Static version of curl library
159 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
160 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
161 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
162 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165
166 %description static
167 Static version of curl library.
168
169 %description static -l pl.UTF-8
170 Statyczna wersja biblioteki curl.
171
172 %description static -l pt_BR.UTF-8
173 Bibliotecas estáticas para desenvolvimento com o curl.
174
175 %description static -l ru.UTF-8
176 Этот пакет содержит статическую библиотеку для разработки программ с
177 использованием библиотеки curl.
178
179 %description static -l uk.UTF-8
180 Цей пакет містить статичну бібліотеку для розробки програм з
181 використанням бібліотеки curl.
182
183 %prep
184 %setup -q
185 %patch0 -p1
186 %patch1 -p1
187 %patch2 -p1
188 %patch3 -p1
189 %patch4 -p1
190
191 %build
192 %{__libtoolize}
193 %{__aclocal} -I m4
194 %{__autoconf}
195 %{__autoheader}
196 %{__automake}
197 %configure \
198         ac_cv_header_gss_h=no \
199 %if %{with ssl}
200         --with-ca-bundle=/etc/certs/ca-certificates.crt \
201 %if %{with gnutls}
202         --with-gnutls --without-ssl \
203 %else
204         --with-ssl=%{_prefix} \
205 %endif
206 %endif
207         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
208         %{?with_rtmp:--with-librtmp} \
209         %{?with_ares:--enable-ares} \
210         --enable-ldaps \
211         --enable-ipv6
212
213 %{__make}
214
215 %install
216 rm -rf $RPM_BUILD_ROOT
217
218 %{__make} install \
219         DESTDIR=$RPM_BUILD_ROOT
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224 %post   libs -p /sbin/ldconfig
225 %postun libs -p /sbin/ldconfig
226
227 %files
228 %defattr(644,root,root,755)
229 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
230 %attr(755,root,root) %{_bindir}/curl
231 %{_mandir}/man1/curl.1*
232
233 %files libs
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
236 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
237
238 %files devel
239 %defattr(644,root,root,755)
240 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
241 %attr(755,root,root) %{_bindir}/curl-config
242 %attr(755,root,root) %{_libdir}/libcurl.so
243 %{_libdir}/libcurl.la
244 %{_includedir}/curl
245 %{_pkgconfigdir}/libcurl.pc
246 %{_mandir}/man1/curl-config.1*
247 %{_mandir}/man3/curl_*.3*
248 %{_mandir}/man3/libcurl*.3*
249
250 %files static
251 %defattr(644,root,root,755)
252 %{_libdir}/libcurl.a
This page took 0.0442 seconds and 4 git commands to generate.