]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- 7.9.4 Bugfixes
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(es):    Busca URL (soporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP y HTTPS)
3 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
4 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
5 Name:           curl
6 Version:        7.9.4
7 Release:        1
8 License:        MPL
9 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
10 Group:          Applications/Networking
11 Group(de):      Applikationen/Netzwerkwesen
12 Group(pl):      Aplikacje/Sieciowe
13 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
14 Patch0:         %{name}-no_strip.patch
15 URL:            http://curl.haxx.se/
16 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Obsoletes:      libcurl2
19
20 %description
21 cURL is a tool for getting files with URL syntax, supporting FTP,
22 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
23 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
24 cookies, user+password authentication and a busload of other useful
25 tricks. The main use for curl is when you want to get or send files
26 automatically to or from a site using one of the supported protocols.
27
28 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
29 Dict servers, using any of the supported protocols. cURL is designed
30 to work without user interaction or any kind of interactivity. cURL
31 offers many useful capabilities, like proxy support, user
32 authentication, FTP upload, HTTP post, and file transfer resume.
33
34 %description -l es
35 Curl es un cliente para bajar documentos/archivos de servidores usando
36 uno de los protocolos soportados. Está proyectado para funcionar sin
37 interacción del usuario.
38
39 Curl trabaja con proxy, autenticación, ftp put, HTTP post, y puede
40 continuar transferencias interrumpidas, y además...
41
42 %description -l pl
43 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
44 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
45 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
46 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
47 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
48 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
49 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
50
51 Uwaga: ten pakiet wspiera takze SSL.
52
53 %description -l pt_BR
54 Curl é um cliente para baixar/enviar arquivos de/para servidores
55 usando um dos protocolos suportados. É projetado para funcionar sem a
56 interação do usuário.
57
58 Curl trabalha com proxy, autenticação, ftp put, HTTP post, e pode
59 continuar transferências interrompidas, e mais...
60
61 %package devel
62 Summary:        Header files and development documentation for curl library
63 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
64 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
65 Group:          Development/Libraries
66 Group(de):      Entwicklung/Libraries
67 Group(es):      Desarrollo/Bibliotecas
68 Group(fr):      Development/Librairies
69 Group(pl):      Programowanie/Biblioteki
70 Group(pt_BR):   Desenvolvimento/Bibliotecas
71 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
72 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
73 Requires:       %{name} = %{version}
74 Obsoletes:      libcurl2-devel
75
76 %description devel
77 Header files and development documentation for curl library.
78
79 %description -l pl devel
80 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
81
82 %description -l pt_BR devel
83 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
84
85 %package static
86 Summary:        Static version of curl library
87 Summary(pl):    Statyczna wersja biblioteki curl
88 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
89 Group:          Development/Libraries
90 Group(de):      Entwicklung/Libraries
91 Group(es):      Desarrollo/Bibliotecas
92 Group(fr):      Development/Librairies
93 Group(pl):      Programowanie/Biblioteki
94 Group(pt_BR):   Desenvolvimento/Bibliotecas
95 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
96 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
97 Requires:       %{name}-devel = %{version}
98
99 %description static
100 Static version of curl library.
101
102 %description -l pl static
103 Statyczna wersja biblioteki curl.
104
105 %description -l pt_BR static
106 Bibliotecas estáticas para desenvolvimento com o curl.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 %build
113 %configure \
114         %{!?_without_ssl:--with-ssl=%{_prefix}} \
115         --with-ipv6
116
117 %{__make} 
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install DESTDIR=$RPM_BUILD_ROOT
123
124 gzip -9nf CHANGES LEGAL README docs/TheArtOfHttpScripting \
125         docs/{BUGS,CONTRIBUTE,FAQ,FEATURES,INTERNALS,MANUAL,README*,RESOURCES,THANKS,TODO}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc *.gz docs/*.gz
136 %attr(755,root,root) %{_bindir}/%{name}
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138 %{_mandir}/man1/*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/%{name}-config
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %attr(755,root,root) %{_libdir}/lib*.la
145 %{_includedir}/*
146 %{_mandir}/man3/*
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/lib*.a
This page took 0.093377 seconds and 4 git commands to generate.