]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
switch to new conditional builds macros (bcond_on_ -> _with_/bcond_off_ -> _without_...
[packages/curl.git] / curl.spec
1 %define         ver     7.7.4 
2 %define         prerel  pre2
3  
4 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
5 Summary(pl):    narzêdziem do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
6 Name:           curl
7 Version:        %{ver}%{prerel}
8 Release:        1
9 License:        MPL
10 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
11 Group:          Applications/Networking
12 Group(de):      Applikationen/Netzwerkwesen
13 Group(pl):      Aplikacje/Sieciowe
14 Source0:        http://curl.haxx.se/stuff/%{name}-%{ver}-%{prerel}.tar.gz
15 URL:            http://curl.haxx.se/
16 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 cURL is a tool for getting files with URL syntax, supporting FTP,
21 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
22 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
23 cookies, user+password authentication and a busload of other useful
24 tricks. The main use for curl is when you want to get or send files
25 automatically to or from a site using one of the supported protocols.
26
27 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
28 Dict servers, using any of the supported protocols. cURL is designed
29 to work without user interaction or any kind of interactivity. cURL
30 offers many useful capabilities, like proxy support, user
31 authentication, FTP upload, HTTP post, and file transfer resume.
32
33 %description -l pl
34 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
35 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
36 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
37 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
38 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
39 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
40 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
41
42 %package devel
43 Summary:        Header files and development documentation for curl library
44 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
45 Group:          Development/Libraries
46 Group(de):      Entwicklung/Libraries
47 Group(fr):      Development/Librairies
48 Group(pl):      Programowanie/Biblioteki
49 Requires:       %{name} = %{version}
50
51 %description devel
52 Header files and development documentation for curl library.
53
54 %description -l pl devel
55 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
56
57 %package static
58 Summary:        Static version of curl library
59 Summary(pl):    Statyczna wersja biblioteki curl
60 Group:          Development/Libraries
61 Group(de):      Entwicklung/Libraries
62 Group(fr):      Development/Librairies
63 Group(pl):      Programowanie/Biblioteki
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Static version of curl library.
68
69 %description -l pl static
70 Statyczna wersja biblioteki curl.
71
72 %prep
73 %setup -q -n %{name}-%{ver}-%{prerel}
74
75 %build
76 %configure \
77         %{!?_without_ssl:--with-ssl=/usr}
78
79 %{__make} 
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install DESTDIR=$RPM_BUILD_ROOT
85
86 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc docs/*.gz
97 %attr(755,root,root) %{_bindir}/%{name}
98 %attr(755,root,root) %{_libdir}/lib*.so.*.*
99 %{_mandir}/man1/*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/%{name}-config
104 %attr(755,root,root) %{_libdir}/lib*.so
105 %attr(755,root,root) %{_libdir}/lib*.la
106 %{_mandir}/man3/*
107 %{_includedir}/*
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/lib*.a
This page took 0.054138 seconds and 4 git commands to generate.