]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- remove libtool m4, allows building with older libtool
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
8 %bcond_without  rtmp            # without Real Time Media Protocol
9 %bcond_without  ldap            # without LDAP support
10 #
11 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
12 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
13 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
14 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
15 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
16 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
17 Name:           curl
18 Version:        7.22.0
19 Release:        1
20 License:        MIT-like
21 Group:          Applications/Networking
22 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
23 # Source0-md5:  2fd7d848e143b32a42bf2a28af7caab0
24 Patch0:         %{name}-no_strip.patch
25 Patch1:         %{name}-ac.patch
26 Patch2:         %{name}-pc.patch
27 Patch3:         %{name}-krb5flags.patch
28 Patch4:         libcurl.fb-changes.diff
29 URL:            http://curl.haxx.se/
30 BuildRequires:  autoconf >= 2.57
31 BuildRequires:  automake
32 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
33 %{?with_kerberos5:BuildRequires:        heimdal-devel}
34 BuildRequires:  libidn-devel >= 0.4.1
35 %{?with_rtmp:BuildRequires:     librtmp-devel}
36 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
37 BuildRequires:  libtool
38 %{?with_ldap:BuildRequires:     openldap-devel}
39 BuildRequires:  pkgconfig
40 %if %{with ssl}
41 %if %{with gnutls}
42 BuildRequires:  gnutls-devel
43 %else
44 BuildRequires:  openssl-devel >= 0.9.7d
45 %endif
46 %endif
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  zlib-devel
49 Requires:       %{name}-libs = %{version}-%{release}
50 Requires:       libidn >= 0.4.1
51 %{?with_ssh:Requires:   libssh2 >= 0.16}
52 Obsoletes:      libcurl2
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 cURL is a tool for getting files with URL syntax, supporting FTP,
57 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
58 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
59 cookies, user+password authentication and a busload of other useful
60 tricks. The main use for curl is when you want to get or send files
61 automatically to or from a site using one of the supported protocols.
62
63 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
64 Dict servers, using any of the supported protocols. cURL is designed
65 to work without user interaction or any kind of interactivity. cURL
66 offers many useful capabilities, like proxy support, user
67 authentication, FTP upload, HTTP post, and file transfer resume.
68
69 %description -l pl.UTF-8
70 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
71 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
72 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
73 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
74 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
75 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
76 pliki z/na serwer używając jednego z dostępnych protokołów.
77 %{?with_ssl:Ten pakiet obsługuje także SSL.}
78
79 %description -l pt_BR.UTF-8
80 Curl é um cliente para baixar/enviar arquivos de/para servidores
81 usando um dos protocolos suportados. É projetado para funcionar sem a
82 interação do usuário.
83
84 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
85 continuar transferências interrompidas, e mais...
86
87 %description -l ru.UTF-8
88 curl - это клиент с множеством поддерживаемых протоколов для получения
89 файлов с серверов, спроектированный для работы как в неинтерактивном
90 режиме, так и с возможностью диалога с пользователем.
91
92 curl поддерживает много полезных возможностей, среди которых поддержка
93 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
94 POST, восстановление прерванной пересылки и многое другое.
95
96 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
97 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
98 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
99
100 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
101 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
102 в╕дновлення перервано╖ пересилки та багато ╕ншого.
103
104 %package libs
105 Summary:        curl library
106 Summary(pl.UTF-8):      Biblioteka curl
107 Group:          Libraries
108 Suggests:       ca-certificates
109 Conflicts:      ca-certificates < 20080809-4
110 %{?with_ares:Requires:  c-ares >= 1.7.0}
111
112 %description libs
113 curl library.
114
115 %description libs -l pl.UTF-8
116 Biblioteka curl.
117
118 %package devel
119 Summary:        Header files and development documentation for curl library
120 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
121 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
122 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
123 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
124 Group:          Development/Libraries
125 Requires:       %{name}-libs = %{version}-%{release}
126 %{?with_ares:Requires:  c-ares-devel}
127 %{?with_kerberos5:Requires:     heimdal-devel}
128 Requires:       libidn-devel >= 0.4.1
129 %{?with_rtmp:Requires:  librtmp-devel}
130 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
131 %{?with_ldap:Requires:  openldap-devel}
132 %if %{with ssl}
133 %if %{with gnutls}
134 Requires:       gnutls-devel
135 %else
136 Requires:       openssl-devel >= 0.9.7c
137 %endif
138 %endif
139 Requires:       zlib-devel
140 Obsoletes:      libcurl2-devel
141
142 %description devel
143 Header files and development documentation for curl library.
144
145 %description devel -l pl.UTF-8
146 Pliki nagłówkowe i dokumentacja do biblioteki curl.
147
148 %description devel -l pt_BR.UTF-8
149 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
150
151 %description devel -l ru.UTF-8
152 Этот пакет содержит файлы, необходимые для разработки программ с
153 использованием библиотеки curl.
154
155 %description devel -l uk.UTF-8
156 Цей пакет містить файли, необхідні для розробки програм з
157 використанням бібліотеки curl.
158
159 %package static
160 Summary:        Static version of curl library
161 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
162 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
163 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
164 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167
168 %description static
169 Static version of curl library.
170
171 %description static -l pl.UTF-8
172 Statyczna wersja biblioteki curl.
173
174 %description static -l pt_BR.UTF-8
175 Bibliotecas estáticas para desenvolvimento com o curl.
176
177 %description static -l ru.UTF-8
178 Этот пакет содержит статическую библиотеку для разработки программ с
179 использованием библиотеки curl.
180
181 %description static -l uk.UTF-8
182 Цей пакет містить статичну бібліотеку для розробки програм з
183 використанням бібліотеки curl.
184
185 %prep
186 %setup -q
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p1
192
193 %{__rm} -v m4/lt*.m4 m4/libtool.m4
194
195 %build
196 %{__libtoolize}
197 %{__aclocal} -I m4
198 %{__autoconf}
199 %{__autoheader}
200 %{__automake}
201 %configure \
202         ac_cv_header_gss_h=no \
203 %if %{with ssl}
204         --with-ca-bundle=/etc/certs/ca-certificates.crt \
205 %if %{with gnutls}
206         --with-gnutls --without-ssl \
207 %else
208         --with-ssl=%{_prefix} \
209 %endif
210 %endif
211         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
212         %{?with_rtmp:--with-librtmp} \
213         %{?with_ares:--enable-ares} \
214         %{?with_ldap:--enable-ldaps} \
215         %{!?with_ldap:--disable-ldap} \
216         --enable-ipv6
217
218 %{__make}
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222
223 %{__make} install \
224         DESTDIR=$RPM_BUILD_ROOT
225
226 # no longer in upstream but a lot of apps tries to include it so we create fake one
227 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
228 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
229
230 %clean
231 rm -rf $RPM_BUILD_ROOT
232
233 %post   libs -p /sbin/ldconfig
234 %postun libs -p /sbin/ldconfig
235
236 %files
237 %defattr(644,root,root,755)
238 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
239 %attr(755,root,root) %{_bindir}/curl
240 %{_mandir}/man1/curl.1*
241
242 %files libs
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
245 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
246
247 %files devel
248 %defattr(644,root,root,755)
249 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
250 %attr(755,root,root) %{_bindir}/curl-config
251 %attr(755,root,root) %{_libdir}/libcurl.so
252 %{_libdir}/libcurl.la
253 %{_includedir}/curl
254 %{_pkgconfigdir}/libcurl.pc
255 %{_mandir}/man1/curl-config.1*
256 %{_mandir}/man3/curl_*.3*
257 %{_mandir}/man3/libcurl*.3*
258
259 %files static
260 %defattr(644,root,root,755)
261 %{_libdir}/libcurl.a
This page took 0.151882 seconds and 4 git commands to generate.