]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 7.3
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Name:           curl
3 Version:        7.3
4 Release:        1
5 License:        MPL
6 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
7 Group:          Applications/Networking
8 Group(pl):      Aplikacje/Sieciowe
9 Source0:        http://curl.haxx.nu/stuff/%{name}-%{version}.tar.gz
10 URL:            http://curl.haxx.nu/
11 BuildRequires:  openssl-devel
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 cURL is a tool for getting files with URL syntax, supporting FTP,
16 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
17 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
18 cookies, user+password authentication and a busload of other useful
19 tricks. The main use for curl is when you want to get or send files
20 automatically to or from a site using one of the supported protocols.
21
22 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
23 Dict servers, using any of the supported protocols. cURL is designed
24 to work without user interaction or any kind of interactivity. cURL
25 offers many useful capabilities, like proxy support, user
26 authentication, FTP upload, HTTP post, and file transfer resume. 
27
28 %description -l pl
29 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
30 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
31 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
32 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
33 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
34 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
35 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów. 
36
37 %package devel
38 Summary:        Header files and development documentation for curl library
39 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
40 Group:          Development/Libraries
41 Group(fr):      Development/Librairies
42 Group(pl):      Programowanie/Biblioteki
43 Requires:       %{name} = %{version}
44
45 %description devel
46 Header files and development documentation for curl library.
47
48 %package static
49 Summary:        Static version of curl library
50 Summary(pl):    Statyczna wersja biblioteki curl
51 Group:          Development/Libraries
52 Group(fr):      Development/Librairies
53 Group(pl):      Programowanie/Biblioteki
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 Static version of curl library
58
59
60 %prep
61 %setup -q 
62
63 %build
64 LDFLAGS="-s"; export LDFLAGS
65 %configure --with-ssl=/usr
66 %{__make} 
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} DESTDIR=$RPM_BUILD_ROOT install
71 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %attr(755,root,root) %{_bindir}/%{name}
82 %attr(755,root,root) %{_libdir}/lib*.so.*
83 %{_mandir}/man1/*
84 %doc docs/*.gz
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/lib*.so
89 %attr(755,root,root) %{_libdir}/lib*.la
90 %{_mandir}/man3/*
91 %{_includedir}/*
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/lib*.a
This page took 0.095123 seconds and 4 git commands to generate.