]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- CVE-2009-0037 security blocker
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without MIT Kerberos 5 support
8 #
9 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
10 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
11 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
12 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
13 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
14 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
15 Name:           curl
16 Version:        7.19.3
17 Release:        1
18 License:        MIT-like
19 Group:          Applications/Networking
20 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
21 # Source0-md5:  10eb8c13350c735eff20d7b4530be8cd
22 Patch0:         %{name}-no_strip.patch
23 Patch1:         %{name}-ac.patch
24 Patch2:         %{name}-pc.patch
25 Patch3:         %{name}-krb5flags.patch
26 URL:            http://curl.haxx.se/
27 # http://curl.haxx.se/docs/adv_20090303.html
28 # Patch or 7.19.4 upgrade needed
29 BuildRequires:  security(CVE-2009-0037)
30 BuildRequires:  autoconf >= 2.57
31 BuildRequires:  automake
32 %{?with_ares:BuildRequires:     c-ares-devel}
33 %{?with_kerberos5:BuildRequires:        krb5-devel}
34 BuildRequires:  libidn-devel >= 0.4.1
35 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
36 BuildRequires:  libtool
37 BuildRequires:  openldap-devel
38 %if %{with ssl}
39 %if %{with gnutls}
40 BuildRequires:  gnutls-devel
41 %else
42 BuildRequires:  openssl-devel >= 0.9.7d
43 %endif
44 %endif
45 BuildRequires:  zlib-devel
46 Requires:       %{name}-libs = %{version}-%{release}
47 Requires:       libidn >= 0.4.1
48 %{?with_ssh:Requires:   libssh2 >= 0.16}
49 Requires:       openssl-tools >= 0.9.7d
50 Obsoletes:      libcurl2
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 cURL is a tool for getting files with URL syntax, supporting FTP,
55 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
56 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
57 cookies, user+password authentication and a busload of other useful
58 tricks. The main use for curl is when you want to get or send files
59 automatically to or from a site using one of the supported protocols.
60
61 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
62 Dict servers, using any of the supported protocols. cURL is designed
63 to work without user interaction or any kind of interactivity. cURL
64 offers many useful capabilities, like proxy support, user
65 authentication, FTP upload, HTTP post, and file transfer resume.
66
67 %description -l pl.UTF-8
68 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
69 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
70 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
71 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
72 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
73 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
74 pliki z/na serwer używając jednego z dostępnych protokołów.
75 %{?with_ssl:Ten pakiet obsługuje także SSL.}
76
77 %description -l pt_BR.UTF-8
78 Curl é um cliente para baixar/enviar arquivos de/para servidores
79 usando um dos protocolos suportados. É projetado para funcionar sem a
80 interação do usuário.
81
82 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
83 continuar transferências interrompidas, e mais...
84
85 %description -l ru.UTF-8
86 curl - это клиент с множеством поддерживаемых протоколов для получения
87 файлов с серверов, спроектированный для работы как в неинтерактивном
88 режиме, так и с возможностью диалога с пользователем.
89
90 curl поддерживает много полезных возможностей, среди которых поддержка
91 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
92 POST, восстановление прерванной пересылки и многое другое.
93
94 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
95 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
96 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
97
98 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
99 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
100 в╕дновлення перервано╖ пересилки та багато ╕ншого.
101
102 %package libs
103 Summary:        curl library
104 Summary(pl.UTF-8):      Biblioteka curl
105 Group:          Libraries
106 Suggests:       ca-certificates
107 Conflicts:      ca-certificates < 20080809-4
108
109 %description libs
110 curl library.
111
112 %description libs -l pl.UTF-8
113 Biblioteka curl.
114
115 %package devel
116 Summary:        Header files and development documentation for curl library
117 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
118 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
119 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
120 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
121 Group:          Development/Libraries
122 Requires:       %{name}-libs = %{version}-%{release}
123 %{?with_ares:Requires:  c-ares-devel}
124 %{?with_kerberos5:Requires:     krb5-devel}
125 Requires:       libidn-devel >= 0.4.1
126 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
127 %if %{with ssl}
128 %if %{with gnutls}
129 Requires:       gnutls-devel
130 %else
131 Requires:       openssl-devel >= 0.9.7c
132 %endif
133 %endif
134 Requires:       zlib-devel
135 Obsoletes:      libcurl2-devel
136
137 %description devel
138 Header files and development documentation for curl library.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe i dokumentacja do biblioteki curl.
142
143 %description devel -l pt_BR.UTF-8
144 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
145
146 %description devel -l ru.UTF-8
147 Этот пакет содержит файлы, необходимые для разработки программ с
148 использованием библиотеки curl.
149
150 %description devel -l uk.UTF-8
151 Цей пакет містить файли, необхідні для розробки програм з
152 використанням бібліотеки curl.
153
154 %package static
155 Summary:        Static version of curl library
156 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
157 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
158 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
159 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
160 Group:          Development/Libraries
161 Requires:       %{name}-devel = %{version}-%{release}
162
163 %description static
164 Static version of curl library.
165
166 %description static -l pl.UTF-8
167 Statyczna wersja biblioteki curl.
168
169 %description static -l pt_BR.UTF-8
170 Bibliotecas estáticas para desenvolvimento com o curl.
171
172 %description static -l ru.UTF-8
173 Этот пакет содержит статическую библиотеку для разработки программ с
174 использованием библиотеки curl.
175
176 %description static -l uk.UTF-8
177 Цей пакет містить статичну бібліотеку для розробки програм з
178 використанням бібліотеки curl.
179
180 %prep
181 %setup -q
182 %patch0 -p1
183 %patch1 -p1
184 %patch2 -p1
185 %patch3 -p1
186
187 %build
188 %{__libtoolize}
189 %{__aclocal} -I m4
190 %{__autoconf}
191 %{__autoheader}
192 %{__automake}
193 %configure \
194         ac_cv_header_gss_h=no \
195 %if %{with ssl}
196         --with-ca-bundle=/etc/certs/ca-certificates.crt \
197 %if %{with gnutls}
198         --with-gnutls=%{_prefix} --without-ssl \
199 %else
200         --with-ssl=%{_prefix} \
201 %endif
202 %endif
203         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
204         %{?with_ares:--enable-ares=%{_prefix}} \
205         --enable-ldaps \
206         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
207
208 %{__make}
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212
213 %{__make} install \
214         DESTDIR=$RPM_BUILD_ROOT
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post   libs -p /sbin/ldconfig
220 %postun libs -p /sbin/ldconfig
221
222 %files
223 %defattr(644,root,root,755)
224 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
225 %attr(755,root,root) %{_bindir}/curl
226 %{_mandir}/man1/curl.1*
227
228 %files libs
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
231 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
232
233 %files devel
234 %defattr(644,root,root,755)
235 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
236 %attr(755,root,root) %{_bindir}/curl-config
237 %attr(755,root,root) %{_libdir}/libcurl.so
238 %{_libdir}/libcurl.la
239 %{_includedir}/curl
240 %{_pkgconfigdir}/libcurl.pc
241 %{_mandir}/man1/curl-config.1*
242 %{_mandir}/man3/curl_*.3*
243 %{_mandir}/man3/libcurl*.3*
244
245 %files static
246 %defattr(644,root,root,755)
247 %{_libdir}/libcurl.a
This page took 0.05557 seconds and 4 git commands to generate.