]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.19.5
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without MIT Kerberos 5 support
8 #
9 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
10 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
11 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
12 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
13 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
14 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
15 Name:           curl
16 Version:        7.19.5
17 Release:        1
18 License:        MIT-like
19 Group:          Applications/Networking
20 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
21 # Source0-md5:  e4612af6cc471879ae0f4727457eb6fc
22 Patch0:         %{name}-no_strip.patch
23 Patch1:         %{name}-ac.patch
24 Patch2:         %{name}-pc.patch
25 Patch3:         %{name}-krb5flags.patch
26 URL:            http://curl.haxx.se/
27 BuildRequires:  autoconf >= 2.57
28 BuildRequires:  automake
29 %{?with_ares:BuildRequires:     c-ares-devel}
30 %{?with_kerberos5:BuildRequires:        krb5-devel}
31 BuildRequires:  libidn-devel >= 0.4.1
32 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
33 BuildRequires:  libtool
34 BuildRequires:  openldap-devel
35 %if %{with ssl}
36 %if %{with gnutls}
37 BuildRequires:  gnutls-devel
38 %else
39 BuildRequires:  openssl-devel >= 0.9.7d
40 %endif
41 %endif
42 BuildRequires:  zlib-devel
43 Requires:       %{name}-libs = %{version}-%{release}
44 Requires:       libidn >= 0.4.1
45 %{?with_ssh:Requires:   libssh2 >= 0.16}
46 Requires:       openssl-tools >= 0.9.7d
47 Obsoletes:      libcurl2
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 cURL is a tool for getting files with URL syntax, supporting FTP,
52 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
53 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
54 cookies, user+password authentication and a busload of other useful
55 tricks. The main use for curl is when you want to get or send files
56 automatically to or from a site using one of the supported protocols.
57
58 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
59 Dict servers, using any of the supported protocols. cURL is designed
60 to work without user interaction or any kind of interactivity. cURL
61 offers many useful capabilities, like proxy support, user
62 authentication, FTP upload, HTTP post, and file transfer resume.
63
64 %description -l pl.UTF-8
65 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
66 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
67 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
68 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
69 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
70 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
71 pliki z/na serwer używając jednego z dostępnych protokołów.
72 %{?with_ssl:Ten pakiet obsługuje także SSL.}
73
74 %description -l pt_BR.UTF-8
75 Curl é um cliente para baixar/enviar arquivos de/para servidores
76 usando um dos protocolos suportados. É projetado para funcionar sem a
77 interação do usuário.
78
79 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
80 continuar transferências interrompidas, e mais...
81
82 %description -l ru.UTF-8
83 curl - это клиент с множеством поддерживаемых протоколов для получения
84 файлов с серверов, спроектированный для работы как в неинтерактивном
85 режиме, так и с возможностью диалога с пользователем.
86
87 curl поддерживает много полезных возможностей, среди которых поддержка
88 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
89 POST, восстановление прерванной пересылки и многое другое.
90
91 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
92 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
93 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
94
95 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
96 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
97 в╕дновлення перервано╖ пересилки та багато ╕ншого.
98
99 %package libs
100 Summary:        curl library
101 Summary(pl.UTF-8):      Biblioteka curl
102 Group:          Libraries
103 Suggests:       ca-certificates
104 Conflicts:      ca-certificates < 20080809-4
105
106 %description libs
107 curl library.
108
109 %description libs -l pl.UTF-8
110 Biblioteka curl.
111
112 %package devel
113 Summary:        Header files and development documentation for curl library
114 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
115 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
116 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
117 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
118 Group:          Development/Libraries
119 Requires:       %{name}-libs = %{version}-%{release}
120 %{?with_ares:Requires:  c-ares-devel}
121 %{?with_kerberos5:Requires:     krb5-devel}
122 Requires:       libidn-devel >= 0.4.1
123 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
124 %if %{with ssl}
125 %if %{with gnutls}
126 Requires:       gnutls-devel
127 %else
128 Requires:       openssl-devel >= 0.9.7c
129 %endif
130 %endif
131 Requires:       zlib-devel
132 Obsoletes:      libcurl2-devel
133
134 %description devel
135 Header files and development documentation for curl library.
136
137 %description devel -l pl.UTF-8
138 Pliki nagłówkowe i dokumentacja do biblioteki curl.
139
140 %description devel -l pt_BR.UTF-8
141 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
142
143 %description devel -l ru.UTF-8
144 Этот пакет содержит файлы, необходимые для разработки программ с
145 использованием библиотеки curl.
146
147 %description devel -l uk.UTF-8
148 Цей пакет містить файли, необхідні для розробки програм з
149 використанням бібліотеки curl.
150
151 %package static
152 Summary:        Static version of curl library
153 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
154 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
155 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
156 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
157 Group:          Development/Libraries
158 Requires:       %{name}-devel = %{version}-%{release}
159
160 %description static
161 Static version of curl library.
162
163 %description static -l pl.UTF-8
164 Statyczna wersja biblioteki curl.
165
166 %description static -l pt_BR.UTF-8
167 Bibliotecas estáticas para desenvolvimento com o curl.
168
169 %description static -l ru.UTF-8
170 Этот пакет содержит статическую библиотеку для разработки программ с
171 использованием библиотеки curl.
172
173 %description static -l uk.UTF-8
174 Цей пакет містить статичну бібліотеку для розробки програм з
175 використанням бібліотеки curl.
176
177 %prep
178 %setup -q
179 %patch0 -p1
180 %patch1 -p1
181 %patch2 -p1
182 %patch3 -p1
183
184 %build
185 %{__libtoolize}
186 %{__aclocal} -I m4
187 %{__autoconf}
188 %{__autoheader}
189 %{__automake}
190 %configure \
191         ac_cv_header_gss_h=no \
192 %if %{with ssl}
193         --with-ca-bundle=/etc/certs/ca-certificates.crt \
194 %if %{with gnutls}
195         --with-gnutls=%{_prefix} --without-ssl \
196 %else
197         --with-ssl=%{_prefix} \
198 %endif
199 %endif
200         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
201         %{?with_ares:--enable-ares=%{_prefix}} \
202         --enable-ldaps \
203         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
204
205 %{__make}
206
207 %install
208 rm -rf $RPM_BUILD_ROOT
209
210 %{__make} install \
211         DESTDIR=$RPM_BUILD_ROOT
212
213 %clean
214 rm -rf $RPM_BUILD_ROOT
215
216 %post   libs -p /sbin/ldconfig
217 %postun libs -p /sbin/ldconfig
218
219 %files
220 %defattr(644,root,root,755)
221 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
222 %attr(755,root,root) %{_bindir}/curl
223 %{_mandir}/man1/curl.1*
224
225 %files libs
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
228 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
229
230 %files devel
231 %defattr(644,root,root,755)
232 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
233 %attr(755,root,root) %{_bindir}/curl-config
234 %attr(755,root,root) %{_libdir}/libcurl.so
235 %{_libdir}/libcurl.la
236 %{_includedir}/curl
237 %{_pkgconfigdir}/libcurl.pc
238 %{_mandir}/man1/curl-config.1*
239 %{_mandir}/man3/curl_*.3*
240 %{_mandir}/man3/libcurl*.3*
241
242 %files static
243 %defattr(644,root,root,755)
244 %{_libdir}/libcurl.a
This page took 0.091913 seconds and 4 git commands to generate.