]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- adapterized.
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
3 Name:           curl
4 Version:        7.9
5 Release:        2
6 License:        MPL
7 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
8 Group:          Applications/Networking
9 Group(de):      Applikationen/Netzwerkwesen
10 Group(pl):      Aplikacje/Sieciowe
11 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-no_strip.patch
13 Patch1:         %{name}-readtimeout-fix.patch
14 URL:            http://curl.haxx.se/
15 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 cURL is a tool for getting files with URL syntax, supporting FTP,
20 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
21 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
22 cookies, user+password authentication and a busload of other useful
23 tricks. The main use for curl is when you want to get or send files
24 automatically to or from a site using one of the supported protocols.
25
26 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
27 Dict servers, using any of the supported protocols. cURL is designed
28 to work without user interaction or any kind of interactivity. cURL
29 offers many useful capabilities, like proxy support, user
30 authentication, FTP upload, HTTP post, and file transfer resume.
31
32 %description -l pl
33 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
34 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
35 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
36 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
37 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
38 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
39 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
40
41 %package devel
42 Summary:        Header files and development documentation for curl library
43 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
44 Group:          Development/Libraries
45 Group(de):      Entwicklung/Libraries
46 Group(es):      Desarrollo/Bibliotecas
47 Group(fr):      Development/Librairies
48 Group(pl):      Programowanie/Biblioteki
49 Group(pt_BR):   Desenvolvimento/Bibliotecas
50 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
51 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
52 Requires:       %{name} = %{version}
53
54 %description devel
55 Header files and development documentation for curl library.
56
57 %description -l pl devel
58 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
59
60 %package static
61 Summary:        Static version of curl library
62 Summary(pl):    Statyczna wersja biblioteki curl
63 Group:          Development/Libraries
64 Group(de):      Entwicklung/Libraries
65 Group(es):      Desarrollo/Bibliotecas
66 Group(fr):      Development/Librairies
67 Group(pl):      Programowanie/Biblioteki
68 Group(pt_BR):   Desenvolvimento/Bibliotecas
69 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
70 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
71 Requires:       %{name}-devel = %{version}
72
73 %description static
74 Static version of curl library.
75
76 %description -l pl static
77 Statyczna wersja biblioteki curl.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 
83
84 %build
85 %configure \
86         %{!?_without_ssl:--with-ssl=%{_prefix}} \
87         --with-ipv6
88
89 %{__make} 
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install DESTDIR=$RPM_BUILD_ROOT
95
96 gzip -9nf CHANGES LEGAL README docs/TheArtOfHttpScripting
97 gzip -9nf docs/{BUGS,CONTRIBUTE,FAQ,FEATURES,INTERNALS,MANUAL,README*,RESOURCES,THANKS,TODO}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc *.gz docs/*.gz
108 %attr(755,root,root) %{_bindir}/%{name}
109 %attr(755,root,root) %{_libdir}/lib*.so.*.*
110 %{_mandir}/man1/*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/%{name}-config
115 %attr(755,root,root) %{_libdir}/lib*.so
116 %attr(755,root,root) %{_libdir}/lib*.la
117 %{_mandir}/man3/*
118 %{_includedir}/*
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/lib*.a
This page took 0.041115 seconds and 3 git commands to generate.