]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- don't print endl if progress callback is set
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(pl):    narzêdziem do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
3 Name:           curl
4 Version:        7.8
5 Release:        3
6 License:        MPL
7 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
8 Group:          Applications/Networking
9 Group(de):      Applikationen/Netzwerkwesen
10 Group(pl):      Aplikacje/Sieciowe
11 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-so.patch
13 Patch1:         %{name}-no_strip.patch
14 URL:            http://curl.haxx.se/
15 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 cURL is a tool for getting files with URL syntax, supporting FTP,
20 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
21 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
22 cookies, user+password authentication and a busload of other useful
23 tricks. The main use for curl is when you want to get or send files
24 automatically to or from a site using one of the supported protocols.
25
26 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
27 Dict servers, using any of the supported protocols. cURL is designed
28 to work without user interaction or any kind of interactivity. cURL
29 offers many useful capabilities, like proxy support, user
30 authentication, FTP upload, HTTP post, and file transfer resume.
31
32 %description -l pl
33 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
34 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
35 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
36 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
37 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
38 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
39 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
40
41 %package devel
42 Summary:        Header files and development documentation for curl library
43 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
44 Group:          Development/Libraries
45 Group(de):      Entwicklung/Libraries
46 Group(fr):      Development/Librairies
47 Group(pl):      Programowanie/Biblioteki
48 Requires:       %{name} = %{version}
49
50 %description devel
51 Header files and development documentation for curl library.
52
53 %description -l pl devel
54 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
55
56 %package static
57 Summary:        Static version of curl library
58 Summary(pl):    Statyczna wersja biblioteki curl
59 Group:          Development/Libraries
60 Group(de):      Entwicklung/Libraries
61 Group(fr):      Development/Librairies
62 Group(pl):      Programowanie/Biblioteki
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Static version of curl library.
67
68 %description -l pl static
69 Statyczna wersja biblioteki curl.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75
76 %build
77 %configure \
78         %{!?_without_ssl:--with-ssl=%{_prefix}} \
79         --with-ipv6
80
81 %{__make} 
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install DESTDIR=$RPM_BUILD_ROOT
87
88 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc docs/*.gz
99 %attr(755,root,root) %{_bindir}/%{name}
100 %attr(755,root,root) %{_libdir}/lib*.so.*.*
101 %{_mandir}/man1/*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/%{name}-config
106 %attr(755,root,root) %{_libdir}/lib*.so
107 %attr(755,root,root) %{_libdir}/lib*.la
108 %{_mandir}/man3/*
109 %{_includedir}/*
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/lib*.a
This page took 0.05472 seconds and 3 git commands to generate.