]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- added progress-fix.patch (release 4)
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(pl):    narzêdziem do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
3 Name:           curl
4 Version:        7.8
5 Release:        4
6 License:        MPL
7 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
8 Group:          Applications/Networking
9 Group(de):      Applikationen/Netzwerkwesen
10 Group(pl):      Aplikacje/Sieciowe
11 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-so.patch
13 Patch1:         %{name}-no_strip.patch
14 Patch2:         %{name}-progress-fix.patch
15 URL:            http://curl.haxx.se/
16 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.6a}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 cURL is a tool for getting files with URL syntax, supporting FTP,
21 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
22 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
23 cookies, user+password authentication and a busload of other useful
24 tricks. The main use for curl is when you want to get or send files
25 automatically to or from a site using one of the supported protocols.
26
27 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
28 Dict servers, using any of the supported protocols. cURL is designed
29 to work without user interaction or any kind of interactivity. cURL
30 offers many useful capabilities, like proxy support, user
31 authentication, FTP upload, HTTP post, and file transfer resume.
32
33 %description -l pl
34 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
35 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
36 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
37 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
38 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
39 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
40 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
41
42 %package devel
43 Summary:        Header files and development documentation for curl library
44 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
45 Group:          Development/Libraries
46 Group(de):      Entwicklung/Libraries
47 Group(fr):      Development/Librairies
48 Group(pl):      Programowanie/Biblioteki
49 Requires:       %{name} = %{version}
50
51 %description devel
52 Header files and development documentation for curl library.
53
54 %description -l pl devel
55 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
56
57 %package static
58 Summary:        Static version of curl library
59 Summary(pl):    Statyczna wersja biblioteki curl
60 Group:          Development/Libraries
61 Group(de):      Entwicklung/Libraries
62 Group(fr):      Development/Librairies
63 Group(pl):      Programowanie/Biblioteki
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Static version of curl library.
68
69 %description -l pl static
70 Statyczna wersja biblioteki curl.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75 %patch1 -p1
76 %patch2 -p0
77
78 %build
79 %configure \
80         %{!?_without_ssl:--with-ssl=%{_prefix}} \
81         --with-ipv6
82
83 %{__make} 
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install DESTDIR=$RPM_BUILD_ROOT
89
90 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc docs/*.gz
101 %attr(755,root,root) %{_bindir}/%{name}
102 %attr(755,root,root) %{_libdir}/lib*.so.*.*
103 %{_mandir}/man1/*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/%{name}-config
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %attr(755,root,root) %{_libdir}/lib*.la
110 %{_mandir}/man3/*
111 %{_includedir}/*
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib*.a
This page took 0.069574 seconds and 3 git commands to generate.