]> git.pld-linux.org Git - packages/ctl.git/blob - ctl.spec
- new
[packages/ctl.git] / ctl.spec
1 Summary:        Color Transform Language libraries
2 Summary(pl.UTF-8):      Biblioteki CTL (języka przekształceń kolorów)
3 Name:           ctl
4 Version:        1.4.1
5 Release:        1
6 License:        BSD + IP clause
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/ampasctl/%{name}-%{version}.tar.gz
9 # Source0-md5:  11e215aea6c6380833ade3b576660638
10 URL:            http://www.oscars.org/council/ctl.html
11 BuildRequires:  ilmbase-devel >= 1.0.1
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  pkgconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 CTL (Color Transform Language) interpreter contains the following C++
18 libraries:
19
20 IlmCtl - CTL interpreter frontend and the interpreter's public
21 programming interface.
22
23 IlmCtlSimd - interpreter's SIMD backend.
24
25 IlmCtlMath - math routines used by IlmCtlSimd: conversions between
26 standard color spaces, 1D and 3D lookup tables, 3D scattered data
27 interpolation.
28
29 %description -l pl.UTF-8
30 Interpreter CTL (Color Transform Language - języka przekształceń
31 kolorów) składa się z następujących bibliotek C++:
32
33 IlmCtl - frontend interpretera CTL i jego publiczny interfejs
34 programistyczny.
35
36 IlmCtlSimd - backend SIMD interpretera.
37
38 IlmCtlMath - funkcje matematyczne wykorzystywane przez IlmCtlSimd:
39 przekształcenia między standardowymi przestrzeniami kolorów, tablice
40 wyszukiwań 1D i 3D, interpolacja zgromadzonych danych 3D.
41
42 %package devel
43 Summary:        Header files for CTL library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CTL
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       ilmbase-devel >= 1.0.1
48 Requires:       libstdc++-devel
49
50 %description devel
51 Header files for CTL library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki CTL.
55
56 %package static
57 Summary:        Static CTL library
58 Summary(pl.UTF-8):      Statyczna biblioteka CTL
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static CTL library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka CTL.
67
68 %prep
69 %setup -q
70
71 %build
72 %configure
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS COPYING ChangeLog NEWS README
90 %attr(755,root,root) %{_libdir}/libIlmCtl.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libIlmCtl.so.2
92 %attr(755,root,root) %{_libdir}/libIlmCtlMath.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libIlmCtlMath.so.2
94 %attr(755,root,root) %{_libdir}/libIlmCtlSimd.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libIlmCtlSimd.so.2
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc doc/CtlManual.pdf
100 %attr(755,root,root) %{_libdir}/libIlmCtl.so
101 %attr(755,root,root) %{_libdir}/libIlmCtlMath.so
102 %attr(755,root,root) %{_libdir}/libIlmCtlSimd.so
103 %{_libdir}/libIlmCtl.la
104 %{_libdir}/libIlmCtlMath.la
105 %{_libdir}/libIlmCtlSimd.la
106 %{_includedir}/CTL
107 %{_pkgconfigdir}/CTL.pc
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libIlmCtl.a
112 %{_libdir}/libIlmCtlMath.a
113 %{_libdir}/libIlmCtlSimd.a
This page took 0.080914 seconds and 3 git commands to generate.