]> git.pld-linux.org Git - packages/crossmingw32-pcre.git/blob - crossmingw32-pcre.spec
- filterout_cxx too
[packages/crossmingw32-pcre.git] / crossmingw32-pcre.spec
1 %define         realname        pcre
2 Summary:        Perl-Compatible Regular Expression library - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka perlowych wyrażeń regularnych - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        8.31
6 Release:        1
7 License:        BSD (see LICENCE)
8 Group:          Development/Libraries
9 Source0:        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  1c9a276af932b5599157f96e945391f0
11 URL:            http://www.pcre.org/
12 BuildRequires:  autoconf >= 2.57
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  crossmingw32-w32api
16 BuildRequires:  libtool >= 2:1.5
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target          i386-mingw32
23 %define         target_platform i386-pc-mingw32
24
25 %define         _prefix         /usr/%{target}
26 %define         _libdir         %{_prefix}/lib
27 %define         _pkgconfigdir   %{_prefix}/lib/pkgconfig
28 %define         _dlldir         /usr/share/wine/windows/system
29
30 %define         __cc            %{target}-gcc
31 %define         __cxx           %{target}-g++
32
33 %ifnarch %{ix86}
34 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
35 %define         optflags        -O2
36 %endif
37 # -z options are invalid for mingw linker, most of -f options are Linux-specific
38 %define         filterout_ld    -Wl,-z,.*
39 %define         filterout_c     -f[-a-z0-9=]*
40 %define         filterout_cxx   -f[-a-z0-9=]*
41
42 %description
43 PCRE stands for the Perl Compatible Regular Expression library. It
44 contains routines to match text against regular expressions similar to
45 Perl's. It also contains a POSIX compatibility library.
46
47 %description -l pl.UTF-8
48 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
49 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
50 tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
51 Zawiera także bibliotekę kompatybilną z POSIX.
52
53 %package static
54 Summary:        Static PCRE libraries (cross MinGW32 version)
55 Summary(pl.UTF-8):      Statyczne biblioteki PCRE (wersja skrośna MinGW32)
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description static
60 Static PCRE libraries (cross MinGW32 version).
61
62 %description static -l pl.UTF-8
63 Statyczne biblioteki PCRE (wersja skrośna MinGW32).
64
65 %package dll
66 Summary:        %{realname} - DLL libraries for Windows
67 Summary(pl.UTF-8):      %{realname} - biblioteki DLL dla Windows
68 Group:          Applications/Emulators
69 Requires:       wine
70
71 %description dll
72 %{realname} - DLL libraries for Windows.
73
74 %description dll -l pl.UTF-8
75 %{realname} - biblioteki DLL dla Windows.
76
77 %prep
78 %setup -q -n %{realname}-%{version}
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --host=%{target} \
88         --target=%{target} \
89         --enable-jit \
90         --enable-pcre16 \
91         --enable-unicode-properties \
92         --enable-utf8
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_dlldir}
103 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
104
105 %if 0%{!?debug:1}
106 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
107 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
108 %endif
109
110 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog LICENCE NEWS NON-UNIX-USE README
118 %{_libdir}/libpcre.dll.a
119 %{_libdir}/libpcre16.dll.a
120 %{_libdir}/libpcrecpp.dll.a
121 %{_libdir}/libpcreposix.dll.a
122 %{_libdir}/libpcre.la
123 %{_libdir}/libpcre16.la
124 %{_libdir}/libpcrecpp.la
125 %{_libdir}/libpcreposix.la
126 %{_includedir}/pcre*.h
127 %{_pkgconfigdir}/libpcre.pc
128 %{_pkgconfigdir}/libpcre16.pc
129 %{_pkgconfigdir}/libpcrecpp.pc
130 %{_pkgconfigdir}/libpcreposix.pc
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libpcre.a
135 %{_libdir}/libpcre16.a
136 %{_libdir}/libpcrecpp.a
137 %{_libdir}/libpcreposix.a
138
139 %files dll
140 %defattr(644,root,root,755)
141 %{_dlldir}/libpcre-1.dll
142 %{_dlldir}/libpcre16-0.dll
143 %{_dlldir}/libpcrecpp-0.dll
144 %{_dlldir}/libpcreposix-0.dll
This page took 0.071279 seconds and 3 git commands to generate.