]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- updated to 1.22.0
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross Mingw32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla Mingw32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.22.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.22/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  37a185a3cb5c1a39ade7fdc3e6c75349
11 Patch0:         %{realname}-xfonts.patch
12 Patch1:         %{realname}-lt.patch
13 URL:            http://www.pango.org/
14 BuildRequires:  autoconf >= 2.59-9
15 BuildRequires:  automake >= 1:1.9
16 BuildRequires:  crossmingw32-cairo >= 1.8.0
17 BuildRequires:  crossmingw32-fontconfig >= 2.4.0
18 BuildRequires:  crossmingw32-freetype >= 2.1.7
19 BuildRequires:  crossmingw32-gcc
20 BuildRequires:  crossmingw32-glib2 >= 2.18.0
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.197
25 Requires:       crossmingw32-cairo >= 1.8.0
26 Requires:       crossmingw32-fontconfig >= 2.4.0
27 Requires:       crossmingw32-freetype >= 2.1.7
28 Requires:       crossmingw32-glib2 >= 2.18.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43
44 %ifnarch %{ix86}
45 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46 %define         optflags        -O2
47 %endif
48 # -z options are invalid for mingw linker
49 %define         filterout_ld    -Wl,-z,.*
50
51 %description
52 System for layout and rendering of internationalized text (cross
53 mingw32 version).
54
55 %description -l pl.UTF-8
56 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
57 mingw32).
58
59 %package dll
60 Summary:        DLL pango libraries for Windows
61 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
62 Group:          Applications/Emulators
63 Requires:       crossmingw32-cairo-dll >= 1.8.0
64 Requires:       crossmingw32-fontconfig-dll >= 2.4.0
65 Requires:       crossmingw32-freetype-dll >= 2.1.7
66 Requires:       crossmingw32-glib2-dll >= 2.18.0
67 Requires:       wine
68
69 %description dll
70 DLL pango libraries for Windows.
71
72 %description dll -l pl.UTF-8
73 Biblioteki DLL pango dla Windows.
74
75 %prep
76 %setup -q -n %{realname}-%{version}
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoheader}
85 %{__autoconf}
86 %{__automake}
87 %configure \
88         --target=%{target} \
89         --host=%{target}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 # missing from make install but required by it
97 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
98
99 %{__make} -j1 install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_dlldir}
103 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
104
105 %if 0%{!?debug:1}
106 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
107 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
108 %endif
109
110 rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
111 # useless (modules loaded through libgmodule)
112 rm -f $RPM_BUILD_ROOT%{_libdir}/pango/1.6.0/modules/*.{la,a}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS NEWS README
120 %{_libdir}/libpango-1.0.dll.a
121 %{_libdir}/libpangocairo-1.0.dll.a
122 %{_libdir}/libpangoft2-1.0.dll.a
123 %{_libdir}/libpangowin32-1.0.dll.a
124 %{_libdir}/libpango-1.0.la
125 %{_libdir}/libpangocairo-1.0.la
126 %{_libdir}/libpangoft2-1.0.la
127 %{_libdir}/libpangowin32-1.0.la
128 %{_libdir}/pango-1.0.def
129 %{_libdir}/pangocairo-1.0.def
130 %{_libdir}/pangoft2-1.0.def
131 %{_libdir}/pangowin32-1.0.def
132 %{_includedir}/pango-1.0
133 %{_pkgconfigdir}/pango.pc
134 %{_pkgconfigdir}/pangocairo.pc
135 %{_pkgconfigdir}/pangoft2.pc
136 %{_pkgconfigdir}/pangowin32.pc
137
138 %files dll
139 %defattr(644,root,root,755)
140 %{_dlldir}/libpango-1.0-*.dll
141 %{_dlldir}/libpangocairo-1.0-*.dll
142 %{_dlldir}/libpangoft2-1.0-*.dll
143 %{_dlldir}/libpangowin32-1.0-*.dll
This page took 0.040207 seconds and 4 git commands to generate.