]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
- updated to 2.2.10
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - MinGW32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.2.10
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.xz
10 # Source0-md5:  73419b477f3bb9ddb9905c88a92f4b4c
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  libtool
16 BuildRequires:  m4
17 BuildRequires:  mm-common >= 0.7.2
18 BuildRequires:  perl-base
19 BuildRequires:  pkgconfig
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       crossmingw32-runtime
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker
43 %define         filterout_ld    -Wl,-z,.*
44
45 %description
46 This library implements a full callback system for use in widget
47 libraries, abstract interfaces, and general programming. Originally
48 part of the Gtk-- widget set, libsigc++ is now a seperate library to
49 provide for more general use. It is the most complete library of its
50 kind with the ablity to connect an abstract callback to a class
51 method, function, or function object. It contains adaptor classes for
52 connection of dissimilar callbacks and has an ease of use unmatched by
53 other C++ callback libraries.
54
55 This package contains cross MinGW32 version.
56
57 %description -l pl.UTF-8
58 Ta biblioteka jest implementacją pełnego systemu callbacków do
59 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
60 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
61 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
62 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
63 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
64 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
65 callbacków.
66
67 Ten pakiet zawiera wersję skrośną MinGW32.
68
69 %package static
70 Summary:        Static libsigc++ library (cross MinGW32 version)
71 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description static
76 Static libsigc++ library (cross MinGW32 version).
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
80
81 %package dll
82 Summary:        DLL libsigc++ library for Windows
83 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
84 Group:          Applications/Emulators
85 Requires:       wine
86
87 %description dll
88 DLL libsigc++ library for Windows.
89
90 %description dll -l pl.UTF-8
91 Biblioteka DLL libsigc++ dla Windows.
92
93 %prep
94 %setup -q -n %{realname}-%{version}
95
96 %build
97 %{__libtoolize}
98 %{__aclocal} -I build
99 %{__autoconf}
100 %{__automake}
101 %configure \
102         --target=%{target} \
103         --host=%{target} \
104         --enable-static
105
106 %{__make} all
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT%{_dlldir}
115 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
116
117 %if 0%{!?debug:1}
118 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
119 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
120 %endif
121
122 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS README TODO
130 %{_libdir}/libsigc-2.0.dll.a
131 %{_libdir}/libsigc-2.0.la
132 %{_libdir}/sigc++-2.0
133 %{_includedir}/sigc++-2.0
134 %{_pkgconfigdir}/sigc++-2.0.pc
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libsigc-2.0.a
139
140 %files dll
141 %defattr(644,root,root,755)
142 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.056141 seconds and 4 git commands to generate.