]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
- updated to 2.2.9
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - MinGW32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.2.9
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  16dc0c868aeef9ee5ef055f3e3e865d3
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1.9
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  libtool
16 BuildRequires:  m4
17 BuildRequires:  mm-common >= 0.7.2
18 BuildRequires:  perl-base
19 BuildRequires:  pkgconfig
20 Requires:       crossmingw32-runtime
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24
25 %define         target                  i386-mingw32
26 %define         target_platform         i386-pc-mingw32
27
28 %define         _sysprefix              /usr
29 %define         _prefix                 %{_sysprefix}/%{target}
30 %define         _libdir                 %{_prefix}/lib
31 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
32 %define         _dlldir                 /usr/share/wine/windows/system
33 %define         __cc                    %{target}-gcc
34 %define         __cxx                   %{target}-g++
35
36 %ifnarch %{ix86}
37 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
38 %define         optflags        -O2
39 %endif
40 # -z options are invalid for mingw linker
41 %define         filterout_ld    -Wl,-z,.*
42
43 %description
44 This library implements a full callback system for use in widget
45 libraries, abstract interfaces, and general programming. Originally
46 part of the Gtk-- widget set, libsigc++ is now a seperate library to
47 provide for more general use. It is the most complete library of its
48 kind with the ablity to connect an abstract callback to a class
49 method, function, or function object. It contains adaptor classes for
50 connection of dissimilar callbacks and has an ease of use unmatched by
51 other C++ callback libraries.
52
53 This package contains cross MinGW32 version.
54
55 %description -l pl.UTF-8
56 Ta biblioteka jest implementacją pełnego systemu callbacków do
57 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
58 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
59 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
60 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
61 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
62 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
63 callbacków.
64
65 Ten pakiet zawiera wersję skrośną MinGW32.
66
67 %package static
68 Summary:        Static libsigc++ library (cross MinGW32 version)
69 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description static
74 Static libsigc++ library (cross MinGW32 version).
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
78
79 %package dll
80 Summary:        DLL libsigc++ library for Windows
81 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
82 Group:          Applications/Emulators
83 Requires:       wine
84
85 %description dll
86 DLL libsigc++ library for Windows.
87
88 %description dll -l pl.UTF-8
89 Biblioteka DLL libsigc++ dla Windows.
90
91 %prep
92 %setup -q -n %{realname}-%{version}
93
94 %build
95 %{__libtoolize}
96 %{__aclocal} -I build
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         --target=%{target} \
101         --host=%{target} \
102         --enable-static
103
104 %{__make} all
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT%{_dlldir}
113 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
114
115 %if 0%{!?debug:1}
116 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
117 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
118 %endif
119
120 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog NEWS README TODO
128 %{_libdir}/libsigc-2.0.dll.a
129 %{_libdir}/libsigc-2.0.la
130 %{_libdir}/sigc++-2.0
131 %{_includedir}/sigc++-2.0
132 %{_pkgconfigdir}/sigc++-2.0.pc
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libsigc-2.0.a
137
138 %files dll
139 %defattr(644,root,root,755)
140 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.082899 seconds and 4 git commands to generate.