]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
- updated to 2.12.0
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - MinGW32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.12.0
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        https://download.gnome.org/sources/libsigc++/2.12/%{realname}-%{version}.tar.xz
10 # Source0-md5:  943b7aef5d74fbc4f4a3bb67bcfaae02
11 URL:            https://libsigcplusplus.github.io/libsigcplusplus/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.7
15 BuildRequires:  libtool >= 2:2.0
16 BuildRequires:  m4
17 BuildRequires:  mm-common >= 0.9.10
18 BuildRequires:  perl-base
19 BuildRequires:  pkgconfig
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       crossmingw32-gcc-c++ >= 1:4.7
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26 %define         _enable_debug_packages  0
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38 %define         __pkgconfig_provides    %{nil}
39 %define         __pkgconfig_requires    %{nil}
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker, most of -f options are Linux-specific
46 %define         filterout_ld    -Wl,-z,.*
47 %define         filterout_c     -f[-a-z0-9=]*
48 %define         filterout_cxx   -f[-a-z0-9=]*
49
50 %description
51 This library implements a full callback system for use in widget
52 libraries, abstract interfaces, and general programming. Originally
53 part of the Gtk-- widget set, libsigc++ is now a seperate library to
54 provide for more general use. It is the most complete library of its
55 kind with the ablity to connect an abstract callback to a class
56 method, function, or function object. It contains adaptor classes for
57 connection of dissimilar callbacks and has an ease of use unmatched by
58 other C++ callback libraries.
59
60 This package contains cross MinGW32 version.
61
62 %description -l pl.UTF-8
63 Ta biblioteka jest implementacją pełnego systemu callbacków do
64 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
65 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
66 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
67 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
68 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
69 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
70 callbacków.
71
72 Ten pakiet zawiera wersję skrośną MinGW32.
73
74 %package static
75 Summary:        Static libsigc++ library (cross MinGW32 version)
76 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description static
81 Static libsigc++ library (cross MinGW32 version).
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
85
86 %package dll
87 Summary:        DLL libsigc++ library for Windows
88 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
89 Group:          Applications/Emulators
90 Requires:       wine
91
92 %description dll
93 DLL libsigc++ library for Windows.
94
95 %description dll -l pl.UTF-8
96 Biblioteka DLL libsigc++ dla Windows.
97
98 %prep
99 %setup -q -n %{realname}-%{version}
100
101 %build
102 mm-common-prepare --copy --force
103 %{__libtoolize}
104 %{__aclocal} -I build
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         --target=%{target} \
110         --host=%{target} \
111         --disable-silent-rules \
112         --enable-static
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install -d $RPM_BUILD_ROOT%{_dlldir}
123 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
124
125 %if 0%{!?debug:1}
126 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
127 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
128 %endif
129
130 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README.md
138 %{_libdir}/libsigc-2.0.dll.a
139 %{_libdir}/libsigc-2.0.la
140 %{_libdir}/sigc++-2.0
141 %{_includedir}/sigc++-2.0
142 %{_pkgconfigdir}/sigc++-2.0.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libsigc-2.0.a
147
148 %files dll
149 %defattr(644,root,root,755)
150 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.192319 seconds and 4 git commands to generate.