]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
- updated to 2.2.3
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - Mingw32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla Mingw32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.2.3
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  f4574b343eebc4bff66a9e1e5ce6e490
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1.9
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  libtool
16 BuildRequires:  m4
17 BuildRequires:  perl-base
18 Requires:       crossmingw32-runtime
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         no_install_post_strip   1
22
23 %define         target                  i386-mingw32
24 %define         target_platform         i386-pc-mingw32
25
26 %define         _sysprefix              /usr
27 %define         _prefix                 %{_sysprefix}/%{target}
28 %define         _libdir                 %{_prefix}/lib
29 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
30 %define         _dlldir                 /usr/share/wine/windows/system
31 %define         __cc                    %{target}-gcc
32 %define         __cxx                   %{target}-g++
33
34 %ifnarch %{ix86}
35 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
36 %define         optflags        -O2
37 %endif
38 # -z options are invalid for mingw linker
39 %define         filterout_ld    -Wl,-z,.*
40
41 %description
42 This library implements a full callback system for use in widget
43 libraries, abstract interfaces, and general programming. Originally
44 part of the Gtk-- widget set, libsigc++ is now a seperate library to
45 provide for more general use. It is the most complete library of its
46 kind with the ablity to connect an abstract callback to a class
47 method, function, or function object. It contains adaptor classes for
48 connection of dissimilar callbacks and has an ease of use unmatched by
49 other C++ callback libraries.
50
51 This package contains cross Mingw32 version.
52
53 %description -l pl.UTF-8
54 Ta biblioteka jest implementacją pełnego systemu callbacków do
55 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
56 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
57 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
58 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
59 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
60 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
61 callbacków.
62
63 Ten pakiet zawiera wersję skrośną Mingw32.
64
65 %package static
66 Summary:        Static libsigc++ library (cross mingw32 version)
67 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna mingw32)
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description static
72 Static libsigc++ library (cross mingw32 version).
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka libsigc++ (wersja skrośna mingw32).
76
77 %package dll
78 Summary:        DLL libsigc++ library for Windows
79 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
80 Group:          Applications/Emulators
81 Requires:       wine
82
83 %description dll
84 DLL libsigc++ library for Windows.
85
86 %description dll -l pl.UTF-8
87 Biblioteka DLL libsigc++ dla Windows.
88
89 %prep
90 %setup -q -n %{realname}-%{version}
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I scripts
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --target=%{target} \
99         --host=%{target} \
100         --enable-shared \
101         --enable-static
102
103 %{__make} all
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install -d $RPM_BUILD_ROOT%{_dlldir}
112 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
113
114 %if 0%{!?debug:1}
115 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
116 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
117 %endif
118
119 rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README TODO
127 %{_libdir}/libsigc-2.0.dll.a
128 %{_libdir}/libsigc-2.0.la
129 %{_libdir}/sigc++-2.0
130 %{_includedir}/sigc++-2.0
131 %{_pkgconfigdir}/sigc++-2.0.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libsigc-2.0.a
136
137 %files dll
138 %defattr(644,root,root,755)
139 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.031815 seconds and 3 git commands to generate.