]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/blob - crossmingw32-harfbuzz.spec
- cleanup
[packages/crossmingw32-harfbuzz.git] / crossmingw32-harfbuzz.spec
1 Summary:        HarfBuzz - internationalized text shaping library - MinGW32 cross version
2 Summary(pl.UTF-8):      Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
3 Name:           crossmingw32-harfbuzz
4 Version:        0.9.4
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
9 # Source0-md5:  4d12e3d9fdc132237767f5965e1684bb
10 URL:            http://www.freedesktop.org/wiki/HarfBuzz
11 BuildRequires:  crossmingw32-cairo >= 1.8.0
12 BuildRequires:  crossmingw32-freetype >= 2.3.8
13 BuildRequires:  crossmingw32-glib2 >= 2.16
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  pkgconfig
16 Requires:       crossmingw32-cairo >= 1.8.0
17 Requires:       crossmingw32-freetype >= 2.3.8
18 Requires:       crossmingw32-glib2 >= 2.16
19 Requires:       crossmingw32-gcc-c++
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # see <harfbuzz/internal/ftserv.h>, the real horror
23 %define         specflags       -fno-strict-aliasing
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker, most of -f options are Linux-specific
43 %define         filterout_ld    -Wl,-z,.*
44 %define         filterout_c     -f[-a-z0-9=]*
45 %define         filterout_cxx   -f[-a-z0-9=]*
46
47 %description
48 Internationalized OpenType text layout and rendering library.
49
50 This package contains the cross version for Win32.
51
52 %description -l pl.UTF-8
53 Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
54 obsługująca wiele języków.
55
56 Ten pakiet zawiera wersję skrośną dla Win32.
57
58 %package static
59 Summary:        Static harfbuzz library (cross MinGW32 version)
60 Summary(pl.UTF-8):      Statyczna biblioteka harfbuzz (wersja skrośna MinGW32)
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description static
65 Static harfbuzz library (cross MinGW32 version).
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka harfbuzz (wersja skrośna MinGW32).
69
70 %package dll
71 Summary:        DLL harfbuzz library for Windows
72 Summary(pl.UTF-8):      Biblioteka DLL harfbuzz dla Windows
73 Group:          Applications/Emulators
74 Requires:       crossmingw32-cairo-dll >= 1.8.0
75 Requires:       crossmingw32-freetype-dll >= 2.3.8
76 Requires:       crossmingw32-glib2-dll >= 2.16
77 Requires:       wine
78
79 %description dll
80 DLL harfbuzz library for Windows.
81
82 %description dll -l pl.UTF-8
83 Biblioteka DLL harfbuzz dla Windows.
84
85 %prep
86 %setup -q -n harfbuzz-%{version}
87
88 %build
89 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
90 %configure \
91         --target=%{target} \
92         --build=i686-pc-linux-gnu \
93         --host=%{target} \
94         --disable-silent-rules \
95         --enable-static
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install -d $RPM_BUILD_ROOT%{_dlldir}
106 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
107
108 %if 0%{!?debug:1}
109 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
110 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc COPYING ChangeLog README TODO
119 %{_libdir}/libharfbuzz.dll.a
120 %{_libdir}/libharfbuzz.la
121 %{_includedir}/harfbuzz
122 %{_pkgconfigdir}/harfbuzz.pc
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libharfbuzz.a
127
128 %files dll
129 %defattr(644,root,root,755)
130 %{_dlldir}/libharfbuzz-*.dll
This page took 0.067452 seconds and 4 git commands to generate.