]> git.pld-linux.org Git - packages/crossmingw32-gdk-pixbuf2.git/blob - crossmingw32-gdk-pixbuf2.spec
- updated to 2.28.1
[packages/crossmingw32-gdk-pixbuf2.git] / crossmingw32-gdk-pixbuf2.spec
1 #
2 # Conditional build:
3 %bcond_without  gdiplus # use libjpeg and libtiff instead of system GDIPLUS
4 #
5 Summary:        An image loading and scaling library - cross MinGW32 version
6 Summary(pl.UTF-8):      Biblioteka ładująca i skalująca obrazki - wersja skrośna MinGW32
7 Name:           crossmingw32-gdk-pixbuf2
8 Version:        2.28.1
9 Release:        1
10 License:        LGPL v2+
11 Group:          Development/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/2.28/gdk-pixbuf-%{version}.tar.xz
13 # Source0-md5:  5c71cce316d08c559fc5970aa60754ab
14 Patch0:         gdk-pixbuf2-png-nodep.patch
15 Patch1:         gdk-pixbuf2-gdip.patch
16 URL:            http://developer.gnome.org/gdk-pixbuf/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  crossmingw32-gcc
20 BuildRequires:  crossmingw32-glib2 >= 2.34.0
21 BuildRequires:  crossmingw32-jasper
22 BuildRequires:  crossmingw32-libpng
23 BuildRequires:  gettext-devel >= 0.17
24 BuildRequires:  gtk-doc >= 1.11
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  pkgconfig >= 1:0.15
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 %if %{without gdiplus}
30 BuildRequires:  crossmingw32-libjpeg
31 BuildRequires:  crossmingw32-libtiff
32 %endif
33 Requires:       crossmingw32-glib2 >= 2.34.0
34 Conflicts:      crossmingw32-gtk+2 < 2.22.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         abiver  2.10.0
38
39 %define         no_install_post_strip   1
40
41 %define         target                  i386-mingw32
42 %define         target_platform         i386-pc-mingw32
43
44 %define         _sysprefix              /usr
45 %define         _prefix                 %{_sysprefix}/%{target}
46 %define         _libdir                 %{_prefix}/lib
47 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
48 %define         _dlldir                 /usr/share/wine/windows/system
49 %define         __cc                    %{target}-gcc
50 %define         __cxx                   %{target}-g++
51
52 #define         filterout_ld            (-Wl,)?-as-needed.*
53
54 %ifnarch %{ix86}
55 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
56 %define         optflags        -O2
57 %endif
58 # -z options are invalid for mingw linker, most of -f options are Linux-specific
59 %define         filterout_ld    -Wl,-z,.*
60 %define         filterout_c     -f[-a-z0-9=]*
61
62 %description
63 gdk-pixbuf is an image loading and scaling library that can be
64 extended by loadable modules for new image formats.
65
66 This package contains the cross version for Win32.
67
68 %description -l pl.UTF-8
69 gdk-pixbuf to biblioteka ładująca i skalująca obrazki, której
70 funkcjonalność może być rozszerzana o obsługę nowych formatów poprzez
71 ładowane moduły.
72
73 Ten pakiet zawiera wersję skrośną dla Win32.
74
75 %package dll
76 Summary:        DLL gdk-pixbuf libraries for Windows
77 Summary(pl.UTF-8):      Biblioteki DLL gdk-pixbuf dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-glib2-dll >= 2.34.0
80 Requires:       wine
81 Conflicts:      crossmingw32-gtk+2-dll < 2.22.0
82
83 %description dll
84 DLL gdk-pixbuf libraries for Windows.
85
86 %description dll -l pl.UTF-8
87 Biblioteki DLL gdk-pixbuf dla Windows.
88
89 %prep
90 %setup -q -n gdk-pixbuf-%{version}
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 %{__gettextize}
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
102 %configure \
103         --target=%{target} \
104         --host=%{target} \
105         --disable-gtk-doc \
106         --disable-man \
107         --disable-silent-rules \
108         --with-libjasper \
109         %{!?with_gdiplus:--without-gdiplus}
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT%{_dlldir}
120 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122 %if 0%{!?debug:1}
123 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll \
124         $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.dll
125 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
126 %endif
127
128 # shut up check-files
129 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,locale,man}
130 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.{la,dll.a}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %{_libdir}/libgdk_pixbuf-2.0.dll.a
138 %{_libdir}/libgdk_pixbuf-2.0.la
139 %{_libdir}/gdk_pixbuf-2.0.def
140 %{_includedir}/gdk-pixbuf-2.0
141 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
142
143 %files dll
144 %defattr(644,root,root,755)
145 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
146 %dir %{_libdir}/gdk-pixbuf-2.0
147 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}
148 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders
149 %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/libpixbufloader-*.dll
This page took 0.083239 seconds and 3 git commands to generate.