]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blob - crossmingw32-fontconfig.spec
- proper shared + static build
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
1 #
2 # Conditional build
3 %bcond_with     bytecode        # use bytecode hinting instead of autohinting by default
4 %define         _realname   fontconfig
5 Summary:        Font configuration and customization tools - cross Mingw32 versoin
6 Summary(pl.UTF-8):Narzędzia do konfigurowania fontów - wersja skrośna dla Mingw32
7 Summary(pt_BR.UTF-8):Ferramentas para configuração e customização do acesso a fontes
8 Name:           crossmingw32-%{_realname}
9 Version:        2.4.2
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://fontconfig.org/release/%{_realname}-%{version}.tar.gz
14 # Source0-md5:  f035852f521b54677f2b5c9e2f6d54a4
15 Patch0:         %{name}-dll.patch
16 Patch1:         %{_realname}-blacklist.patch
17 Patch2:         %{_realname}-autohint.patch
18 Patch3:         %{_realname}-bitstream-cyberbit.patch
19 URL:            http://fontconfig.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  crossmingw32-expat
23 BuildRequires:  crossmingw32-freetype >= 2.1.5
24 BuildRequires:  crossmingw32-pkgconfig
25 Requires:       crossmingw32-freetype >= 2.1.5
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         no_install_post_strip   1
29
30 %define         target                  i386-mingw32
31 %define         target_platform         i386-pc-mingw32
32 %define         arch                    %{_prefix}/%{target}
33 %define         gccarch                 %{_prefix}/lib/gcc-lib/%{target}
34 %define         gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _aclocaldir             %{_datadir}/aclocal
39 %define         _pkgconfigdir           %{_libdir}/pkgconfig
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42
43 %description
44 Fontconfig is designed to locate fonts within the system and select
45 them according to requirements specified by applications.
46
47 This package contains tools and documentation.
48
49 %description -l pl.UTF-8
50 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
51 systemie i wybierania ich w zależności od potrzeb aplikacji.
52
53 Paket ten zawiera programy narzędziowe i dokumentację.
54
55 %description -l pt_BR.UTF-8
56 Fontconfig é uma biblioteca para configuração e customização do
57 acesso a fontes.
58
59 Este pacote contém as ferramentas e documentação.
60
61 %prep
62 %setup -q -n %{_realname}-%{version}
63 #%patch0 -p1
64 %patch1 -p1
65 %if %{with bytecode}
66 %patch2 -p1
67 %endif
68 %patch3 -p1
69
70 %build
71 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 %configure \
78         --target=%{target} \
79         --host=%{target} \
80         --with-arch=%{target} \
81         --disable-docs
82
83 #%{__sed} -i -e 's/^deplibs_check_method=.*/deplibs_check_method="pass_all"/' libtool
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 cp -f conf.d/README README.confd
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 umask 022
101 # Is this needed?
102 #HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS COPYING ChangeLog README README.confd
107 #%dir %{_sysconfdir}/fonts
108 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
109 #%{_sysconfdir}/fonts/fonts.dtd
110 #%dir %{_sysconfdir}/fonts/conf.avail
111 #%{_sysconfdir}/fonts/conf.avail/*.conf
112 #%{_sysconfdir}/fonts/conf.avail/README
113 #%dir %{_sysconfdir}/fonts/conf.d
114 #%config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
115 %{_libdir}/lib*.la
116 %{_libdir}/lib*.a
117 %{_bindir}/*.dll
118 %dir %{_includedir}/fontconfig
119 %{_includedir}/fontconfig/*.h
120 %{_pkgconfigdir}/fontconfig.pc
This page took 0.05973 seconds and 3 git commands to generate.