]> git.pld-linux.org Git - packages/crossmingw32-cairomm.git/blob - crossmingw32-cairomm.spec
- updated to 1.12.2
[packages/crossmingw32-cairomm.git] / crossmingw32-cairomm.spec
1 Summary:        C++ wrapper for cairo - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ do cairo - wersja skrośna dla MinGW32
3 %define         realname   cairomm
4 Name:           crossmingw32-%{realname}
5 Version:        1.12.2
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        https://www.cairographics.org/releases/%{realname}-%{version}.tar.gz
10 # Source0-md5:  9d2282ea34cf9aaa89208bb4bb911909
11 URL:            https://www.cairographics.org/
12 BuildRequires:  autoconf >= 2.62
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  crossmingw32-cairo >= 1.10.0
15 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.6
16 BuildRequires:  crossmingw32-libsigc++ >= 2.5.1
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  mm-common >= 0.8
19 BuildRequires:  pkgconfig >= 1:0.15
20 Requires:       crossmingw32-cairo >= 1.10.0
21 Requires:       crossmingw32-gcc-c++ >= 1:4.6
22 Requires:       crossmingw32-libsigc++ >= 2.5.1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38 %define         __pkgconfig_requires    %{nil}
39
40 %define         _ssp_cflags             %{nil}
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker, most of -f options are Linux-specific
46 %define         filterout_ld    -Wl,-z,.*
47 %define         filterout_c             -f[-a-z0-9=]*
48
49 %description
50 C++ wrapper for cairo (cross MinGW32 version).
51
52 %description -l pl.UTF-8
53 Interfejs C++ do cairo (wersja skrośna MinGW32).
54
55 %package static
56 Summary:        Static cairomm library (cross MinGW32 version)
57 Summary(pl.UTF-8):      Statyczna biblioteka cairomm (wersja skrośna MinGW32)
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description static
62 Static cairomm library (cross MinGW32 version).
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka cairomm (wersja skrośna MinGW32).
66
67 %package dll
68 Summary:        DLL cairomm library for Windows
69 Summary(pl.UTF-8):      Biblioteka DLL cairomm dla Windows
70 Group:          Applications/Emulators
71 Requires:       crossmingw32-cairo-dll >= 1.10.0
72 Requires:       crossmingw32-libsigc++-dll >= 2.5.1
73
74 %description dll
75 DLL cairomm library for Windows.
76
77 %description dll -l pl.UTF-8
78 Biblioteka DLL cairomm dla Windows.
79
80 %prep
81 %setup -q -n %{realname}-%{version}
82
83 %build
84 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
85 %{__libtoolize}
86 %{__aclocal} -I build
87 %{__automake}
88 %{__autoconf}
89 # mingw32 requires gnu++11 (instead of c++11) for M_PI
90 CXXFLAGS="%{rpmcxxflags} -std=gnu++11"
91 %configure \
92         --enable-static \
93         --target=%{target} \
94         --host=%{target}
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 install -d $RPM_BUILD_ROOT%{_dlldir}
105 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
106
107 %if 0%{!?debug:1}
108 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
109 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
110 %endif
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc/cairomm-1.0,devhelp}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
120 %{_libdir}/libcairomm-1.0.dll.a
121 %{_libdir}/libcairomm-1.0.la
122 %{_libdir}/cairomm-1.0
123 %{_includedir}/cairomm-1.0
124 %{_pkgconfigdir}/cairomm-1.0.pc
125 %{_pkgconfigdir}/cairomm-ft-1.0.pc
126 %{_pkgconfigdir}/cairomm-pdf-1.0.pc
127 %{_pkgconfigdir}/cairomm-png-1.0.pc
128 %{_pkgconfigdir}/cairomm-ps-1.0.pc
129 %{_pkgconfigdir}/cairomm-svg-1.0.pc
130 %{_pkgconfigdir}/cairomm-win32-1.0.pc
131 %{_pkgconfigdir}/cairomm-win32-font-1.0.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libcairomm-1.0.a
136
137 %files dll
138 %defattr(644,root,root,755)
139 %{_dlldir}/libcairomm-1.0-*.dll
This page took 0.03149 seconds and 4 git commands to generate.