]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Mingw32 Binary Utility Development Utilities - GNU binutils
2 Summary(pl):    Zestaw narzêdzi mingw32 - GNU binutils
3 Name:           crossmingw32-binutils
4 Version:        2.11.92.0.10
5 Release:        2
6 License:        GPL
7 Group:          Development/Tools
8 ExclusiveArch:  %{ix86}
9 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
10 Patch0:         binutils-info.patch
11 BuildRequires:  flex
12 BuildRequires:  bison
13 BuildRequires:  perl-devel
14 BuildRequires:  bash
15 Requires:       crossmingw32-platform
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         target          i386-mingw32
19 %define         arch            %{_prefix}/%{target}
20
21 %description
22 crossmingw32 is a complete cross-compiling development system for
23 building stand-alone Microsoft Windows applications under Linux using
24 the Mingw32 build libraries. This includes a binutils, gcc with g++
25 and objc, and libstdc++, all cross targeted to i386-mingw32, along
26 with supporting Win32 libraries in 'coff' format from free sources.
27
28 This package contains cross targeted binutils.
29
30 %description -l pl
31 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalaj±cym
32 budowaæ aplikacje MS Windows pod Linuksem u¿ywaj±c bibliotek mingw32.
33 System sk³ada siê z binutils, gcc z g++ i objc, libstdc++ - wszystkie
34 generuj±ce kod dla platformy i386-mingw32, oraz z bibliotek w formacie
35 COFF.
36
37 Ten pakiet zawiera binutils generuj±ce binaria Win32.
38
39 %prep
40 %setup -q -n binutils-%{version}
41 %patch -p1
42
43 %build
44 rm -rf $RPM_BUILD_ROOT
45
46 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
47 # lib<target>bfd.so*. To prevent confusion with native binutils, we
48 # forget about shared libraries right now, and do not install libbfd.a
49 # [the same applies to binutils 2.10.1.0.4]
50
51 # ldscripts won't be generated properly if SHELL is not bash...
52 CFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
53 CONFIG_SHELL="/bin/bash" \
54 ./configure \
55         --prefix=%{_prefix} \
56         --libdir=%{_libdir} \
57         --mandir=%{_mandir} \
58         --infodir=%{_infodir} \
59         --target=%{target}
60
61 %{__make} tooldir=%{_prefix} EXEEXT="" all
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         prefix=$RPM_BUILD_ROOT%{_prefix} \
68         mandir=$RPM_BUILD_ROOT%{_mandir} \
69         infodir=$RPM_BUILD_ROOT%{_infodir} \
70         libdir=$RPM_BUILD_ROOT%{_libdir}
71
72 # remove this man page unless we cross-build for netware platform.
73 # however, this should be done in Makefiles.
74 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{arch}/bin/*
79 %{arch}/lib/*
80 %attr(755,root,root) %{_bindir}/%{target}-*
81 %{_mandir}/man1/%{target}-*
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
This page took 0.092492 seconds and 4 git commands to generate.