]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
- updated to 2.25.51.0.1
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.25.51.0.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 #Source0:       https://www.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.xz
13 Source0:        binutils-%{version}.tar.xz
14 # Source0-md5:  4d3bd9694a1c9c318e7afe6db4a23b69
15 Patch0:         binutils-libdir.patch
16 Patch1:         binutils-am.patch
17 URL:            http://sources.redhat.com/binutils/
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  bash
21 BuildRequires:  bison
22 BuildRequires:  flex
23 BuildRequires:  gettext-tools
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  texinfo >= 4.2
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         target          i386-mingw32
31 %define         arch            %{_prefix}/%{target}
32
33 %description
34 crossmingw32 is a complete cross-compiling development system for
35 building stand-alone Microsoft Windows applications under Linux using
36 the MinGW32 build libraries. This includes a binutils, gcc with g++
37 and objc, and libstdc++, all cross targeted to i386-mingw32, along
38 with supporting Win32 libraries in 'coff' format from free sources.
39
40 This package contains cross targeted binutils.
41
42 %description -l pl.UTF-8
43 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
44 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
45 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
46 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
47 COFF.
48
49 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
50
51 %prep
52 %setup -q -n binutils-%{version}
53 %patch0 -p1
54 %patch1 -p1
55
56 # file contains hacks for ac 2.64 only
57 %{__rm} config/override.m4
58 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
59
60 %build
61 cp -f /usr/share/automake/config.* .
62 %{__aclocal}
63 %{__autoconf}
64
65 # non-standard regeneration (needed because of libdir patch)
66 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
67 for dir in gas bfd; do
68         cd $dir || exit 1
69         %{__aclocal} -I .. -I ../config -I ../bfd
70         %{__automake} Makefile
71         %{__automake} doc/Makefile
72         %{__autoconf}
73         cd ..
74 done
75
76 # We don't install libbfd (nor use shared binutils libraries) to avoid
77 # conflict with native binutils.
78
79 # ldscripts won't be generated properly if SHELL is not bash...
80 CFLAGS="%{rpmcflags}" \
81 LDFLAGS="%{rpmldflags}" \
82 CONFIG_SHELL="/bin/bash" \
83 ./configure \
84         --disable-nls \
85         --disable-shared \
86         --prefix=%{_prefix} \
87         --libdir=%{_libdir} \
88         --mandir=%{_mandir} \
89         --infodir=%{_infodir} \
90         --host=%{_target_platform} \
91         --build=%{_target_platform} \
92         --target=%{target}
93
94 %{__make} all \
95         tooldir=%{_prefix}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         INSTALL='$$s/install-sh -c' \
102         prefix=$RPM_BUILD_ROOT%{_prefix} \
103         mandir=$RPM_BUILD_ROOT%{_mandir} \
104         infodir=$RPM_BUILD_ROOT%{_infodir} \
105         libdir=$RPM_BUILD_ROOT%{_libdir}
106
107 # remove this man page unless we cross-build for netware platform.
108 # however, this should be done in Makefiles.
109 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
110
111 # not prefixed, keep infos only from native packages
112 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
113
114 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
115 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README
123 # mingw32 directory tree
124 %dir %{arch}
125 %dir %{arch}/lib
126 %dir %{arch}/lib/pkgconfig
127 %dir %{arch}/bin
128 # binutils files
129 %attr(755,root,root) %{arch}/bin/ar
130 %attr(755,root,root) %{arch}/bin/as
131 %attr(755,root,root) %{arch}/bin/dlltool
132 %attr(755,root,root) %{arch}/bin/ld
133 %attr(755,root,root) %{arch}/bin/ld.bfd
134 %attr(755,root,root) %{arch}/bin/nm
135 %attr(755,root,root) %{arch}/bin/objcopy
136 %attr(755,root,root) %{arch}/bin/objdump
137 %attr(755,root,root) %{arch}/bin/ranlib
138 %attr(755,root,root) %{arch}/bin/strip
139 %{arch}/lib/ldscripts
140 %attr(755,root,root) %{_bindir}/%{target}-addr2line
141 %attr(755,root,root) %{_bindir}/%{target}-ar
142 %attr(755,root,root) %{_bindir}/%{target}-as
143 %attr(755,root,root) %{_bindir}/%{target}-c++filt
144 %attr(755,root,root) %{_bindir}/%{target}-dlltool
145 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
146 %attr(755,root,root) %{_bindir}/%{target}-elfedit
147 %attr(755,root,root) %{_bindir}/%{target}-gprof
148 %attr(755,root,root) %{_bindir}/%{target}-ld
149 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
150 %attr(755,root,root) %{_bindir}/%{target}-nm
151 %attr(755,root,root) %{_bindir}/%{target}-objcopy
152 %attr(755,root,root) %{_bindir}/%{target}-objdump
153 %attr(755,root,root) %{_bindir}/%{target}-ranlib
154 %attr(755,root,root) %{_bindir}/%{target}-readelf
155 %attr(755,root,root) %{_bindir}/%{target}-size
156 %attr(755,root,root) %{_bindir}/%{target}-strings
157 %attr(755,root,root) %{_bindir}/%{target}-strip
158 %attr(755,root,root) %{_bindir}/%{target}-windmc
159 %attr(755,root,root) %{_bindir}/%{target}-windres
160 %{_mandir}/man1/%{target}-addr2line.1*
161 %{_mandir}/man1/%{target}-ar.1*
162 %{_mandir}/man1/%{target}-as.1*
163 %{_mandir}/man1/%{target}-c++filt.1*
164 %{_mandir}/man1/%{target}-dlltool.1*
165 %{_mandir}/man1/%{target}-elfedit.1*
166 %{_mandir}/man1/%{target}-gprof.1*
167 %{_mandir}/man1/%{target}-ld.1*
168 %{_mandir}/man1/%{target}-nm.1*
169 %{_mandir}/man1/%{target}-objcopy.1*
170 %{_mandir}/man1/%{target}-objdump.1*
171 %{_mandir}/man1/%{target}-ranlib.1*
172 %{_mandir}/man1/%{target}-readelf.1*
173 %{_mandir}/man1/%{target}-size.1*
174 %{_mandir}/man1/%{target}-strings.1*
175 %{_mandir}/man1/%{target}-strip.1*
176 %{_mandir}/man1/%{target}-windmc.1*
177 %{_mandir}/man1/%{target}-windres.1*
This page took 0.072875 seconds and 3 git commands to generate.