]> git.pld-linux.org Git - packages/crossmingw32-atkmm.git/blob - crossmingw32-atkmm.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-atkmm.git] / crossmingw32-atkmm.spec
1 Summary:        A C++ interface for atk library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - wersja skrośna MinGW32
3 Name:           crossmingw32-atkmm
4 Version:        2.22.6
5 Release:        2
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atkmm/2.22/atkmm-%{version}.tar.xz
9 # Source0-md5:  30f8e34c92b14f17ba3029937b2f218a
10 URL:            http://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.9
13 BuildRequires:  crossmingw32-atk >= 1.22.0
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  crossmingw32-glibmm >= 2.24.0
16 BuildRequires:  libtool >= 2:2.0
17 BuildRequires:  mm-common >= 0.9.5
18 BuildRequires:  pkgconfig >= 1:0.15
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 Requires:       crossmingw32-atk >= 1.22.0
22 Requires:       crossmingw32-glibmm >= 2.24.0
23 Provides:       crossmingw32-gtkmm-atk
24 Obsoletes:      crossmingw32-gtkmm-atk
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         i386-pc-mingw32
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39 %define         __pkgconfig_provides    %{nil}
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker
46 %define         filterout_ld    -Wl,-z,.*
47
48 %description
49 A C++ interface for atk library - cross MinGW32 version.
50
51 %description -l pl.UTF-8
52 Interfejs C++ dla biblioteki atk - wersja skrośna MinGW32.
53
54 %package static
55 Summary:        Static atkmm library (cross MinGW32 version)
56 Summary(pl.UTF-8):      Statyczna biblioteka atkmm (wersja skrośna MinGW32)
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Provides:       crossmingw32-gtkmm-atk-static
60 Obsoletes:      crossmingw32-gtkmm-atk-static
61
62 %description static
63 Static atkmm library (cross MinGW32 version).
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka atkmm (wersja skrośna MinGW32).
67
68 %package dll
69 Summary:        DLL atkmm library for Windows
70 Summary(pl.UTF-8):      Biblioteka DLL atkmm dla Windows
71 Group:          Applications/Emulators
72 Requires:       crossmingw32-atk-dll >= 1.22.0
73 Requires:       crossmingw32-glibmm-dll >= 2.24.0
74 Requires:       wine
75 Provides:       crossmingw32-gtkmm-atk-dll
76 Obsoletes:      crossmingw32-gtkmm-atk-dll
77
78 %description dll
79 DLL atkmm library for Windows.
80
81 %description dll -l pl.UTF-8
82 Biblioteka DLL atkmm dla Windows.
83
84 %prep
85 %setup -q -n atkmm-%{version}
86
87 %build
88 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
89 %{__libtoolize}
90 %{__aclocal} -I build
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --target=%{target} \
96         --host=%{target} \
97         --disable-documentation \
98         --enable-static
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT%{_dlldir}
109 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
110
111 %if 0%{!?debug:1}
112 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
113 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
114 %endif
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README
122 %{_libdir}/libatkmm-1.6.dll.a
123 %{_libdir}/libatkmm-1.6.la
124 %{_libdir}/atkmm-1.6
125 %{_includedir}/atkmm-1.6
126 %{_pkgconfigdir}/atkmm-1.6.pc
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libatkmm-1.6.a
131
132 %files dll
133 %defattr(644,root,root,755)
134 %{_dlldir}/libatkmm-1.6-*.dll
This page took 0.179039 seconds and 3 git commands to generate.