]> git.pld-linux.org Git - packages/corona.git/blob - corona.spec
- gcc43 patch
[packages/corona.git] / corona.spec
1 Summary:        Image input/output library
2 Summary(pl.UTF-8):      Biblioteka wejścia/wyjścia dla obrazów
3 Name:           corona
4 Version:        1.0.2
5 Release:        2
6 License:        zlib
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/corona/%{name}-%{version}.tar.gz
9 # Source0-md5:  29d1a7f1e2c85a83e9620496c62740ce
10 Patch0:         %{name}-system-gif.patch
11 Patch1:         %{name}-config.patch
12 Patch2:         %{name}-gcc43.patch
13 URL:            http://corona.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  giflib-devel >= 4.1.0
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:1.5
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Corona is an image input/output library that can read, write, and
25 manipulate image files in just a few lines of code. It can write PNG
26 and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was
27 designed to be easy to use, and exports a straightforward C++ API.
28 With just a few lines of C++, you can add image loading to your
29 application.
30
31 %description -l pl.UTF-8
32 Corona to biblioteka wejścia/wyjścia dla obrazów, potrafiąca czytać,
33 zapisywać i obrabiać pliki obrazów w zaledwie kilku liniach kodu.
34 Potrafi zapisywać pliki PNG i TGA, a czytać PNG, JPEG, PCX, BMP, TGA i
35 GIF. Została zaprojektowana jako łatwa w użyciu i eksportuje
36 bezpośrednie API C++. Za pomocą tylko kilku linii kodu C++ można dodać
37 wczytywanie obrazów do swojej aplikacji.
38
39 %package devel
40 Summary:        Header files for corona library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki corona
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       giflib-devel >= 4.1.0
45 Requires:       libjpeg-devel
46 Requires:       libpng-devel
47 Requires:       libstdc++-devel
48
49 %description devel
50 Header files for corona library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki corona.
54
55 %package static
56 Summary:        Static corona library
57 Summary(pl.UTF-8):      Statyczna biblioteka corona
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static corona library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka corona.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %{__automake}
78 %configure
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc doc/{changelog.txt,faq.txt,license.txt,literature.txt,readme.txt}
96 %attr(755,root,root) %{_bindir}/corconvert
97 %attr(755,root,root) %{_libdir}/libcorona-*.so
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc doc/tutorial.txt
102 %attr(755,root,root) %{_bindir}/corona-config
103 %attr(755,root,root) %{_libdir}/libcorona.so
104 %{_libdir}/libcorona.la
105 %{_includedir}/corona.h
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libcorona.a
This page took 0.102184 seconds and 4 git commands to generate.