]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
- install systemd service
[packages/colord.git] / colord.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 Summary:        Color daemon - system daemon for managing color devices
8 Summary(pl.UTF-8):      Demon colord - usługa systemowa do zarządzania urządzeniami obsługującymi kolory
9 Name:           colord
10 Version:        0.1.16
11 Release:        2
12 License:        GPL v2+ and LGPL v2+
13 Group:          Daemons
14 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  cb73ffdcebe4c06852c48355e83a4bc4
16 URL:            http://www.freedesktop.org/software/colord/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dbus-devel
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.8
23 BuildRequires:  gtk-doc >= 1.9
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  lcms2-devel >= 2.2
26 BuildRequires:  libgusb-devel >= 0.1.1
27 BuildRequires:  libtool
28 BuildRequires:  libusb-devel >= 1.0.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  polkit-devel >= 0.103
31 BuildRequires:  rpmbuild(macros) >= 1.644
32 BuildRequires:  sane-backends-devel >= 1.0.20-3
33 BuildRequires:  sqlite3-devel
34 BuildRequires:  udev-glib-devel
35 %{?with_vala:BuildRequires:     vala}
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires:       polkit-libs >= 0.103
38 Requires:       systemd-units >= 38
39 Suggests:       shared-color-profiles
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 colord is a low level system activated daemon that maps color devices
44 to color profiles in the system context.
45
46 %description -l pl.UTF-8
47 colord to niskopoziomowa usługa systemowa odwzorowująca urządzenia
48 obsługujące kolory na profile kolorów w kontekście systemu.
49
50 %package libs
51 Summary:        colord library
52 Summary(pl.UTF-8):      Biblioteka colord
53 Group:          Libraries
54 Requires:       glib2 >= 1:2.28.0
55 Suggests:       %{name} = %{version}-%{release}
56 Conflicts:      colord < 0.1.12-4
57
58 %description libs
59 colord library.
60
61 %description libs -l pl.UTF-8
62 Biblioteka colord.
63
64 %package devel
65 Summary:        Header files for colord library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69 Requires:       dbus-devel
70 Requires:       glib2-devel >= 1:2.28.0
71
72 %description devel
73 Header files for colord library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki colord.
77
78 %package static
79 Summary:        Static colord library
80 Summary(pl.UTF-8):      Statyczna biblioteka colord
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static colord library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka colord.
89
90 %package apidocs
91 Summary:        colord API documentation
92 Summary(pl.UTF-8):      Dokumentacja API colord
93 Group:          Documentation
94 Requires:       gtk-doc-common
95
96 %description apidocs
97 colord API documentation.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API colord.
101
102 %package -n vala-colord
103 Summary:        colord API for Vala language
104 Summary(pl.UTF-8):      API colord dla języka Vala
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107
108 %description -n vala-colord
109 colord API for Vala language.
110
111 %description -n vala-colord -l pl.UTF-8
112 API colord dla języka Vala.
113
114 %prep
115 %setup -q
116
117 %build
118 %{__intltoolize}
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --disable-silent-rules \
126         %{__enable_disable apidocs gtk-doc} \
127         %{__enable_disable static_libs static} \
128         --with-html-dir=%{_gtkdocdir} \
129         --with-systemdsystemunitdir=%{systemdunitdir}
130 # doc build is broken with -j
131 %{__make} -j1
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
142
143 # the same as it locale
144 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/it_IT
145
146 %find_lang %{name}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post
152 %systemd_post colord.service
153
154 %preun
155 %systemd_preun colord.service
156
157 %postun
158 %systemd_reload
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog NEWS README TODO
166 %attr(755,root,root) %{_bindir}/cd-create-profile
167 %attr(755,root,root) %{_bindir}/cd-fix-profile
168 %attr(755,root,root) %{_bindir}/colormgr
169 %attr(755,root,root) %{_libexecdir}/colord
170 %dir %{_libdir}/colord-sensors
171 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_colorhug.so
172 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_dummy.so
173 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_huey.so
174 # disabled for now
175 #%attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_munki.so
176 %dir %{_datadir}/color/icc/colord
177 %{_datadir}/color/icc/colord/*.icc
178 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
179 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
180 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
181 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
182 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
183 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
184 %{_mandir}/man1/cd-create-profile.1*
185 %{_mandir}/man1/cd-fix-profile.1*
186 %{_mandir}/man1/colormgr.1*
187 %{systemdunitdir}/colord.service
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
189 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
190 /lib/udev/rules.d/69-cd-sensors.rules
191 /lib/udev/rules.d/95-cd-devices.rules
192 %dir /var/lib/colord
193
194 %files libs
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
198 %{_libdir}/girepository-1.0/Colord-1.0.typelib
199
200 %files devel
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libcolord.so
203 %{_includedir}/colord-1
204 %{_pkgconfigdir}/colord.pc
205 %{_datadir}/gir-1.0/Colord-1.0.gir
206
207 %if %{with static_libs}
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libcolord.a
211 %endif
212
213 %if %{with apidocs}
214 %files apidocs
215 %defattr(644,root,root,755)
216 %{_gtkdocdir}/colord
217 %endif
218
219 %if %{with vala}
220 %files -n vala-colord
221 %defattr(644,root,root,755)
222 %{_datadir}/vala/vapi/colord.vapi
223 %endif
This page took 0.080826 seconds and 4 git commands to generate.